Vegas 8.0b - Crashes

mdopp wrote on 1/15/2008, 10:05 PM
Took me just 5 minutes to discover the first problem in Vegas 8.0b...
I have a HDV project (1080i25) with some animated maps in progressive SD format (576p25). When I render to AVC-HD (for blu-ray, i.e. 1440x1080i25) Vegas 8.0b crashes ("MS C++ library - Runtime Error") as soon as the process hits the sd clip. Vegas 8.0a "just" stalled at the same place.
BTW, rendering to WMV is working nicely with the same project.


DJPadre wrote on 1/15/2008, 10:14 PM
did u send this to the error report link?

no point positng it here aside from general troubleshooting.. but toi get it fixed, send it to the support ppl
PeterWright wrote on 1/15/2008, 11:54 PM
I also had an SD project I created yesterday - today updated to 8.0b and Vegas wouldn't open it. Error message, something to do with zero integers ....

Used System Restore to go back to yesterday and 8.0a, and the same project opens fine.

Another previous project, with EX1 HD footage opened fine in 8.0b after the update.

I guess I'd better do the right thing - reinstal the update to 8.0b, try again and copy the error message, paste it into Word, transfer it to Internet PC and send to Support, filling in all those Support field questions even though I already have a user profile, then do another Sysytem restore back to 8.0a so I can work on the project ..... whatever happened to the easy life?

p.s. sorry about the smell of burning martyr!

Grazie wrote on 1/16/2008, 12:00 AM
Hi Pete - I've been openning "a" into "b" without issue problem. But only SD projects here. No HD at all. Maybe that is a clue? Dunno . . ..

Grazie wrote on 1/16/2008, 12:01 AM
what IS that smell?
Marco. wrote on 1/16/2008, 12:01 AM
I tried to repro but I can't. I took some of my HDV 1080i25 stuff and put additional 576p25 in it. Once just as a cut once as composition. Both worked fine as AVCHD render.

More infos about what exactly you do in your project and what kind of files that are?

PeterWright wrote on 1/16/2008, 12:27 AM
The problem project is actually mpg footage from a Chinese VCD which I am converting to DVD.

It still works fine in 8.0a but in 8.0b, after displaying the clips on the Timeline, the error message appears. One strange thing is that if I click outside the error message, the Timeline plays normally, although the waveforms for the last three clips do not draw - bottom left box says "0% (18 of 26) Building peaks ...." but nothing happens, it stays at 0% so that may be a clue ...

Even though the Timeline plays ok, including the audio from the undrawn waveforms, as soon as I restore the Error message from the task bar and either click on "OK" or the "X" in the top right corner, Vegas closes and disappears.

Anyway, I've written to Support about it, and I have a workaround, called 8.0a.
rmack350 wrote on 1/16/2008, 8:31 AM
I hear your pain about the support page being so cumbersome. It's awful!

I filed a complaint about it on that very same page, but I'm sure it got thrown out.

DJPadre wrote on 1/16/2008, 8:49 AM
Pete that issue your seeing with the continuation of vegas over that "glitch" is usually a software plugin.. Vegas and the codecs in question are usually ok, but vegas sometimes flakes out with plugins... which is wierd considering Soundforg is driven by its plugin architecture..

i get these all the time when i use certain audio DX plugins or VST plugins and even when i use Satish or 3rd party filters or the Plugin Pack to run Vdub filters in Vegas, i get them..

And this is on V7...

Its come to a point that depsite the evolution of render times, the application itself requries a major rebuild. I mean in many cases, for the most mundane elements, Vegas does seem to expereince certain issues.. and this is for everyday normal usage..

as it stands, its a great product, but sadly lacking in afew departments...
PeterWright wrote on 1/16/2008, 4:18 PM
Thanks DJP - this project uses no plug-ins. I've tracked it down to a particular mpg clip from a VCD which has audio that 8.0b will not accept. It behaves fine in 8.0a and Version 7, but not the new update.

As it happens, I'd already rendered the clip to Video and Audio streams for a DVD, so hopefully I won't need to revisit that project, but there's obviously some difference between 8.0a and 8.0b that needs checking.
DGates wrote on 1/16/2008, 9:53 PM
...Its come to a point that despite the evolution of render times, the application itself requries a major rebuild. I mean in many cases, for the most mundane elements, Vegas does seem to experience certain issues.. and this is for everyday normal usage..

Vegas 8 was probably the one I was most psyched about once I played with the trial. But I haven't bought it yet, and won't until version 8d.

mdopp wrote on 1/17/2008, 10:14 AM
Actually I have reported the problem to Sony support two weeks ago and just a few hours ago they came back to me and suggested I'd better give them a call.

My problems with Vegas 8 are just related to Sony's AVC encoder. I can edit the project nicely without crashes but I can't render it to AVCHD (wmv works fine).

Yesterday I have replaced the SD clips by m2t HDV clips. Now rendering of these clips works - BUT Vegas still crashes during the render process randomly after some hours of work. This happens irregularly at various points in the project. Maybe I'll try to render 2.0 instead of 5.1 sound next to reduce complexity.

BTW, it's not a problem of my PC. I've been rendering other projects to wmv or m2t for over 100 hours several times without any issues.
DJPadre wrote on 1/17/2008, 1:13 PM
"Vegas 8 was probably the one I was most psyched about once I played with the trial. But I haven't bought it yet, and won't until version 8d. "

Its for this (among other) reasons why i have multiple workstations. This main unit only runs 100% rock solid SW. I wont risk testing on this machine, depsite the setup.
As it stands, weve got V8b on the laptop and it does SEEM stable, but we havnt pushed it.
There are many problems i find with it, but stability is not one of them... so far

Then again weve only pushed V8 during rendering and testing, and not actual project as I wont risk wasting that produciton time then to have it die on me

Darren Powell wrote on 1/17/2008, 8:21 PM
Yep, welcome to the Vegas Pro 8.0 (yes, I'm using b now) nightmare ... I'm still trying to render a sequence of Cineform files and m2t's ... it's crap crap crap crap crap.

Much worse on my Quadcore box (won't render at all) have gone back to my Dual Xeon and at least I can render portions of the project on that machine and stitch them all together on the Quad ... not sure what to do after that ... I'm just hoping that Vegas renders the project if everything on the timeline is just one type of file ... ie: m2t.

Good luck!

Darren Powell
Sydney Australia
Kim Nance wrote on 1/18/2008, 1:30 AM
My client supplied camera DVD's which I attempted to load into version 8.0 Lots of crashes. Updated to 8.0b, no change. Figured it might be a problem with the MPEG camera files, and so attempted to render the small amount that was stable to another format. Some codecs crashed immediately, others after a short time, none successful.

In desperation, tried loading the same camera files into Vegas 7d. No problem whatsoever.

The only 'no standard' part of my install, is that I am still using DVD Architect 3.0c - I've had no reason to update it. Could this be the problem?


Kim Nance
Armadillo Post
Melbourne Australia
mdopp wrote on 1/19/2008, 7:04 AM
I have trapped the problem now:

First I tried to render to mp4 instead of m2ts - still using the Sony AVC codec.
Result: Vegas crashed immediately - during the first frame !

Next I tried to render to mp4, but this time using the Mainconcept codec.
Result: No problems at all. Vegas runs smoothly through the project. It's slow (more than 24 hours for 30 mins of video) but it works.

Finally I tried to free up some memory by removing all unused clips from the media pool (my machine has 2 GB RAM).
That brought me down from 2119 clips to 767 clips (the project spans over 13 HDV tapes ;-).
Opening the project now takes 3:40 mins (it was almost 15 mins before).
Again I tried to render to m2ts (AVCHD) using the Sony AVC codec.
Guess what: It worked !
Obviously there is a memory handling problem in the AVC codec that pops up when a huge amount of clips are active.

BTW, this was my only problem in Vegas Pro 8. Editing the project (again: 13 HDV tapes) was smooth and without any issues. I am still very happy with the software.