Vegas and Acid 4.0 render problem

Terpsichore wrote on 2/13/2004, 9:29 AM
I'm reposting this as a new thread since I'm not sure anyone saw it at the bottom of the old thread. I'm experiencing slight audio crackling on render from either 4.0 app, and I believe I also see this on record into Acid. Not sure about record into Vegas. Here's the details:

It occurs from Vegas 4.0e, from from Acid 4.0f, but not from Vegas 3.0 build 76. Here's how I can reliably reproduce it:

In Sound Forge 6.0, create a new 44.1/16 stereo file. Insert 20-30sec of silence. Then adjust the DC offset to something easily visible like 10000. Save as the test file. Open Vegas 4.0, create a new 44.1/16 project. (not sure if this matters)

Open the test file onto track. I didn't touch or add
any effects. Make sure all levels including master buss are 0dB and render to new file. Open in SF6.0 and playback. Other
than the initial click which is expected, there should be silence. Instead, I see slight crackles on the right channel only.

They appear as single sample depressions below the correct DC level. Barely visible but audible. Same thing happens in Acid when the track is set to beatmap. When set to one-shot, the depressions go all the way to zero, so are much more audible and visible. Again only right channel. I had to run the beatmapped test twice, the first time I didn't get the problem, but the
second render did. But previously I saw depressions all the way to zero from a beatmapped render. In all of my cases so far the beatmap and project tempos are exactly the same.

p.s. the reason I did this with a DC offset (silence) is that inspecting my original problem track which was rendered piano (beatmapped), I heard the crackles but had a hard time finding them. Once I did, they were one sample depressions to zero from either north or south. So the DC makes it much easier to see and hear.

Sony, can you reproduce it? Anyone else getting this kind of behavior?


SonyMLogan wrote on 2/13/2004, 10:58 AM

No, I cannot repro given the steps you outline with vegas 4.0e (bulid 239) with a clean set of prefs. Here's what I did:

Create a 44100/16/stereo wav file, about 50 seconds long in forge 7.0.

start vegas (with Shift+Ctrl held down to clean my prefs).

create a new 44.1/16 project.

Render As... to a new wave file.

Open the rendered file in forge 7, strip DC offset, normalize/ Play.

** I see and hear no depressions/clicks in the signal.

Are there other settings required?
Rednroll wrote on 2/13/2004, 3:13 PM
I tried to repro this one also and couldn't find anything wrong. I even did a "Statistics" in Sound Forge on the final render and it showed the minimum and maximum sample values at 10,000, so no drop outs. It sounds like there is probably something causing an interupt during the render from Vegas/Acid. See if there's anything running in the background by hitting Cntrol+Alt+Delete, and shutdown any unnecessary programs running including virus protection software. You might want to check to see if anything is sharing any IRQ's and temporarily disable the hardware that is sharing an IRQ possibly with your hard drives, or video card and see if you get the same problem.
Cudgel wrote on 3/1/2004, 8:25 AM
I always defrag when I run into problems like this. Usually it helps.
cosmo wrote on 3/1/2004, 8:28 AM
Yuck. But I do the same only I reformat(only the OS drive). Two hours later I'm ready to go again and it usually fixes those really strange problems.
Terpsichore wrote on 3/10/2004, 10:54 AM
It's been a strange ride. In short, nothing helped including a new HD and fresh OS install. And to give you an idea of the problem, it didn't show up everytime. Sometimes most of the renders were corrupt, other times it was like 3 or 4 renders out of 20. Never in Vegas 3.0 though.

So I bought a new motherboard and the problem went away!!! Same 1.8G P4 used on both, same RAM sticks, same HDs, everything the same except the motherboard. Hard to fathom that Vegas 3.0 was happy with the old board and Vegas 4.0 and Acid 4.0 weren't. But it's true.

Old board: Asus P4S533
New board: Asus P4P800