Vegas and Photoshop not working together

Marc S wrote on 3/28/2013, 3:50 PM
I am unable to save changes to my psd files in Photoshop CS 5.5 without shutting down Vegas if the psd file is on the Vegas timeline. I have the preferences set up in Vegas to let go of files when using in other programs. This works fine in Vegas 10.

Something is wrong with Vegas 12 not letting go of files properly. I filed a ticket.

Comments

ECB wrote on 3/28/2013, 5:01 PM
Mark,

I just tried your same conditions with PS CS6 and got the same results. As a work-around, if I minimized Vegas before starting PS CS6 I could save the modified PSD file.

ed
Marc S wrote on 3/28/2013, 5:46 PM
Thanks for confirming that. If possible please file a ticket. I'll try the minimizing work around but usually the way I work is back forth between photoshop and Vegas. I'm also experiencing strange issues with Sound Forge 9 and Vegas 12. I usually have to close SF after returning to Vegas in order for Vegas to recognize the audio changes.
risce1 wrote on 6/19/2013, 4:41 PM
this is a pain... i have to close vegas completely..no problem in vegas 10..just with 12 and cs5
DavidMcKnight wrote on 6/19/2013, 5:25 PM
I'm not in front of Vegas at the moment, but isn't there a setting in Options / Preferences about Vegas releasing files? I don't remember what it's called or what to look for, but I seem to recall there's a setting like this. Maybe it's set differently in 12 than in your other versions?

Or it could be a bug, there's always that....
ritsmer wrote on 6/20/2013, 1:35 AM
It is your own choice:

Preferences, General : ( ) Close media files when not the active application.
Grazie wrote on 6/20/2013, 1:41 AM
Something is wrong with Vegas 12 not letting go of files properly.

I have this working fine in Corel>PSD File import to VP12 and then alter in Corel then Save. I am using the Open in Graphics Editor script by Rosebud. Holding together here.

Could it be a PS thingie?

Cheers

G

risce1 wrote on 6/20/2013, 7:30 AM
...........Preferences, General : ( ) Close media files when not the active application.


no working here...works in 10 not 12







Lovelight wrote on 6/20/2013, 1:25 PM
Sorry to be no help, but V12 & photoshop work on my system. I use the open in image editor script with V12 & PS & it just works. Hopefully, that gives you hope in fixing this problem.
rs170a wrote on 6/21/2013, 7:29 AM
It works for me in Pro 12 too. I find that sometimes I have to switch back to Vegas and take focus off of the event that I opened in Photoshop (click anywhere else) but otherwise it's fine.

Mike
cold ones wrote on 6/21/2013, 12:25 PM
I'll throw in my 2 cents---I don't usually select the "Close Media Files" option because (if the files within Vegas aren't changing) it can dramatically slow down the time Vegas gets ready to work when you click off and back to it. But when I do, and if I'm using Photoshop to fiddle with a graphic, quite often during the switch between Vegas & Photoshop the file becomes marked as busy elsewhere and unable to be saved. Once the file becomes marked this way, I usually quit Vegas, then open Task Manager.

In Task Manager I can see whether or not Vegas is still running and exerting control over the file. Vegas can appear in the Processes tab for a long time (45 seconds) after I close it, which can cause confusion in "ownership" of files. This behavior seems to compound when I open multiple instances of Vegas---usually one of them crashes, which doesn't help matters either.
Marc S wrote on 6/24/2013, 9:31 AM
I thought this was fixed in the latest version but it's not. Sometimes it works but most of the time it does not. Please file a bug report with Sony if you're having this issue.
Grazie wrote on 6/25/2013, 2:01 AM
OK . . . I've got an anomaly that I don't remember happening before: I can now no longer treat the separate "layers" now Event on its own Tracks with any movement like Rotation in either Pan/Crop or Track Motion. I defintiely could before. Also changing the "layer" in Vegas breaks the link back into Corel.

Yup, I got it now.

Here's a (yes, badly rendered from me, from my WMP file) multi-layered PSD (PSP<>Vegas) I did in previous version of VP. And this worked.......



PeterWright wrote on 6/25/2013, 3:11 AM
That's great Grazie - sorry it's not yet working in V12.

I hadn't realised how effective this is as a way of animating the layers of a still and finishing with the still Logo - a multi level transition.
Grazie wrote on 6/25/2013, 4:51 AM
Thank you Peter.

It's a great Creative way to utilize Vegas. This plus using the Compositing Layers. When this came avaible for Vegas I really saw an opportunity to treat Vector layer in VP as I would in Corel<>PSD.

I hope the engineers can reclaim the territory around this.

Grazie

VMP wrote on 6/25/2013, 12:02 PM
@ Grazie

Love the music.
What is it?
Grazie wrote on 6/25/2013, 12:10 PM
Ah man, my brain hurtz . . . one of my Royalty Free vendors? OR it could have been a Cinescore slap?

G

Grazie wrote on 6/25/2013, 12:21 PM
I sent my results on this issue to SCS. I hope that helps them.

Cheers

Grazie

VMP wrote on 6/25/2013, 3:02 PM
Ok Grazie :-D. No title on the track eh?
Grazie wrote on 6/25/2013, 3:50 PM
No title on the track eh?

Let me "investigate".

G

VMP wrote on 6/25/2013, 6:54 PM
Thanks :-D.
Marc S wrote on 8/14/2013, 6:56 PM
Just had another round with tech support and they have confirmed the issue.

Hi Marc,

Thank you for writing back. The developer I have been working with has responded saying that this is a known issue and that it has been submitted to be fixed in a future release of the application. Apologies for the inconvenience and be sure to keep an eye out for future updates.
set wrote on 8/14/2013, 7:59 PM
Instead, temporarily export per required layers to different files of PNGs.

Add:
Small graphic 'animation' created with PNG layers.
https://www.dropbox.com/s/1zzcgibc5mhn7k7/AdeElen_OpeningChapterIntro.mp4