Vegas Audio Synch Trouble

shnosh wrote on 2/6/2004, 6:45 AM
I am running Vegas 4.0 on a P4 2.8 with 512 of Ram and every time I record, the track I am recording is like a half second off from the playback I was listening to while recording when I play it back. The audio is not skipping during recording but when I play it back, the track I just recorded is off. I then have to go in and re-synch the track and that gets very annoying.

Anyone have this same problem? Anyone know a fix?

Thanks for any help you all might have.


Sari wrote on 2/6/2004, 7:02 AM
Update to the latest version.
shnosh wrote on 2/6/2004, 8:37 AM
I think that I do have the latest version. I was running the previous version before I updated to Vegas 4.0 and I never had any problems.

Is there a new patch that came out for it? Is this a known bug?
shnosh wrote on 2/6/2004, 11:27 AM
Is there no one out there that can be my hero and help me out here?

Please, someone help.

SonyEPM wrote on 2/6/2004, 1:36 PM
what soundcard are you using?
shnosh wrote on 2/6/2004, 3:54 PM
Not Sure. SoundMAX? Does that sound right?

It is what ever comes standard on the Sony Vaio P4 2.8 computers.

Does that help?
pwppch wrote on 2/7/2004, 1:21 PM
By latest version, you need to get the latest update.

There was a problem in the original release of 4.0 where input would not be correctly lined up with some audio hardware. The manual overrides for this were also not working as expected.

However, with audio hardware like you have, the input and output will NEVER be completely in-sync with each other. Why? Because the drivers don't support synchronous input/output. What happens is that the playback and input stream are started asynchronously cause a slight delay to occur. The updated version of Vegas 4 attempts to auto correct this delay. (Vegas 3 also had this, but it got 'broken' in the initial release of Vegas 4.0).

Anyway, make sure you have downloaded and correctly installed the latest update available on this web site. Try the auto adjust mode (the default) first. If that does not solve your problem, then turn off auto mode, make a small recording of the output to the input. Record something with a very distinct transiant so you can then measure the exact offset in ms and then use this number in the audio devices prefs page.

shnosh wrote on 2/7/2004, 3:30 PM
I got the latest version and it works great now... Thank You!