Vegas crashing with Boris FX Filter

Yep wrote on 1/10/2016, 6:35 PM
I recently installed Boris FX Time unit plugins and have started having problems rendering my Vegas Projects. I have the Boris Optical Flow filter applied to a number of clips in a project to slow them down. Rendering starts fine but Vegas crashes just as it reaches the first clip with the optical flow applied.

I filled in the automated problem report and got a message telling me to update to the latest version of Vegas Pro 13. I did that and it seemed to solve the problem. I was able to render several projects all of which had the optical flow applied to a number of clips in the timeline.

However, now the problem is back with a vengance. The details listed in the automated problem report when Vegas crashes are as follows:


Problem Description
Application Name: Vegas Pro
Application Version: Version 13.0 (Build 453) 64-bit
Problem: Unmanaged Exception (0xc00000fd)
Fault Module: C:\Program Files\Boris FX, Inc\Lib\BCC OFX Vegas 9\BCC9_OFXVegas_8Bit.dll
Fault Address: 0x000007FEBEB33287
Fault Offset: 0x0000000000A03287

Fault Process Details
Process Path: C:\Program Files\Sony\Vegas Pro 13.0\vegas130.exe
Process Version: Version 13.0 (Build 453) 64-bit
Process Description: Vegas Pro
Process Image Date: 2015-06-05 (Fri Jun 05) 16:53:04

From the above, and the fact that Vegas crashes just before it gets to a clip with a Boris filter applied, the problem would appear to be with the Boris plugin. Strangely, if I select a loop region of the problem clip and some normal video on each side it will render the loop region without any problem. It is only when I try to render the entire project that Vegas crashes. It is also worth mentioning that all of the projects I've had problems with will render without any problems if I remove the Boris filter.

Things I've tried:

1. Updating Vegas Pro to latest build.
2. Updating my video card drivers.
3. Turning off the "Enable GPU" setting in Boris FX.
4. Cleaning the registry with CC Cleaner - I Googled the Unmanaged Exception (0xc00000fd) and found some info that indicated this error was often associated with mucky registries.

My machine is running Win 7 64bit Pro, Core i7 CPU @ 3.50GHz, 8 Gigs Ram, plenty of hard drive space.

I'm at my wits end - any suggestions or help would be gratefully appreciated.


Rory Cooper wrote on 1/11/2016, 1:56 AM
i had this issue with older versions.

try select all clips and disable resample

i had to render to MOV avi i could not render MP4. this is still the case with older Vegas versions
Eliksir wrote on 4/24/2016, 10:09 AM

I have the some problem today.

So, after searching, i saw that the bcc unit licence was not activated... and was in demo mode (expired)... So check the BCC filter properties used and click on 'Register', perhaps it will ask you for the licence code.

For me is the problem now solved after registring the bcc units.

Sorry for my poor english.

Editor : VegasPro Edit 13.0 build 453 64-bit / W10 Pro