Vegas edit 15 double image at 200%

David-Purdy wrote on 5/15/2019, 4:37 PM

I'm getting double images in the video when moving the velocity or stretching a clip to 200% speed.

I'm trying to overcome a limitation, my computer being slow.

I shot 120fps gopro video and converted it to prores 60 fps by slowing it down 50% and rendering.

This makes editing much easier with my computer but, when I preview, or render the clip speed back up (200%) I see a double image in the frame. I also don't see the frame markers.

Any help would be appreciated.

 

Comments

fr0sty wrote on 5/15/2019, 4:54 PM

You're going about it the wrong way. That Gopro 120fps video plays back at a slower frame rate, so you don't have to change the frame rate of the video when converting it. It captures 120 frames per second, but it stores those frames at 24/30/60 frames per second (not sure which, but my GH5 lets me select between 24p and 30p). This is why when it is played back, those 120 frames are in slow motion, it takes 2-3 seconds to play them all. So, figure out what the frame rate of the video is from that gopro, not the rate it was captured at, and then encode to magix intermediate/prores from there at that frame rate.

Edit: A quick youtube search shows 1080p 24fps is what the camera stores the 120fps video at, so try to set your frame rate to 24 or 23.97 and see how it turns out. That, or you could just tell it to match the source frame rate in the encode settings.

David-Purdy wrote on 5/15/2019, 5:04 PM

Actually, the gopro 120 fps video does not play back at a slower frame rate on video viewer or inside vegas edit.

When I look at the properties of the video in the file manager or when it is imported into vegas, it is 120 fps.

David-Purdy wrote on 5/15/2019, 5:05 PM

I do tell it to match the source frame rate of the video on import and vegas sets the frame rate to 120 fps

 

fr0sty wrote on 5/15/2019, 5:05 PM

Also, because the gopro is actually recording those 120 frames it captured across 5 seconds of 24 frames each, it isn't the frame rate that is bogging your system down, it is the codec that GoPro uses that is requiring too much CPU/GPU power to decode, for future reference. HEVC is one such codec that usually edits very poorly, but captures great quality at low file sizes, which is why so many cameras use it. Some AVC formats decode poorly in Vegas as well, I had Hero 3 footage I couldn't edit smoothly until I bought a Radeon 7 GPU to help decode it. As such, a simple format conversion without touching the frame rate or pixel count can work wonders, or you can use Vegas' built in proxy system, or Happy Otter Scripts' Import assist or proxy system to convert the files either to intermediates or proxies that will be swapped out with the original file(s) when you go to render.

fr0sty wrote on 5/15/2019, 5:07 PM

Didn't see your replies, that is interesting. Try setting the frame rate to 24p, there may be metadata in the file that is incorrectly triggering Vegas to think it is a 120fps file.

fr0sty wrote on 5/15/2019, 5:08 PM

Also, can you upload a sample file for me to check out to google drive or something similar?

David-Purdy wrote on 5/15/2019, 5:13 PM

but it is 120 fps, vegas is correct, and yes, the compression is hard to deal with for my poor computer so I am converting to a something that the computer will handle when editing but magix prores will not do 120 fps so I slowed everything down and output at 60 fps.

Everything comes out at 50% velocity as it should but when I go back to 100% velocity by increasing the velocity to 200% for the clip I get the double image.

I thought there was perhaps a switch in the preferences or some other trick I was missing that get rid of the double and sometimes triple images

Perhaps I should try AVC which will output 120 or really 119 and change.

Kinvermark wrote on 5/15/2019, 5:34 PM

Wow, talk about some frame rate mental "backflips" going on here. :)

120 fps is intended for slow motion. You don't need to render to 60 fps to "help out" your computer, you just need to play it back at normal speed. In this case 120 is evenly divisable by 24, and so your timeline should be 24p. Playback should be a nice slowmo. If for some reason Vegas is setting your footage and project at 120, then manually set the project to 24p, and set the playback rate in the timeline event so it is also 24p (ie 0.2)

 

Kinvermark wrote on 5/15/2019, 5:38 PM

Just tried your download. Works great. Nice slow kite surfing. Cool ! Note that there probably is a metadata issue as frosty said, as it plays back too fast in windows desktop media player as well.

Kinvermark wrote on 5/15/2019, 5:44 PM

BTW, also turn resample off.

David-Purdy wrote on 5/15/2019, 6:53 PM

resample off that worked thanks!

 

fr0sty wrote on 5/15/2019, 9:25 PM

The file isn't supposed to play back at 120fps, that's the issue here, it's got improper metadata telling the player (or Vegas in this case) that it was encoded at, not just recorded at, 120fps. It's supposed to be recorded at 120, encoded at 24, so when playing back it plays in slomo. The problem with Saving it at 60fps is, you are taking what should be a 24p file and converting it to 60, which is going to reduce quality for you because you can't evenly divide 60 by 24, and frames will have to be interpolated. You want to make sure the prores file is at 24 frames per second to get the best quality.

To make sure it works right, disable resample, then make a 24 frame per second prores out of the original 120fps video. You say disabling resample along fixed it, but if you are still using a 60fps prores file, you're not getting proper frame rate conversion and the quality could be better.

David-Purdy wrote on 5/16/2019, 5:24 AM

I disagree, the gopro is recorded at 120fps and tagged at 120 fps and so plays normally. Just like 60 fps or 240 fps or 24 fps or 25 fps or 30 fps all play at normal speed

that is what is meant to do -- that is what it does with media players, vegas, and gopro's own apps

it might be different with your panasonic gh5 which i believe is tagged at 24p regardless of the frame rate it is recorded? so anything shot at above that will play in slow motion

I don't think either one has 'wrong' metadata

when the gopro video comes into vegas the project is set to 120 fps. If you slow it down in half 50% and output at 60 fps you get every frame output and it plays at half speed because you have effectively changed the tag

if you want to convert to 24p, you would slow it down to 20% and render to 24p you would get every frame and it would play at 1/5 speed

try it, i have a link to my video

 

Marco. wrote on 5/16/2019, 6:29 AM

The clip you linked above actually is 119,88 fps. Is this particular clip shown as 120 fps or as 119,88 on your system? Here both Vegas Pro 15 and 16 treat it as 119,88 (just what it is).

David-Purdy wrote on 5/16/2019, 9:16 AM

Yes it is 119.88 and i used prores 59.94. That is what it is. GoPro calls is 120fps in their menu. It is a bit tiresome to write 119.88.

It is h.264 encoded at approximately 67mbits per second

 

Eagle Six wrote on 5/16/2019, 9:58 AM

@David-Purdy is this what you are trying to achieve?

System Specs......
Corsair Obsidian Series 450D ATX Mid Tower
Asus X99-A II LGA 2011-v3, Intel X99 SATA 6 Gb/s USB 3.1/3.0 ATX Intel Motherboard
Intel Core i7-6800K 15M Broadwell-E, 6 core 3.4 GHz LGA 2011-v3 (overclocked 20%)
64GB Corsair Vengeance LPX DDR4 3200
Corsair Hydro Series H110i GTX 280mm Extreme Performance Liquid CPU Cooler
MSI Radeon R9 390 DirectX 12 8GB Video Card
Corsair RMx Series RM750X 740W 80 Plus Gold power pack
Samsung 970 EVO NVMe M.2 boot drive
Corsair Neutron XT 2.5 480GB SATA III SSD - video work drive
Western Digitial 1TB 7200 RPM SATA - video work drive
Western Digital Black 6TB 7200 RPM SATA 6Bb/s 128MB Cache 3.5 data drive

Bluray Disc burner drive
2x 1080p monitors
Microsoft Window 10 Pro
DaVinci Resolve Studio 16 pb2
SVP13, MVP15, MVP16, SMSP13, MVMS15, MVMSP15, MVMSP16

Chief24 wrote on 5/16/2019, 10:27 AM

Being the curious monkey-mate that I am, downloaded the above clip. Looks like it comes from at least the Hero 6 Black (due to file naming convention), so decided to check with my own GoPro Hero 6 Black. Set it at 1920x1080 and 120 fps and recorded my ugly mug for about 6 minutes just playing around. Brought the file onto my computer (i7-6800K, MSI X99A Gaming 7, 32GB 2400MHz, Win 10 Pro 64-Bit "1809", RTX 2070 FE), opened up MediaInfo, and with exception of length, got the same reported information from my file as well.

So, put the video (mine) onto a Movie Studio Platinum Suite 16 (Bld. 109), set my project properties to 1080p24, and added the clip, without matching clip to project. Clip inserted fine with no proxy or intermediate, and played fine as if I was watching any other clip. Disabled Resample. Then, shortened down to a 30 second clip, changed the Video Speed in the Media Properties from "1.000" to "0.200", and it definitely slowed the video down, with no affect to Audio, as expected.

Both files from MediaInfo showed what David-Purdy recorded of 119.880 fps, and as I said, all the file info from his camera and mine matched (except length, naturally). The "file info" shown at the bottom of the Media or Project tabs, also shows the clip properties per what MediaInfo gives as well.

Now, why transcode it to prores 59.94, I can't answer that. Possibly his computer system specs, slow drive, old processor, maybe a laptop? I would think use the Vegas Pro/Movie Studio built in proxy, or transcode to a much more friendly .avi container, by using MagicYUV, Grass Valley HQ, or even Cineform. Just throw that/those clips on a timeline, don't do anything, render out to VideoForWindows and change to one of the above codecs. I purposely did not install the Quicktime Player crap this time around, as I wanted to see if Movie Studio 16 would open my .MOV Canon 80D files natively (though, I did install the Avid DNxHD/HR 2.73 LE codecs). That way, you have the "Full" 120 fps at your disposal, and not some interpolated setting, until you do it.

Oh, and if you don't use Happy Otter Scripts (HOS) for Vegas Pro, you can use DaVinci Resolve Basic (lacks VfW codecs though), or the ER Media Toolkit recommended by @Eagle Six. Just do a search in the forum for it. Or, as I tend to recommend a lot, go to the MovieStudioZen website (Derek Moran, a.k.a. Dr. Zen) has a couple of tutorials for transcoding to Cineform (GoPros' still work great with it) and DNxHD/DNxHR. Plus, peruse his site...he's got some other great Tutorials for both Pro and Movie Studio.

p.s. Dang-nabbit! Just remembered I had not tried that with my Canon. So, just did, and it worked! Yeah!

Self Build: MSI X399 Gaming Pro Carbon AC/1950X @ stock; 64GB Corsair 2666 Mhz; OS-Intel 750 800GB, Project Media-Samsung 960 EVO 1TB; (3) Samsung 850 EVO 500GB SSD for various (LightRoom & Photoshop), Render, Other Assets; Sapphire AMD Radeon VII; Vizio D43-F1 3840x2160 (TV); Windows 10 Pro 64-Bit (1809); (2) Intel 660p 2TB PCI-e on Asus Quad M.2x16; Magix Vegas Pro 15 Suite (416), Magix Movie Studio Platinum 15 Suite (157); Canon EOS 80D; GoPro Hero 5+ & 6 Black; Sony FDR AX-53 HandyCam; Sound Forge Studio 12.6; Creative SoundBlaster Zx sound card; Magix Music Maker Premium 2019

Kinvermark wrote on 5/16/2019, 10:45 AM

@David-Purdy I don't think you've quite got your head around this yet...

You don't want to work in Vegas (or any other NLE) at 120 fps or 240 fps. - performance killer for no reason / benefit. 60 fps might give you the "hyper real" look, depending on the footage. Just set to a normal deliverable frame rate of 24,30, maybe 60 fps, then let Vegas drop frames not needed. Imagine working on a mixed timeline with other 24 fps video or stills. They would all have to be up-sampled to 120 or 240 fps. That's not going to work well.

The clip does not play back properly in Windows movies & TV player - looks like timelapse (too fast) rather than slow motion.

 

 

 

David-Purdy wrote on 5/16/2019, 11:53 AM

@David-Purdy is this what you are trying to achieve?

No.

David-Purdy wrote on 5/16/2019, 12:07 PM

 

Now, why transcode it to prores 59.94, I can't answer that. Possibly his computer system specs, slow drive, old processor, maybe a laptop?

Exactly, page 1, but oddly my newer dell laptop handles the video fine. So I can just bring it in and edit directly without much pain

looks like my desktop needs an update.

ive done CineForm before and other things. I’ve had good luck with magix prores on my slow computer and I don’t have to scurry around downloading other tools.

David-Purdy wrote on 5/16/2019, 12:19 PM

@David-Purdy I don't think you've quite got your head around this yet...

You don't want to work in Vegas (or any other NLE) at 120 fps or 240 fps. - performance killer for no reason / benefit. 60 fps might give you the "hyper real" look, depending on the footage. Just set to a normal deliverable frame rate of 24,30, maybe 60 fps, then let Vegas drop frames not needed. Imagine working on a mixed timeline with other 24 fps video or stills. They would all have to be up-sampled to 120 or 240 fps. That's not going to work well.

The clip does not play back properly in Windows movies & TV player - looks like timelapse (too fast) rather than slow motion.

 

 

 

Actually it plays fine in windows 10 movies and tv, iPads, etc. it plays at normal speed like it should if it’s choppy, you might need a new computer.

vegas is fine with 120 FPS.

I did not know the resample switch. Perfect answer.

 

 

Chief24 wrote on 5/16/2019, 12:24 PM

O.K., no sense being made here. There is no mention of your current desktop, or laptop in your signature; and you have not provided any information about either.

People are trying to assist you in your endeavors, but you seem to continue to provide "negative" feedback.

A video was quickly provided utilizing the clip you provided, not what you wanted (Is this what you are trying to achieve? No.), with no feedback provided on what you do want to achieve.

So, as an extremely sarcastic, and quite impatient person, who will only assist to a certain degree before not providing any further commenting (as to not heighten a quick temper), and seeing all the provided help currently offered just completely ignored...

...bye.

Self Build: MSI X399 Gaming Pro Carbon AC/1950X @ stock; 64GB Corsair 2666 Mhz; OS-Intel 750 800GB, Project Media-Samsung 960 EVO 1TB; (3) Samsung 850 EVO 500GB SSD for various (LightRoom & Photoshop), Render, Other Assets; Sapphire AMD Radeon VII; Vizio D43-F1 3840x2160 (TV); Windows 10 Pro 64-Bit (1809); (2) Intel 660p 2TB PCI-e on Asus Quad M.2x16; Magix Vegas Pro 15 Suite (416), Magix Movie Studio Platinum 15 Suite (157); Canon EOS 80D; GoPro Hero 5+ & 6 Black; Sony FDR AX-53 HandyCam; Sound Forge Studio 12.6; Creative SoundBlaster Zx sound card; Magix Music Maker Premium 2019

Marco. wrote on 5/16/2019, 12:53 PM

I don't take it as negative feedback. I think the problem is solved, isn't it? Due to low playback performance David-Purdy rendered an 59,94 fps intermediate from the 119,88 fps source file. In the beginning the problem was the resampling which generated "ghost" frames. Resampling turned off, problem solved. Right?