Vegas, .m2ts files & Vista 64

Whitlam wrote on 9/2/2008, 9:16 AM
I understand that Sony Media don’t support Vista 64 – but until now I’ve been using Vista 64 & Vegas 8 Pro very happily with video from my Canon HV-20 (.m2t files). No problems at all.

Recently I bought a Sony SR12E video camera and these have been my experiences in trying to get either Vegas 8 Pro or Vegas Movie Studio Platinum 9 to work with .m2ts video files.

Vegas 8 Pro (pre installation of the beta.dll) - I could edit & render .m2ts video clips - however with any rendered video over 1 min (or so), the video track couldn’t be read by Vegas. Opening the file in Vegas – the sound track was there, but no video track.

The video file however was perfectly ok, and would play in WMP – both video and sound. I could open the file in VMS 9 and both the video and sound tracks opened.

Post installation of the beta .dll, Vegas was finally able to open both video and sound tracks of rendered files. However, Vegas hasn’t been able to play them in preview mode – the programme freezes after a few hundred frames.

The sound plays, but the video sticks on a frame and the programme greys out. Vegas then has to be terminated.

The problems with Vegas Movie Studio 9 are a little bit different. In VMS 9 I can edit and render clips (at a full 1920 x 1080).

However, when the clips are put together into a project and a final render done, VMS 9 shuts down around 10% of the way through the final render.

It produces a small .m2ts file – which play perfectly – except it is only 30 – 40 seconds long.

VMS 9 can re-render an already rendered clip (i.e. a single clip) – it just can’t render several clips. I tired it out on a single 60 min video – re-rendered it without drama. Then tried it out on 7 clips totalling 4 minutes in length – it shut down 10% of the way through.

On Vista 64, neither Vegas 8 Pro nor Vegas Movie Studio 9 are able to successfully edit & render video from one Sony’s own cameras !

Until this is fixed, I’m going to have to look elsewhere for software that can actually work with .m2ts files.

Not been a good experience.


Christian de Godzinsky wrote on 9/2/2008, 12:48 PM

I run Vegas Pro 8.0b on Vista x64, and import all the time files from my SR12E. I fully believe what you say that you have serious problems. I do not deny that fact - when I say my system runs without any problems and renders even two hour long projects with ease.

To be able to try to figure out what's the root of your problems - please fill in the system specs in your profile... With the info you have provided - it is impossible to help you...

Your CPU really works HARD with those-m2ts files, that means lots of heat... Probably you have no other apps beating the CPU that hard... It just might be a HW problem, after all...


WIN10 Pro 64-bit | Version 1903 | OS build 18362.535 | Studio 16.1.2 | Vegas Pro 17 b387
CPU i9-7940C 14-core @4.4GHz | 64GB DDR4@XMP3600 | ASUS X299M1
GPU 2 x GTX1080Ti (2x11G GBDDR) | 442.19 nVidia driver | Intensity Pro 4K (BlackMagic)
4x Spyder calibrated monitors (1x4K, 1xUHD, 2xHD)
SSD 500GB system | 2x1TB HD | Internal 4x1TB HD's @RAID10 | Raid1 HDD array via 1Gb ethernet
Steinberg UR2 USB audio Interface (24bit/192kHz)
ShuttlePro2 controller

blink3times wrote on 9/2/2008, 3:55 PM
- however with any rendered video over 1 min (or so), the video track couldn’t be read by Vegas. Opening the file in Vegas – the sound track was there, but no video track.

This is a little bug that has been noted by several people now. The file works fine in Pinnacle, Nero, Ulead, and all of the players.... but import to Vegas and you're left with audio but no video.

It doesn't just happen with the odd sr12, and it's not even restricted to files from cams. This happened to me while trying to import an avchd file that was just rendered by Vegas. Hopefully they'll do something about this, but in the mean time Ulead MF6 will work for you.
JJKizak wrote on 9/3/2008, 6:17 AM
Someone a while back in a previous thread had three of these files that I downloaded and put on the V8.0b timeline in Vista 64 and they all worked fine.
blink3times wrote on 9/3/2008, 6:41 AM
and then I had a file that worked on my 64 machine and not on my 32 machine.... then another one that worked on my 32 machine and not on my 64 machine.

There is however one thing all these files had in common is that they ALL worked in other NLE's. The situation was (and is) only unstable with Vegas.