Vegas on iMac - anyone?

mtntvguy wrote on 9/23/2009, 4:42 PM
I posted this question about 9 or 10 months ago, but never got a resolution to the problem. I'm hoping someone using Vegas on a Mac will have come up with a solution, by now.

The issue is printing to tape. When I'm on the Mac OS side (in Final Cut) printing to tape works fine. When I'm on the Windows side, in Vegas, it doesn't. In Vegas, it "sees" and controls the camera just fine during capture; but when I try to preview via the camera or print to tape, things go wacky: In the PTT setup menu, it does not list the camera (HVR Z1U, HVR A1U, or a JVC consumer cam), and it doesn't do external preview. When I hit 'record," it starts recording but no video or audio is coming into the camera. I then have to switch off the camera to get Vegas to stop.

Apple Support says they don't support Windows applications, so they can't help. Sony Support says they don't know nothin' about no apples. It's making me nuts.

Has anyone else experienced this. If so, how'd you fix it?


Cheno wrote on 9/23/2009, 4:55 PM
I've got two MacBook Pros and a Mac Pro and all three will give me PTT. Are all your apple drivers on the Windows side updated? Have you tried using an external firewire converter and if so can you get external preview that way?

It could be a way windows sees the firewire bus but not having a iMac in front of me, I can't replicate the issue.

mtntvguy wrote on 9/23/2009, 5:14 PM

I have not updated any Apple drivers on the WIndows side. I'm not sure why I would need to, or what drivers would be involved, since I'm not on the Mac OS when I'm in Windows.

I looked on my PC and I seem to be set up identically on the Windows side of the iMac as I am on the PC, unless there's a Service Pack 2 update I missed, or something.

I have a friend who has an iMac and the PTT from Vegas works fine. But his system is running under Tiger, not Leopard. I wonder if that has anything to do with it.

I wish I could get this resolved. I really prefer Vegas (I've got Version 8) over FCP 7. But I must admit I like Apple/Mac hardware, except for Final Cut. I sure don't get why some people prefer it. Maybe they like having to render everything dozens of times, or going out of the program to do things you can just do in the timeline in Vegas.
Cheno wrote on 9/23/2009, 6:01 PM
There is an Apple update program under your installed programs in Windows. I'd suggest you run that and update the windows drivers for the apple hardware. That could be your problem. Yes, any update on the Apple side doesn't effect the windows side.

Leopard shouldn't make a difference. My guess is that's it's a driver issue.

Coursedesign wrote on 9/23/2009, 6:20 PM
Maybe they like having to render everything dozens of times

Spend $19.00 on this immediate download, it will change your world (and your render times].

Best $19 I ever spent.
mtntvguy wrote on 9/23/2009, 8:16 PM
Cheno: I tried that. No luck. The only Apple updates listed were for Quicktime, Safari and iPhone. The only thing I can think of is I have not installed SP3. I've been reluctant to do so because I've heard horror stories about it.

Course: I'll keep the book in mind; but I don't see how it will help my current issue.
Cheno wrote on 9/23/2009, 8:22 PM
SP3 shouldn't do anything but ya never know. I still run SP2.

Weird how it won't run - have you tried DMN, Creative Cow or DVinfo for advice?

Course was merely reacting in kind to your question as to why people edit in FCP and it was a great link to anyone who's wanting to learn it fast. I'm sure there was no harm meant.

mtntvguy wrote on 9/23/2009, 9:21 PM
Sigh. Apple updates didn't work, either.

I wonder if I should go ahead and install SP3. I've been afraid to because of some horror stories I've heard about what it does to Windows running under Boot Camp.
Coursedesign wrote on 9/23/2009, 10:47 PM
Bootcamp has supported SP3 for more than a year now.

I suggest you borrow your friend's "known to work" firewire cable first though.

Many firewire problems are cable-related, you gotta test that first.

This has saved me a lot of trouble with some of my Vegas machines, swapping out the cable solved the problem.

[If you were to get the SP3 update problem that I think you are fearing, this is said to be a quick solution.]

mtntvguy wrote on 9/24/2009, 9:28 AM
Course: One of the first things I tried was a different Firewire cable. Two others, actually. No joy. But remember: Vegas is controlling the camera perfectly in the capture mode. In the PTT dialog box, it "sees" a hot swapable device. But the external preview via firewire and PTT don't work. I think Vegas hates me for buying a Mac.

Ordered the book. Seriously pondering some of the plug-ins DH has, too. Thanks for the tip.
Coursedesign wrote on 9/24/2009, 11:10 AM
The next step would be SP3 then, could fix it instantly. Windows has had a lot of firewire anomalies over the years, that were fixed with updates.

Since so many other users are OK with Vegas PTT on their Macs, I think you'll end up all OK.

[Note also Option-P to preview non-RT effects without rendering, best when you choose Unlimited RT. I also love Play Around Current (the "\" key) which backs up two seconds on the timeline and plays the next four (or any other amount your choose). * DH's Big Time Code plug-in is great, but this feature is now in FCP7.]
mtntvguy wrote on 10/7/2009, 12:11 PM
Okay. So I decided to take some of your advice and install SP3. No can do. For some reason, when Boot Camp loads up the Windows side it adds a nonexistent E,F, G,H, & K drive. THe Apple support people say "yup. That's a Windows thing. They need 'em to see the Mac side." I have no idea what they're talking about. When I talk to the Windows people, they ask: "What eees wrong weeth your preenter?" But I do know that when I try to install SP3, it tries to install to the nonexistent "F" drive, which prompts a warning that there isn't enough room to install SP3 on my F drive, and by the way do I want to format the F drive now? I cannot figure out how to tell WIndows to install SP3 to the C drive where it belongs. There is no apparent option to change the drive location for installing.

All this insanity. I just want to be able to do an external preview via Firewire in Vegas, and to print to tape. Life is cruel.
wm_b wrote on 10/7/2009, 1:36 PM
How old is your imac? How old is the imac your friend has? Apple has used sketchy FW chips that caused problems for some of my audio friends with certain FW audio interfaces. An imac is basically a laptop in a monitor enclosure so you could be stuck if you have one of those oddball FW chips. Do imacs have cardslots like the Macbook pros have? Maybe an external FW card could fix your probelems.

Ask your friend what driver version his FW port is using on the windows side. Check for the same. See if you can find out any device info on the windows side. On the OSX side I can't find anything about my firewire controller except what's connected to it.

There also something fishy about the extra drives. Do you have any sort of virtual drive software like magic disk or something of that nature. Is it out of the question to reinstall? Does an imac have slots for memory cards? My dell monitor has slots on the side and sometimes I will see them even when they are empty in certain programs (those that read memory cards particularly). Have you considered windows 7 ( potentially a re-installation option).

I too was plagued by all the re-render stuff in FCP in the beginning. I was wondering how anyone got anything done. It took me a few days to figure it out but I rarely run into it now. I got one of the apple pro training books from amazon and have gone through most of it. Already knowing a fair amount about editing in vegas made it very simple. Working through that FCP book has changed the way I work in vegas. I haven't looked for one but it would have been nice to have had something like that when I started with vegas in 2005.
mtntvguy wrote on 10/7/2009, 3:51 PM
My iMac is the 2009 version. HIs is two years older.

Seriously... does anyone who uses an iMac have a similar issue, and how'd you fix it?
At least maybe I could find out how to change the install location for SP3 so it doesn't keep trying to go to the nonexistent F drive.
Coursedesign wrote on 10/7/2009, 4:30 PM
You may experience the following error when installing Windows XP Service Pack 3 (SP3) when installing on Intel iMAC using Bootcamp to run Windows XP:

The Apple Pro Training Series books are 5 out of 5, just outstanding. Diana Weynand's FCP book in this series is flat-out incredible the way you learn workflows rather than button pushing, and you learn it with real footage from popular TV shows (Monk, Leverage, etc.) as well as documentary footage from SeaWorld and interstitials from the BBC.

I wish there was a book like that for Vegas. It would really help a lot of new editors get up to speed on a professional level in the shortest time possible.

Btw, the FCP book really teaches you how to set your render settings (there are many!), so you're not getting glazed over every time you change something.
mtntvguy wrote on 10/7/2009, 7:10 PM
"There is not enough disk space on C:\WINDOWS\$NtServicePackUninstall$ to install Service Pack 3 Setup requires an additional 4 megabytes of free space or if you also want to archive the files for uninstallation. Setup requires 4 additional megabytes of free space. Free additional space on your hard disk and then try again."

This is pretty close to exactly what I get, but on mine it says drive "F" rather than C:\Windows...

There is no drive F. I can see drive F, G, H, &K in Windows Explorer, but they don't really exist. SP3 keeps trying to install to drive F. And I can't figure out how to change that.

If I do what Course suggested, will that do it?

I have been on every message board you can think of trying to fix this issue, but I keep coming up blank. Coursedesign's suggestion gave me hope, but then I noticed it doesn't say anything about an F drive.

wm_b wrote on 10/7/2009, 7:24 PM
I have to agree with you about the APS books. I didn't want to start a love-fest over another NLE or it's support materials. After I got through a few chapters I ordered the Color and Motion books too. The workflow in that book has changed the way I interface with vegas. I think I might try to adapt a few of the projects to vegas just to learn to transfer some of the process.

mtntvguy wrote on 10/7/2009, 8:15 PM
I'll give the book a try... for Final Cut. But as I said: Exterior preview and print to tape work fine on the Mac side of the iMac. It's on the Windows side where I have the issues.
wm_b wrote on 10/7/2009, 9:04 PM
What do you see if you right click My Computer, select Manage, and then Disk Drives? Do you see these other drive names? Can you open a command prompt and CD to those drive letters. If so, type Dir and see what's there. I honestly don't expect any of these things will show the mystery drives.

I am also inclined to think SP3 isn't going to hold a solution. Typically service packs have broken firewire in XP history. Also, do you have another FW device you could go "thru"? Since you can daisy chain FW devices you might get lucky.

Coursedesign wrote on 10/7/2009, 10:00 PM
I cannot figure out how to tell WIndows to install SP3 to the C drive where it belongs. There is no apparent option to change the drive location for installing.

That's what the last Registry change above does.

To be sure, Microsoft has had a hard time getting Firewire right in many versions of Windows, but XP SP3 seems to be rock solid in my experience (and that of many others).
mtntvguy wrote on 10/8/2009, 8:50 AM
Okay, I followed your suggestion to the letter and it did let SP3 install. Thank you.

But it didn't cure the problem. I can still capture and print to tape in FCP on the Mac side. I can still capture on the Windows side, but I CANNOT do an external view via firewire, or print to tape.

I've tried different cables. I've daisy-chained. I've checked, double checked and triple checked both camera and computer settings, I've bothered people in forums, at Apple Support, at Windows Support, and at Sony Sopport.

Nobody seems to know how to cure this.

I guess I'll just have to keep doing what I've been doing... taking the Vegas file over to my PC when i need to print it to tape; or just do it from FCP the Mac side. Ratzerfratz!
Cheno wrote on 10/8/2009, 9:18 AM
mtntvguy -

sorry to hear about the continued trouble -

have you tried other forums for help? there are a number of people using Vegas on macs that are not all here at this forum.


edit - just read your last post better - guess you've tried the other forums...

mtntvguy wrote on 10/8/2009, 12:37 PM
Thanks, Course. It worked to get SP3 installed, but it didn't fix the problem. Sigh.
MarkWWWW wrote on 10/9/2009, 5:45 AM
My guess is that wm-b has the right idea.

Have a look in Device Manager and see what is listed for your Firewire controller. If it says it is a TI (Texas Instruments) controller then wm-b and I are on the wrong track, but if it simply says OHCI and doesn't give a manufacturer then you have unfortunately got one of the iMacs with the Agere Firewire chip.

While the Agere Firewire controller works fine under MacOS, it causes untold problems under Windows when using Firewire for audio, and I will bet money that it is also at the root of your video problems under Bootcamp. If you have an Agere Firewire chip then see if you can borrow a Firewire Hub (such as might be built into an external harddrive) or a Firewire Repeater cable - connecting via one of these, rather than connecting directly to the iMac, has been found to solve the audio problems in and it may also help with your video problem.


PS. If you are interested in the technicalities of this (as far as it relates to the audio problems at least), have a look at the RME forums.

JohnnyRoy wrote on 10/9/2009, 11:47 AM
> ...but it didn't fix the problem. Sigh.

You might want to look into this:

Update for Windows XP (KB885222)

Brief Description
After you install Windows XP Service Pack 2, some 1394 devices (such as digital cameras that use S400 speed) may not perform as expected.

I was helping someone on the Creative Cow that couldn't get his MOTU Firewire audio device working under bootcamp and this patch fixed it for him.

I would also go into the Device Manager and disable the firewire port as a Network Adapter. This can cause problems as well and is one of the first things I do after a new Windows installation.