Vegas Pro 11: List of known and confirmed issues

A. Grandt wrote on 10/22/2011, 5:56 AM
This is a place holder thread for Vegas Pro 11 issues
The idea being that people can look in this thread before reposting known issues.

Please do not discuss issues here, once an issue have been confirmed, either by multiple users or SCS, post a brief description and a link to the thread with the actual discussion.

Suggested format of posts:
<brief one line description or title>

Issue in: <32-bit | 64-bit | both>
Severity: <ie.: cosmetic | minor | major | show-stopper >
Occurrence: <Occasional | Intermittent | Reproducible >

Reported to SCS: <yes | no>
Confirmed by SCS: <yes | no>

Thread: <Link to thread>

<detailed description>

<description | none>

"Added reported to SCS" to suggested template as suggested by ushere.


ushere wrote on 10/22/2011, 6:16 AM
how about adding 'reported' since we rarely get to know 'quickly' about 'confirmed' bugs.
marky1 wrote on 10/22/2011, 6:30 AM
stabilizer does not work on 32 bit only 8 bit floating point
gpu accelartion also works better in 8 bit, very slow in 32 bit also better with it off on amd hd5870
newblue titler crashes in 32 bit but fine in 8 bit wrote on 10/22/2011, 12:13 PM
Very slow program startup.

Issue is in both 32 bit and 64 bit

Startup hangs at splash screen stuck at "Creating File I/O manager" and the "Vegas Pro has stopped working" Problem Report window pops up instantly. The problem description points to the Fault Module FileIOSurrogate.exe

The program eventually starts after 1 minute hang. If the Problem Report window is closed, the program also closes.

In contrast Vegas Pro 10e starts in 5 seconds!

No workaround so far. Sony have only one suggested solution and that is a clean uninstall, which I have not tried yet because it would entail uninstalling all my Sony software, and I need to carry on working whilst this problem is solved.

A significat difference between v10 and v11 would appear to be the introduction of GPU acceleration. I have an ATI Radeon HD5770 graphics card, which meets the required specification, and should not cause any problems. However it is not specifically shown in "Preferences-Video-GPU acceleration of video processing" list, only AMD (Juniper) whatever that is. I wonder if Vegas has not correctly identified my card and spends a lot of time looking for it at start up

Vegas Pro 11 is also installed on my HP laptop with an NVIDIA GT 230M which presumably does not meet the specification and is ignored by Vegas for GPU acceleration. This may be the reason that Vegas Pro 11 does not look for the card, and starts up in the same 5 seconds as v 10.
PLS wrote on 10/22/2011, 4:53 PM
Sony AVC and Sony MXF encoder options appear and disappear from day to day.
marky1 wrote on 11/15/2011, 1:33 PM
the AMD device is your card its standard fot ATI, however selecting my hd5870 makes it slower
wbtczn wrote on 11/15/2011, 7:51 PM
I was having this same issue and cannot get a response from Sony support. I didn't have much to lose, so I uninstalled all of my Sony programs, rebooted, and reinstalled Pro 11. It is up and running now.
Gujjuguy wrote on 11/16/2011, 9:58 AM
Can't render as .mp4. Crashes when using Titler

Issue in both 32-bit | 64-bit
Severity: : major
Occurrence: Reproducible

Reported to SCS: Yes
Confirmed by SCS: Not yet. Have posted the issue on 11/10, called up Tech support and they have confirmed that the issue has been assigned


I have done a fresh install/ factory setting on my machine. I un-installed the Trend Micro Anti Virus that came pre-installed. Updated all drivers including Catalyst 10.11 from the AMD’s site. Installed the Wacom/Intuos 4 driver (6.1.7-3 fr Win 7 64 bit)

I did a fresh install of Vegas Pro 11 and activated the software. No additional plugs or updates installed.

Step 1 – On the default project that opens with Vegas Pro 11, update properties to “Match Media Settings’

Step 2 – Add a single 30 seconds clip to the project. It creates one Video and one Audio track.

Step 3 – Select Render as,

Problem 1 – when I select “Match Project Settings’, Vegas Pro only shows Audio file options (.aa3, .ac3, .flac, .mp3, .wav and so on). It is as if Vegas Pro does not recognize the video at all. This is despite the fact that when I updated properties to match Media Settings, it was able to identify the aspect ratio, frame rates etc. of the clip).

Problem 2 – If I ungroup and delete the Audio track (keeping only the Video track), and then do a ‘Render As’ and select ‘Match Media Settings’, Vegas Pro shows a blank under the options.

Problem 3 – If I unselect ‘Match Media Settings’, and render as .mp4 (MainConcept AVC/AAC), it gives the following error after 1 second,
“An error occurred while creating the media file “Filename.mp4’. The reason for the error could not be determined.

Problem 4 - The software starts behaving erratically (programs stops responding every 5-10 minutes) if I add any of the Video Fx. If I add the 2D titler Media generator, it crashes immediately (program stops responding and has to be closed with Ctrl+Alt+Del)

The clips I was using was from Nikon D90 which creates .AVI files (1280x720, 24 fps). I have used these media files for making a lot of projects using Vegas Movie Studio 10 and 11 and never had any issues.

The same problem happens when I use a .wmv file as a source media

I also converted the AVI file to mp4 using the AIT AMD Catalyst Control Center Utility. It converted and played on both Windows Media Player and QuickTIme. When I used the same .mp4 file in Vegas Pro, I had the same problems (Problem 1, 2 and 3 described earlire.

The only time it seems to work fine is if I use .mpg file (Sony Camcorder 720x480 29 fps).

I also tried updating the CODECs by instaling a demo version of the Mainconcept MJPEG VFW codec from the link below,

None at this stage.
Progeocaching wrote on 3/30/2012, 8:08 AM
I had the same issue with Vegas Pro 11. I uninstalled and re-installed twice without success.

Anyway I found this video that solves the problem for Vegas Pro 8.

It works for me.
Gary James wrote on 3/30/2012, 8:36 AM
"Startup hangs at splash screen stuck at "Creating File I/O manager" and the "Vegas Pro has stopped working" Problem Report window pops up instantly. The problem description points to the Fault Module FileIOSurrogate.exe"

I've seen this problem following a Vegas v11 crash. In my case the work-around was very simple:

Start Windows Task Manager by right-clicking on the taskbar. Select the "Processes" Tab. Look through the list of running processes for FileIOSurrogate. Select the list entry and press the End Process button. Restart Vegas and it should start-up normally.
MatsB wrote on 4/14/2012, 1:57 PM
Aaaah... Thanks to a post on this thread the problem was solved:

It is "simply" the Quick Time program that was incompatible with the latest version of Vegas., After updating and installing Quick Time V7.7.1 the problem disappeared altogether.

Just wish Vegas would give a hint about this :) but at least the Sony forums held the answer...

(A workaround I found while looking for the real solution was simply to remove or rename the offending file "FileIOSurrogate.exe".)


My Vegas version is 11.0.595 for x64
My OS is Windows 7 x64 Ultimate
My QuickTime version is now 7.7.1