Vegas Pro 13 on HP ProBook

jmnvideo wrote on 11/4/2015, 1:31 PM

I am trying to get Vegas Pro 13 to run on an HP ProBook laptop. It's an Intel corei7 with AMD Radeon graphics card (separate from the motherboard). When Vegas boots up, it hangs at "Initiating GPU accelerated processing" then stops working. The error message:

Problem Description
Application Name: Vegas Pro
Application Version: Version 13.0 (Build 453) 64-bit
Problem: Unmanaged Exception (0xc0000005)
Fault Module: C:\Program Files\Sony\Vegas Pro 13.0\vegas130.exe
Fault Address: 0x0000000000000000
Fault Offset: 0x0000000000000000

Fault Process Details
Process Path: C:\Program Files\Sony\Vegas Pro 13.0\vegas130.exe
Process Version: Version 13.0 (Build 453) 64-bit
Process Description: Vegas Pro
Process Image Date: 2015-06-05 (Fri Jun 05) 21:53:04

I have tried uninstalling/reinstalling as well as editing the registry, but nothing seems to work. Has anyone else experienced this problem? Any help is appreciated, thanks,



Steve Grisetti wrote on 11/4/2015, 3:36 PM
Obvious question, but have you gone to the AMD web site and ensured you have latest drivers for your graphics card?

Is this a new computer? Are you running Windows 10 and have you ensured you have all of its updates?
jmnvideo wrote on 11/4/2015, 9:16 PM
Yes, I have the latest AMD drivers and Catalyst software.

It is not a new computer, it's a 2012 model. It is running Windows 10 with all of the latest updates. I originally had Vegas Pro 12 on this laptop (with Windows 7) and it worked fine. I wiped the drive when installing Windows 10, and now cannot get either Vegas Pro 12 or 13 to work. .
MTuggy wrote on 11/4/2015, 11:40 PM
What is the power setting you are using? I had a similar issue with my ASUS laptop on any setting other than High Performance. In that mode, it was using my GeForce 630M card (instead of the lame build in graphics processor) which allowed Vegas to run reasonably well. I suspect your video could be defaulting to a built in Intel HD video card that coexists with your Radeon card but only the latter will allow Vegas to boot up right. Ensure that in in your power settings you are selecting the use of the Radeon card.

It could also be that the driver for your Radeon is not terribly compatible with Win 10. I know Nvidia put out a couple drivers in sequence, fixing a couple bugs every time.

astar wrote on 11/5/2015, 2:00 AM
Mobile GPUs may have the same model numbers as desktop GPUs, but they do not have the same hardware.

Sony used to provide recommended GPU configuration stating the HD5770 as the recommended minimum back around Vegas 11 or 12 release. The 5770 runs about 1400 GFLOPs and 12 OpenCL compute units.

The AMD Radeon HD 7650M runs about 500 GFLOPs and 7 Compute units. The GPU runs about half of the minimum recommended performance. Vegas filters capability by memory size and not performance. Clearly there is an issue with either the driver or hardware support for what is being requested.

It would be best to maybe reset Vegas to default and run it without the GPU enabled.

Like others have said about latest drivers, do not forget to check with HP for Windows 10 specific system drivers or updates to the system BIOS.
jmnvideo wrote on 11/5/2015, 12:52 PM
Thanks all. I do have the power setting set for maximum performance. As far as setting Vegas with GPU acceleration off, I would do this if I could just get past the boot up screen, to the project screen.

I will try BIOS settings.
OldSmoke wrote on 11/5/2015, 12:56 PM
Have you tried holding down CTRL+SHIFT while starting Vegas?

Proud owner of Sony Vegas Pro 7, 8, 9, 10, 11, 12 & 13 and now Magix VP15&16.

System Spec.:
Motherboard: ASUS X299 Prime-A

Ram: G.Skill 4x8GB DDR4 2666 XMP

CPU: i7-9800x @ 4.6GHz (custom water cooling system)
GPU: 1x AMD Vega Pro Frontier Edition (water cooled)
Hard drives: System Samsung 970Pro NVME, AV-Projects 1TB (4x Intel P7600 512GB VROC), 4x 2.5" Hotswap bays, 1x 3.5" Hotswap Bay, 1x LG BluRay Burner

PSU: Corsair 1200W
Monitor: 2x Dell Ultrasharp U2713HM (2560x1440)

wjauch wrote on 11/5/2015, 7:29 PM
Just in case it helps I have the same version of Vegas on a 3.5 year old HP Pavillion laptop Win 7. Runs fine with either built in Intel graphics or in built Radeon graphics (don't know the type). When I try to start Vegas with Intel graphics NewBlue gives an error message about low GPU resources but then Vegas opens and runs
jmnvideo wrote on 11/6/2015, 7:03 PM
Finally got it to work. I went back in to AMD Catalyst Control Center again, and set everything to Maximum Performance (including on battery power), unchecked "Power Saving" for everything, and that did the trick.

Thanks everyone! I hope that Sony continues Vegas Pro. I have been using it since version 4, and have always received good advice from the great people in the Vegas community.