Vegas Pro 14 Preview on External Monitor Half Display is Off Screen

Riggan wrote on 6/25/2018, 9:29 PM

Hi,

I just recently upgraded to Windows 10 Pro and suddenly in Vegas Pro 14 when I choose to preview my project on an external monitor the image shows up with a big chunk of it off the right-hand side of the screen. As the cliché goes, everything worked fine till the upgrade. Was running Vegas 14 on Win7 and it worked like a champ.

My system is running an Intel i7-8700K with a GeForce GTX 970 video card with the latest drivers. No other resolution issues with any other program so far.

Here's an example of what it looks like when I try the external preview;

I tried different variations of these settings and nothing changed. I set them back so they currently look like this.

 

I also found a thread on another help forum where someone had nearly an identical issue and resolved it by setting the program to run in compatibility mode with Win8 and selecting it to run as admin. I tried this to avail as well (and changed the settings back). I've also reset Vegas despite it being a fresh install to make sure that base is covered also. Lastly, I've gone into Nvidia Control Panel and I played around with a few settings under resolution and 'desktop size and position'. Nothing changed.

I'm officially stuck.


Any help would be appreciated. Thank you.

Comments

Riggan wrote on 6/26/2018, 6:14 AM

Solved the issue. For anyone else having this problem who might find this thread;

The problem was, you guessed it, WINDOWS! 

I right-clicked my desktop and left-clicked "Display settings." Under "Display", the "change the size of text, apps, and other items" slider for display #2 was set to 125% for some reason. I surely didn't do it. Moved slider to 100% and Vegas is now displaying a full screen on external monitor. 

Hope this helps someone down the road.

paulyuk6 wrote on 6/27/2018, 2:12 AM

I had exactly the same problem with a 4K monitor and Riggan's advice solved it immediately!

I don't understand why Vegas relies on Windows settings to scale the external monitor. It should have its own user-configurable settings to allow more flexibility.

Paul

wwjd wrote on 6/27/2018, 9:39 AM

I had this issue just last night, but didn't look into it. Thanks for the fix! I'll implement first thing tonight!

TheBaboTv wrote on 8/10/2018, 9:55 PM

Solved the issue. For anyone else having this problem who might find this thread;

The problem was, you guessed it, WINDOWS! 

I right-clicked my desktop and left-clicked "Display settings." Under "Display", the "change the size of text, apps, and other items" slider for display #2 was set to 125% for some reason. I surely didn't do it. Moved slider to 100% and Vegas is now displaying a full screen on external monitor. 

Hope this helps someone down the road.

Thanks Riggan its works awesome!!!!

Kinvermark wrote on 8/12/2018, 4:36 PM

Another possible solution is to edit the High DPI / scaling behavior for Vegas. Navigate to the Vegas140.exe file in the programs folder, right-click, select "properties" then Compatibility, then change High DPI settings "High DPI scaling override" to "application."

BukaTV wrote on 12/25/2018, 1:19 PM

Why is it that in version 14 when you set your monitor to 125% this problem DOES NOT HAPPEN! Its the lack of foresight of the development of version 15 that is the ROOT culprit of this problem not Windows per se. Yes by adjusting the resolution from 125% to 100% this fixes the issue but version 14 of Movie Studio did not have this problem! What changed?

onu777ro wrote on 2/16/2019, 12:31 PM

Also I had this kind of problem, on win 10, using a 4k main monitor and a 1080p external monitor.

How it was resolved:

- I made a right click on the application icon, click on Compatibility tab, click on "Run this program as an administrator" than click on "Change high DPI settings" than validate "Use this setting to fix scaling problems for this program instead of the one in Settings" and also on "High DPI scaling override" validate "Override high DPI scaling behavior." and then "Scaling performed by: Application".

It worked.