Vegas Pro 17 crash with DJI Phantom Pro v2.0 h.265 video files.

marcinzm wrote on 1/13/2020, 11:36 AM

Hi,

I have a problem when I have or import video files from DJI Phantom 4 pro v2.0 drone - I mean 4K H.265 video files with 100 Mbps bitrate.
While opening existing project which contains these DJI Phantom 4 Pro v2.0 drone video files or while importing many such files (i.e. many files which have i.e. more than 30 minutes total length) Vegas Pro crashes or Windows 10 Home have black screen and then I need reboot my Window system.

It behave like it would be leak of memory. I have 128 GB RAM.

Vegas Pro 17 Suite build 387.

Can you help me how to open such project or work with these files without crashing Vegas Pro and crashing Windows 10 Home.

Regards
Marcin

Comments

Reyfox wrote on 2/3/2020, 10:13 AM

Just curious. Does it crash when importing a single file or several.

Someone else reported the same problem here:

https://www.vegascreativesoftware.info/us/forum/vegas-crash-while-trying-to-import-100-hevc-4k-files-from-gopro7--118386/

marcinzm wrote on 2/3/2020, 4:34 PM

I had the same problems with HEVC video files as in your link you pasted. The same crash reports and the same. behaviour. I was importing many HEVC video files at once.

Reyfox wrote on 2/3/2020, 4:38 PM

So it appears everyone is waiting for the next patch....

marcinzm wrote on 2/3/2020, 4:51 PM

I think that the fix will not come soon, because Vegas technicans tried to fix the issue and it didn`t suceeed. They had many attempts to fix the issue, they gave me some tips to uncheck some options in Vegas preferences, but it didn`t help. I reported them this issue nearly one month ago, but I has been having the HEVC issues in Vegas for very long time (maybe even since VP16), but they sent me some tips once a few days, but none of them help it. Unfortunately:(. I sent them also via wetransfer.com my HEVC video files from drone DJI P4P v2.0, but unfortunately they wrote me that on their computers the crash didn`t occur:( I wrote them to multiply the HEVC sample video files I sent them by wetransfer.com, but they wrote me they did it and they didn`t have any crash:( If they don`t reproduce the error on their computer it will be very hard for them to fix. This is my opnion, because I am also a developer.

JN- wrote on 2/3/2020, 5:54 PM

@marcinzm Can you make available the smallest project that still causes the problems, for download? If other users can also experience issues, crashes then maybe Magix will look again at it?

---------------------------------------------

Benchmarking thread

Codec Render Quality tables

---------------------------------------------

PC ... Corsair case, own build ...

CPU .. i9 9900K, iGpu UHD 630

Memory .. 32GB DDR4

Graphics card .. MSI RTX 2080 ti

Graphics driver .. latest studio

PSU .. Corsair 850i

Mboard .. Asus Z390 Code

 

Laptop ... (Acer Predator G9-793-77AC)

CPU .. i7-6700HQ Skylake-H

Memory ..32 GB DDR4, was previously 16 GB

Graphics card .. Nvidia GTX 1070

Graphics driver .. latest studio

marcinzm wrote on 2/4/2020, 12:37 PM

@JN- The smallest project would have at least 10 GB.

JN- wrote on 2/4/2020, 12:51 PM

@marcinzm Fine by me. Marcin, if it’s possible, can you save the project file as VP16 then both VP16 & VP17 can be tested by users. Ideally put all files into a single zip downloadable file.

Also supply a screenshot of the render template that you use, either here or in the zip, so that render comparisons are identical. The project properties will be fixed by your .veg file.

If you can include this info. also “they gave me some tips to uncheck some options in Vegas preferences,”

Last changed by JN- on 2/4/2020, 1:05 PM, changed a total of 5 times.

---------------------------------------------

Benchmarking thread

Codec Render Quality tables

---------------------------------------------

PC ... Corsair case, own build ...

CPU .. i9 9900K, iGpu UHD 630

Memory .. 32GB DDR4

Graphics card .. MSI RTX 2080 ti

Graphics driver .. latest studio

PSU .. Corsair 850i

Mboard .. Asus Z390 Code

 

Laptop ... (Acer Predator G9-793-77AC)

CPU .. i7-6700HQ Skylake-H

Memory ..32 GB DDR4, was previously 16 GB

Graphics card .. Nvidia GTX 1070

Graphics driver .. latest studio

marcinzm wrote on 2/4/2020, 1:00 PM

I can share the HEVC vidoes via wetransfer.com, so it wouldn`t be a single downloadable file. Wetransfer.com has 2GB for free so I need it to split it into parts. If you have some server where I can share the content with one downodalable file please let me know. Project can be created by every user, so I don`t need to put it - I think so.

JN- wrote on 2/4/2020, 1:19 PM

 

@marcinzm Ok. Have you looked at this link mentioned above by @Reyfox re: @KamieniosThere is a confirmed bug with the HEVC plugin in vegas 17 that the admins are aware of. I to get the same issue and sent my entire project to the MAGIX team where they were able to reproduce the crash. They are working on a fix for the next update. If you own 16 this bug is not present. If not, you gotta wait it out..”

The bottom of the PM? to Longlslanderrr from Magixheman is cut off, it may be suggesting using a different decoder in VP?

Last changed by JN- on 2/4/2020, 1:30 PM, changed a total of 3 times.

---------------------------------------------

Benchmarking thread

Codec Render Quality tables

---------------------------------------------

PC ... Corsair case, own build ...

CPU .. i9 9900K, iGpu UHD 630

Memory .. 32GB DDR4

Graphics card .. MSI RTX 2080 ti

Graphics driver .. latest studio

PSU .. Corsair 850i

Mboard .. Asus Z390 Code

 

Laptop ... (Acer Predator G9-793-77AC)

CPU .. i7-6700HQ Skylake-H

Memory ..32 GB DDR4, was previously 16 GB

Graphics card .. Nvidia GTX 1070

Graphics driver .. latest studio

JN- wrote on 2/4/2020, 3:50 PM

@marcinzm Update .. I decided to test, on my laptop, see my signature, with 150 Samsung NX500 4 second hevc clips. VP17 opened and laid out all clips on the timeline, plays them also. It used the SO4 ... plugin.

VP16 used the mxhevc plugin. I do realise this is not the same as testing your Gopro files, but I was curious.

Long story short I'm now restoring my laptop from a December 2019 drive C backup image, The VP16 project wrecked the display drivers, then wouldn’t take a reinstall. So thats what curiosity can do🤣.

 

Last changed by JN- on 2/4/2020, 4:05 PM, changed a total of 2 times.

---------------------------------------------

Benchmarking thread

Codec Render Quality tables

---------------------------------------------

PC ... Corsair case, own build ...

CPU .. i9 9900K, iGpu UHD 630

Memory .. 32GB DDR4

Graphics card .. MSI RTX 2080 ti

Graphics driver .. latest studio

PSU .. Corsair 850i

Mboard .. Asus Z390 Code

 

Laptop ... (Acer Predator G9-793-77AC)

CPU .. i7-6700HQ Skylake-H

Memory ..32 GB DDR4, was previously 16 GB

Graphics card .. Nvidia GTX 1070

Graphics driver .. latest studio

marcinzm wrote on 2/4/2020, 4:02 PM

4 seconds HEVC clips is not enough. You have to put on timeline i.e. 30-40 minutes of HEVC clips then you see a crash. I am happy that Magix reproduced the issue. I keep fingers crossed to see the fix of this annoying behaviour.

I recorded a short video which shows this crash and something like leak of memory:

I sent this video to Magix, but they didn`t watch it.

JN- wrote on 2/4/2020, 5:26 PM

@marcinzm “You have to put on timeline i.e. 30-40 minutes of HEVC clips then you see a crash.”

Perhaps you didn’t read my last post, 150x4s clips was more than sufficient to wreck my laptop. Restored now from backup image. Anyway good luck with Magix addressing your problem.

Last changed by JN- on 2/4/2020, 5:26 PM, changed a total of 1 times.

---------------------------------------------

Benchmarking thread

Codec Render Quality tables

---------------------------------------------

PC ... Corsair case, own build ...

CPU .. i9 9900K, iGpu UHD 630

Memory .. 32GB DDR4

Graphics card .. MSI RTX 2080 ti

Graphics driver .. latest studio

PSU .. Corsair 850i

Mboard .. Asus Z390 Code

 

Laptop ... (Acer Predator G9-793-77AC)

CPU .. i7-6700HQ Skylake-H

Memory ..32 GB DDR4, was previously 16 GB

Graphics card .. Nvidia GTX 1070

Graphics driver .. latest studio

Phil-MJr. wrote on 2/9/2020, 12:07 AM

I upload P4P verson 1 HEVC clips and use them regularly. I do have occasional crashes while editing, but I cannot attribute them to the clips. These are 3840x2160 @ 29.97 fps. Perhaps certain configurations have problems? I don't know if the HEVC files are different between version 1 and 2. But I recommend experimenting with the clip settings in the aircraft. Or maybe there is a driver problem with the graphics card?

marcinzm wrote on 2/9/2020, 5:13 AM

I am not sure this is a problem with graphics card drivers, because I have this issue for a very long time, and I update graphics drivers regularly and I have often latest drivers installed.

markr041 wrote on 3/30/2020, 5:33 PM

Still no solution to this basic problem - immediate crash of Vegas Pro 17 when importing several HEVC 4K 30P files.

marcinzm wrote on 3/31/2020, 3:09 AM

If you have installed the latest build of Vegas Pro it is a sad news, because they said that they fixed this issue in the latest build.
So, please register an official ticket to Vegas developers to fix it again