Vegas Pro 17 stuck on "Creating video plug-in factory"

Th3_N1CK wrote on 8/29/2020, 1:33 AM

I have had Vegas Pro 17 for a while now, maybe about a year, and it had worked fine until recently. I originally had a problem where vegas would crash after reaching "Initializing GPU-Accelerated Video Processing" I searched around and tried a few things, but after nothing worked I decided to re-install the program.

Upon startup now it gets stuck at "Creating video plug-in factory" I have tried almost everything I have seen online but to no avail. What's worse is that I still don't know if my original problem has been solved either.

System Info:

  • Windows 10 Home 64bit
  • NVIDIA GTX 1070Ti
  • CPU: Intel i7-6700k
  • Vegas version: Version 17.0 (Build 452)

Things I have already tried:

  • Holding CTRL + Shift and clicking YES to "reset all preferences to default values?"
  • deleting the "temporary files" for backups to videos when vegas crashes
  • Updating windows
  • rolling back my GPU driver
  • completly turning off my GPU
  • There was an update for Intel graphics, but I rolled that back as well for another issue not related to SVP
  • Uninstalling Vegas pro 17 like 12 or so times.
  • manually deleting all related files to vegas after an uninstall (except project files)
  • Uninstalling FL studio as this had caused an eirlier problem with vegas that I managed to fix
  • Re-instaling OFX and other plug-ins for vegas
  • Runing vegas successfully on my laptop and moving the files over manually to my desktop, but I got and error and veags said "the product isnt registered"
  • letting Vegas load for several hours just to see if it would load
  • instaling an older build: SVP build 353
  • closing all open programs and launching
  • As well as more things im sure, but have forgotten

TLDR: SVP broke, stuck on "Creating video plug-in factory." Tried so many things but nothing has worked. Windows 10. Thanks in advance!

Comments

j-v wrote on 8/29/2020, 3:22 AM

Try to deïnstall all your 3th party plugins.
Restart Windows and try again to start the program.
When it starts now you know the reason and have to figure out which one of those plugins need something to do with.

met vriendelijke groet
Marten

Camera : Pan X900, GoPro Hero7 Hero Black, DJI Osmo Pocket, Samsung Galaxy A8
Desktop :MB Gigabyte Z390M, W10 home version 20H2 , i7 9700 4.7Ghz,16 DDR4 GB RAM, Gef. GTX 1660 Ti, Intel HD graphics 630
Laptop  :Asus EVO37T, W10 home version 20H2, CPU i7-10875H, 16 GB RAM, Intel HD Graphics 630 + NVIDIA GeForce RTX 2070. VP 17,18 and VMS PL 17 are installed, all latest builds, both Nvidia GPU's have driver version 461.92 Studiodriver. both Intel GPU's have
driver: 27.20.100.9316 DHC
TV      :LG 4K 55EG960V

My slogan is: BE OR BECOME A STEMCELL DONOR !!!

Th3_N1CK wrote on 8/29/2020, 5:25 AM

@j-v Good news! this did, in fact, solve the "Creating video plug-in factory" error. I had already tried deleting those plugins, and restarting the computer, but I guess never at the same time!

The bad news is that the original "initializing GPU-Accelerated video processing" error is still there, and it crashes when it gets to that point. I'm not sure If I should start a new thread for this tho?

Oh, and thank you, of course!

j-v wrote on 8/29/2020, 5:35 AM

The bad news is that the original "initializing GPU-Accelerated video processing" error is still there, and it crashes when it gets to that point. I'm not sure If I should start a new thread for this tho?

Yess, that is better.
Another problem needs other options to repair, which I 'll try to give you in that new thread.

met vriendelijke groet
Marten

Camera : Pan X900, GoPro Hero7 Hero Black, DJI Osmo Pocket, Samsung Galaxy A8
Desktop :MB Gigabyte Z390M, W10 home version 20H2 , i7 9700 4.7Ghz,16 DDR4 GB RAM, Gef. GTX 1660 Ti, Intel HD graphics 630
Laptop  :Asus EVO37T, W10 home version 20H2, CPU i7-10875H, 16 GB RAM, Intel HD Graphics 630 + NVIDIA GeForce RTX 2070. VP 17,18 and VMS PL 17 are installed, all latest builds, both Nvidia GPU's have driver version 461.92 Studiodriver. both Intel GPU's have
driver: 27.20.100.9316 DHC
TV      :LG 4K 55EG960V

My slogan is: BE OR BECOME A STEMCELL DONOR !!!

Th3_N1CK wrote on 8/30/2020, 4:39 AM

@j-v Alright cool, I'll do that then, thanks again!