Vegas Pro Rendering Glitching (Please help)

Richard-Allen wrote on 1/24/2023, 11:20 PM

I can not for the life of me, figure out how to get this video to render properly. Attached is the YouTube video that shows the problem.

I have Vegas pro 19

Project source and render setting are the same.

Here is the video:

Comments

fr0sty wrote on 1/24/2023, 11:24 PM

Does it happen if you do not use the preset that ends with NVENC?

Does your project framerate match your media frame rate, and does that match your output frame rate? What resample mode is enabled in project settings?

Last changed by fr0sty on 1/24/2023, 11:24 PM, changed a total of 1 times.

Systems:

Desktop

AMD Ryzen 7 1800x 8 core 16 thread at stock speed

64GB 3000mhz DDR4

Geforce RTX 3090

Windows 10

Laptop:

ASUS Zenbook Pro Duo 32GB (9980HK CPU, RTX 2060 GPU, dual 4K touch screens, main one OLED HDR)

Richard-Allen wrote on 1/24/2023, 11:29 PM

Sorry i reuploaded the video with audio. Yes the frame rate matches the source material. HOWEVER this portion of the time line is just pictures added in. so this is super confusing.

fr0sty wrote on 1/24/2023, 11:34 PM

If you do a dynamic RAM preview (set a loop region around the area of the timeline in question, press shift+B), does it also show this same stuttering of the motion, or is it only present upon rendering it?

Systems:

Desktop

AMD Ryzen 7 1800x 8 core 16 thread at stock speed

64GB 3000mhz DDR4

Geforce RTX 3090

Windows 10

Laptop:

ASUS Zenbook Pro Duo 32GB (9980HK CPU, RTX 2060 GPU, dual 4K touch screens, main one OLED HDR)

Richard-Allen wrote on 1/24/2023, 11:35 PM

Seems to just be when rendering. the DRAM Preview was flawless

3POINT wrote on 1/24/2023, 11:41 PM

@Richard-Allen Your GPU meets the minimum specs? Pictures have probably a much higher resolution than your project resolution.

Richard-Allen wrote on 1/24/2023, 11:42 PM

I have a 3070 TI and the pictures were edited in PS to match the 4k resolution of the video. I was thinking the same thing as you 3POINT

Richard-Allen wrote on 1/24/2023, 11:45 PM

UPDATE: This seems to be an NVENC problem, as rendering in AVC the outcome is normal. The graphics card driver was updated tonight as I thought that was the problem but it still persist. Does hardware rendering come with janky outcomes/ or am I doing something wrong?

RogerS wrote on 1/24/2023, 11:47 PM

Try setting dynamic ram preview to 0Mb and render with MagixAVC with NVENC. Are the glitches still there?

Richard-Allen wrote on 1/24/2023, 11:51 PM

My guy! Thank you! It must have been rendering cached footage from preview intertwined with the source material! You are a genius!

3POINT wrote on 1/24/2023, 11:52 PM

NVENC rendering with Magix, always a source of issues, my experience. Try NVENC rendering with (free) Voukoder which renders without issues and even much faster as with Magix.

fr0sty wrote on 1/24/2023, 11:58 PM

Voukoder is fantastic, as is Render+ in Happy Otter Scripts.

Systems:

Desktop

AMD Ryzen 7 1800x 8 core 16 thread at stock speed

64GB 3000mhz DDR4

Geforce RTX 3090

Windows 10

Laptop:

ASUS Zenbook Pro Duo 32GB (9980HK CPU, RTX 2060 GPU, dual 4K touch screens, main one OLED HDR)

3POINT wrote on 1/25/2023, 12:02 AM

Seems to just be when rendering. the DRAM Preview was flawless

How much RAM did you reserved for DRAM preview?

RogerS wrote on 1/25/2023, 3:23 AM

I've been doing testing of it this week and seeing glitches with multiple encoders including Voukoder x264. Temporarily setting dynamic ram preview to zero avoids it. Only affects my laptop, not desktop (see signature).

3POINT wrote on 1/25/2023, 4:10 AM

I never had any need to reduce DRAM preview setting from default 5% to 0%.

The time that I suffered with such glitches was at the time my GPU wasn't meeting minimum specs for 4k. Solution at that time was for me deactivating GPU support in the Video settings tab of preferences.

As far as I know setting DRAM preview to 0% has also impact on preview speed.

RogerS wrote on 1/25/2023, 8:07 AM

It may be an issue with systems with slightly older Intel iGPUs? Not sure. My hardware meets VP requirements and I only see issues when overlaying elements like text and pictures, not video.

In the new VP 20 benchmark project I added a checkbox for glitches to help narrow it down.

Yes it reduces preview and thus render performance, though disabling the GPU entirely has large impacts too. Pick your poison.

Illusion wrote on 1/25/2023, 8:23 AM

I edit with DRAM set to 20~30% range. Before rendering, I set to 0.

  • ASUS ROG Strix X570-E
  • Ryzen 9 3900x 12-core
  • 64GB RAM (2x32GB)
  • Nvidia RTX 2070 8GDDR6
  • 1TB WD Black NVMe M.2 for OS/Prog
  • 1TB WD Black NVMe M.2 for Media
  • 1TB SATA3 SSD for projects
  • 2TB SATA3 SSD for additional media
  • 4TB WD Red drive for local cache
  • 10TB EXOS enterprise drive for local cache
  • 32in 4k main monitor, 24in 1080 second
  • Win 11 Pro
  • 28TB NAS for long term archive storage
  • Sony a6000
  • Sony A7C
  • GoPro Hero 8
  • GoPro Hero 11