Vegas Stream ISO Recording, more than 1 hour.

boris-p wrote on 5/23/2022, 12:39 PM

Processor 11th Gen Intel(R) Core(TM) i7-11800H @ 2.30GHz 2.30 GHz

Installed RAM 16.0 GB (15.7 GB usable)

System type 64-bit operating system, x64-based processor

External SSD Sandisc Ulta. Thunderbold 4.


I am not able to iso record more than 1 hour with 4 Cameras NDI and this has been tested with every setting and file format.

Other programs for ISO recording like for example VMIX, Livemind, NDI Studio monitor, etc...

can do this simple task without mistake.

Please fix this problem with Vegas Stream.

Thank you!


jetdv wrote on 5/23/2022, 6:51 PM

@boris-p, some early versions of Stream has some issues if the file size exceeded - I think - 2 Gig. So it's not the length of time that's the issue, it's the file size. This was fixed in the later builds. What build do you have installed? Try this build:


Charlie-Rockwell wrote on 8/15/2022, 4:13 PM

I also have been experiencing this issue as well. I would record a session over an hour to the hard drive and the file would be over 3gb. All ISO files would not open at all. I just downloaded this link and will install and test out when I can. @boris-p, have you tried this install and has it solved your issue? @jetdv Thanks for the link.

My current workaround to this problem is to just stream it to YouTube live, and everything works fine. However, there is no way to edit anything in post. Something I would like to do if I can get Vegas stream to work. I know there are other alternatives such as OBS, but I’m so used to using Vegas and NewBlueFX Titler Pro, it just makes sense for what I’m trying to do.

Current setup:


i7 9750H, 64GB Ram, 2TB internal NVME M.2. (I’ve also tried recording to an external Samsung T5 SSD, same issue)

Running 2 Canon 90ds on 2 cam link 4K 60 capture devices and a laptop running on a pass thru capture device for screen share. Audio is recorded thru Mackie ProfxV3 USB Mixer/Audio interface.

Any advice would be greatly appreciated. Thanks in advance.



jetdv wrote on 8/15/2022, 4:49 PM

@Charlie-Rockwell, the real solution is to update to a newer version. The version I linked to fixed that issue. The current Vegas pro 20 version also fixes the issue.

Charlie-Rockwell wrote on 8/15/2022, 5:07 PM

@jetdv ok, I got the free upgrade from Vegas pro 19 to 20. I’ll do a fresh install of it when I get the link from Magix. I’ll make sure to give it a try. Hoping it will resolve the issues.

Charlie-Rockwell wrote on 8/17/2022, 12:28 AM

Just wanted to report back that I did a test with the new install file of Vegas Stream with Vegas Pro 20. IT WORKED! Did a test recording over an hour and the file was well over 2GBs and ISO files opened up just fine. I was able to import into vegas with no issues.

@jedtv I was curious to know, does this issue only happen with the install files provided with Vegas Pro 19 and earlier? I tried to look on NewBlueFX's site and there was no update file to download.

jetdv wrote on 8/17/2022, 8:35 AM

There was an update given to Magix during the past year that also fixed the issue. I don't remember exactly when it was. But the issue has been fixed for quite some time now. The issue was when it exceeded 2Gig, the file did not get the proper information written. I know I haven't had an issue with this for at least 8 or 9 months. Glad to hear the current version resolved it for you.