Velocity Creep

cworld29 wrote on 10/13/2004, 11:14 PM
I am doing a credit roll CHiPs style. I have an .AVI that I want to play then freeze 8 to 10 seconds. After setting up the velocity envelope I noticed that every 7 seconds the video would creep 1 frame.

I started a new project with the same short .AVI and set the velocity the same way. Every 7 seconds it would jump forward 1 frame.

Just to experiment I dropped an .MPEG2 file further down the same track and gave it the same velocity envelope. I stretched it out and it went a full 20 seconds without creeping.

Anyway, is this a known bug or is there something I am doing wrong?


jetdv wrote on 10/14/2004, 7:39 AM
Right-click the velocity point, choose "Set To..." and enter 0 (zero). By simply dragging to "zero", you sometimes get something more like .2 instead.
cworld29 wrote on 10/14/2004, 9:21 AM
Yeah I figured that might be the case. I was very careful dragging to make sure it was on 0%. It was, but I did the "set to" step anyway just to make sure. I still got the creep.

It's consistant at set intervals. Every 7 seconds in the first one, one I set up this morning took longer, 15 seconds apart.

If anyone has time can you try to see if this happens on your computer too?
This is video capture with Vegas, put about a 5 - 10 sec. clip on the timeline then set the velocity envelope to freeze a about 5 sec. into the clip. Then stretch the freeze frame out 30 seconds or so and watch.

Using a clip with a scene change makes it a little more obvious.
jetdv wrote on 10/14/2004, 9:47 AM
Do you have another point farther down that is set to something other than 0%?

Using set to and setting it to zero tested solid here on a clip lasting over two minutes.
cworld29 wrote on 10/14/2004, 12:43 PM
Yep just 2 points, 100% and then 0%.

I messed around with this for about an hour this morning trying different media types, lengths etc. I notice the problem occurs on AVI. clips when setting the freeze point closer to the beginning of the clip. About 3 seconds. As I move the point closer to the left edge of the clip it occurs more rapidly.

Spot|DSE wrote on 10/14/2004, 1:00 PM
Change the envelope attribute by right clicking and selecting the type of envelope attribute you'd like. Default is Smooth, but you likely want Linear.
cworld29 wrote on 10/14/2004, 6:38 PM
The creep happens after the velocity is dropped to 0%. There are no other points after that to set the transition type. I have also tried putting another point at the end of the clip and setting this to 0% as well and I still get it. Between two 0% points!

Thanks for both or your help. I cannot reproduce it reliably so I will just try a work around. I will just render this particular clip to mpeg and apply the velocity envelope to that.
apit34356 wrote on 10/14/2004, 10:49 PM
on the timeline, are you snapping the clip to an even or odd number, is the lenght of clip an odd number or number of the frame frozen odd/even?
zcus wrote on 10/14/2004, 11:57 PM
I have noticed this also, recently I was trying to get a credit roll to gradully slowmo to a complete stop and it would not! (every so many frames it would still advance even when the envlope is set to 0%) I have done this in Vegas 4 successfully so I think it's a small bug - try it all - I can reproduce it again and again.
jaegersing wrote on 10/15/2004, 2:44 AM
I suppose it doesn't help you, but for info I tried it and had solid results, i.e. no creep. I used the right-click and "Set To" method to make sure the velocity value was exactly zero.

Richard Hunter