VirtualDub Deshaker Assistance

Byron K wrote on 6/7/2009, 5:39 PM
I'm trying to use the Deshaker in Vegas 9 but the output comes out ghosty and wobbly. I can get better quality keyframing the clip to stabilize video than the Deshaker script but this obviously will take too much time to do.

How do I get to the Deshaker settings in Vegas? Once the script is selected it automatically starts to render the image and I can't get to the settings.

I've also tried to use the Virtual Dub w/ the Deshaker filter by itself but cant seem to get it to process after I've selected the region on the clip to stabilize.

I'm stuck pls help.



ritsmer wrote on 6/8/2009, 4:02 AM
Quick help - check this thread:

or this

Virtual Dub is a stand alone program and runs outside Vegas - or in a Vegas script like the newest version of the "New Deshaker" script.
Byron K wrote on 6/8/2009, 11:23 AM
Thanks ritsmer!
I've been following those threads but they didn't actually address the issue I was having (Maybe I should have posted to one of those threads).

I was able to find the settings button, (First button under the Filter Preset field)

I spent hours last night playing w/ the settings but didn't result in any acceptable stabilized videos.

When the video processed I saw a whole bunch of white dots and lines and red lines all over the place! The wobbly video turned into a video that jumped around, zoomed in and out with almost no correction. It was almost worse than the original shaky video.

Are there any recommended settings for various degrees of stabilization? It seems that many people here are using it successfully but not sharing any settings. Maybe they've put so much work into getting this thing to work that it's proprietary. lol! ((:

I have read the instructions on the website and on John Myer's site.

The video I was trying to correct was just a test video with some lateral, vertical movement and a little rotation.

Here are some screen shots of the last settings that got minimal results:

BTW, What are the default settings? Looks like I've overwrote them before I knew to save my (botched settings) to another name. (;

Pls let me know if you would like me to post short clip of the .avi video I'm working with.

Any assistance is greatly appreciated!
Tom Pauncz wrote on 6/8/2009, 11:42 AM
I am using the "New Deshaker" and have never seen what you describe.

I have below listed my setting that are different to yours.

My settings for Pass-1:
Block size - 30
Initial search 40%
Differential search - 4 pixels
Under "Discard motion blocks (boxes in order top to bottom) ...:
"Remember discarded..." checked
Deep analysis ...0%
Skip frame ... 5%
Under "Ignore pixels...":
Darker than 15% brightness checked only; "Outside & Inside" not checked.

My settings for Pass-2:
Under "Motion Smoothness": values are 9000 for all three and zoom is 0
Under "Max Correction Limits": values are 99 for all three and zoom is
'Edge Compensation": None
I have "Use previous and future ..." checked, "Soft borders....: checked, value 3 pixels

Try those and see how you go.

If all else fails, post your short clip for download and I'll have a go at it.

Andy E wrote on 6/8/2009, 1:14 PM
BTW, What are the default settings?

See the button with the floppy disc to the right of the "Preset Name" input box on the edit preset dialog?

Hover the mouse over it. It will say "Reset this preset to the default old Deshaker settings". Click on it and then click on ok.
Byron K wrote on 6/9/2009, 10:33 AM
The settings you recommended helped quite a bit! I'm getting a lot of interlacing artifacts. I'll just have to continue to play with the settings.

Andy, Thanks!
ritsmer wrote on 6/9/2009, 1:27 PM
Interlacing artifacts? then they are probably made when Vegas renders the avi as input to VD.
So check project/input media settings ?
douglas_clark wrote on 6/10/2009, 2:47 PM
Byron, in Pass 1, try lowering block size to 25 or 20 to get more blocks.

Are you sure you want to exclude the border area of the frame? (100 pixels from edge all the way around). In most cases, the surrounding area is what you want to stabilize on (background), rather than the center subject, which may have its own motion.

Home-built ASUS PRIME Z270-A, i7-7700K, 32GB; Win 10 Pro x64 (21H2);
- Intel HD Graphics 630 (built-in); no video card; ViewSonic VP3268-4K display via HDMI
- C: Samsung SSD 970 EVO 1TB; + several HDDs
- Røde AI-1 via Røde AI-1 ASIO driver;

Byron K wrote on 6/11/2009, 12:12 PM
Thank Douglas for the suggestion! I'll try in and see how it goes.