VP17 - Video FX Plug-ins

Dexcon wrote on 8/5/2019, 6:26 AM

With one exception, all 3rd party video FX plug-ins loaded into VP17 without a problem (so far anyway): BCC, Mocha Pro, Magic Bullet Looks, NewBlueFX.

The exception: HitFilm Ignite. Even re-installing Ignite and rebooting didn't help. It looks like Ignite is not really fully OFX and is locked to NLE versions/builds. HitFilm say that you can keep using Ignite if not resubscribing (which I haven't), but they don't say that Ignite is not fully OFX and therefore won't work in later NLE releases. They'll likely release a new Ignite update supporting VP17, but then I'll need to resubscribe to get it, and the subscription cost is about 80% of an outright purchase - very, very expensive compared to other subscription/upgrade rates from other NLE and 3rd party plug-in companies.

Comments

Reyfox wrote on 8/5/2019, 11:32 AM

Dumb question... so forgive me. Is this Ignite Pro from VP16 you are referring to?

CJacobsSA wrote on 8/5/2019, 11:52 AM

None of my HitFilm plugins are being acknowledged in Vegas 17 either. It says it cannot find them as they aren't installed, but they clearly are installed as I can open up Vegas 16 and they'll work just fine. Did they change the location Vegas uses to search for plugins?

fr0sty wrote on 8/5/2019, 2:30 PM

There was a change made to Vegas 17 (not plugin location, but I can't remember exactly what it was they mentioned when I asked) that required some vendors to have to update their software. Neat Video didn't work in 17 originally either, but was patched to work.

IAM4UK wrote on 8/5/2019, 5:47 PM

Boris Continuum 2019.5 that includes lens flare as part of VP17... The installation says previous version must be removed. Can anyone confirm that no previous BCC stuff will be omitted from the VP17 VFX when doing this upgrade?

Also, how can we get VP17 to recognize the Ignite plugins?

Dexcon wrote on 8/5/2019, 5:51 PM

Is this Ignite Pro from VP16 you are referring to?

A good question. No, not at all. The Ignite I have is the full Ignite Pro OFX package purchased directly from HitFilm. It also works in DaVinci Resolve.

 

fr0sty wrote on 8/5/2019, 10:39 PM

Make sure you have the latest version installed, and if that still doesn't work, contact ignite devs about updating it.

Dexcon wrote on 8/6/2019, 4:17 AM

HitFilm have just advised on their Ignite forum page that Ignite does not support VP17 at this time but that they are working on an update to allow Ignite to function in VP17.

AVsupport wrote on 8/9/2019, 12:50 AM

HitFilm have just advised on their Ignite forum page that Ignite does not support VP17 at this time but that they are working on an update to allow Ignite to function in VP17.

bet ya you'll need to upgrade to the latest version of Ignite Pro to make this happen when it does.. I remember something similar happening last year..

my current Win10/64 system (latest drivers, water cooled) :

Intel Coffee Lake i5 Hexacore (unlocked, but not overclocked) 4.0 GHz on Z370 chipset board,

16GB (2x8GB Corsair Dual Channel DDR4-2133) XMP-3000 RAM,

Intel 600series 512GB M.2 SSD system drive running Win10/64 home automatic driver updates,

4TB 7200RPM NAS HGST data drive,

Intel HD630 iGPU - currently disabled in Bios,

nVidia GTX1060 6GB, always on latest [creator] drivers. nVidia HW acceleration enabled.

main screen 4K/50p 1ms scaled @175%, second screen 1920x1080/50p 1ms.

Dexcon wrote on 8/29/2019, 8:50 PM

Today, I received an email from Eye Scream Factory with their latest offer: Ignite Pro 4.1 for $99.50 instead of $199.50. The link to purchase goes to MacVideoPromo:

https://www.macvideopromo.com/products/ignite-pro-v4-1-for-mac-or-win?mc_cid=243914ec18&mc_eid=abc74c10f0

The compatibility info re this offer is VP14, 15 and 16 - but no mention of 17. However, FXHome's website shows that 4.1 is the latest build, and FXHome on their Ignite forum recently stated that the latest version, 4.1, is compatible with VP17. Nonetheless, if you are thinking about taking up this offer, it would be worthwhile first making sure about VP17 compatibility.

There is no information as far as I can see about how purchasing this offer will affect the ability to upgrade under FXHome's upgrade/ala subscription model.

Eye Scream have been making NLE related offers for years, often involving Boris FX products. In fact, I purchased a couple of Boris FX products from Eye Scream many years ago, and this provided me with a cost-effective entrée into the world of Boris FX via upgrades/cross-grades.

 

RealBlackinator wrote on 9/20/2019, 10:50 AM

Just wanted to chime in any say that any upcoming compatibility update for Ignite unfortunately won't extend to Ignite Express 2017 (the free one). At least that's the statement I got from one of the FXhome staff.