VPE 19 - Playback stops working after rendering.

NOVAdash wrote on 3/24/2023, 4:07 PM

Hello!  Subject says it all. I can work on projects without issue but after rendering anything, playing the timeline/preview will give me an error message (attached) ("An error occured while starting playback. The request is not enabled for this device").  

Media type doesn't matter. I can start a new project, insert only text media and replicate this problem.

I can work around this by going into the Audio Device and selecting from Microsoft Sound Mapper to Direct Sound, and that seems to clear it until I render again, then I have to switch it back. I am hoping that this is a common issue with an easy fix!



EricLNZ wrote on 3/24/2023, 7:53 PM

To my knowledge it's not a common issue but is something encountered occasionally. The cause has never been determined but appears to be unique to particular systems. Search the forum and you will find previous threads.

As for an easy fix the only solution I'm aware of is to play with the Audio Device settings as you have.

Another variation of the problem is not that playback doesn't occur but it plays with terrible audio until you do the Audio Device switch.

NOVAdash wrote on 3/24/2023, 8:44 PM

I did a pretty comprehensive search prior to posting this, but that doesn't mean I didn't miss anything.

I messed around quite a bit with my PC/Windows sound settings. Found a way to fix some things that have been annoying me (outside of Vegas) by accident, but outside of that nothing I tried worked.

But finally I did try selecting the Creative Sound Blaster ASIO Device instead of the two that I'm used to seeing in other places (Microsoft Sound Mapper and DirectSound Surround Mapper) in the drop-down in the screenshot. That seems to have fixed it. Crisis averted!


EricLNZ wrote on 3/25/2023, 4:56 AM

@NOVAdash Not all users may have the Creative Sound Blaster ASIO Device but for those that do you appear to have found a quick solution so I'll mark your post as "The Solution". It could help any others who come across the same problem.

rtbond wrote on 5/22/2023, 10:27 AM

I was having the same problem with VP 20. Selecting the ASIO audio device type (Preferences > Audio Device) cleared the trouble (default device as the Microsoft Sound Mapper). I am running Windows 11 with a Realtek audio chip-based motherboard. Thanks for the direction.

Rob Bond

My System Info:

  • Vegas Pro 20 Build 411
  • OS: Windows 11.0 Home (64-bit), Version: 10.0.22621 Build 22621
  • Processor: i9-10940X CPU @ 3.30GHz (14 core)
  • Physical memory: 64GB (Corsair Vengeance LPX 64GB (2 x 32GB) DDR4 DRAM 3200MHz C16 memory kit)
  • Motherboard Model: MSI x299 Creator (MS-7B96)
  • GPU: EVGA GeForce RTX 2070 SUPER XC ULTRA (Studio Driver Version =  536.40)
  • Storage: Dual Samsung 970 EVO 1TB SSD (boot and Render); WDC WD4004FZWX, 7200 RPM (media)
  • Primary Display: Dell UltraSharp 27, U2723QE, 4K monitor with 98% DCI-P3 and DisplayHDR 400 with Dell Display Manager
  • Secondary Display: LG 32UK550-B, entry-level 4k/HDR-10 level monitor, @95% DCI-P3 coverage