VST plugin problem in Vegas 7

drbam wrote on 3/1/2010, 8:10 PM
I just got a new pc and after installing all of my programs and efx, I discovered that Vegas 7 will not show any of the VST plugins. In the preferences I pointed Vegas to the correct VST folders and performed some re-scans, and it "appears" that Vegas is scanning all of them because the plugin names briefly show during the scan. However they do not show up in the list. I've tried several times to no avail. They do show up and work properly in Acid 6 and Reaper so I know the plugins are installed correctly. Anybody have any suggestions or advice?


drbam wrote on 3/4/2010, 3:16 PM
Nobody?? Almost 4 days. I can't help but get the feeling that SMS is letting the Vegas Audio forum die a slow death through attrition. Note that there is no longer a Sticky for the current version link to download. Vegas Video, SF and Acid still has one. Oh well . . .
SonyMLogan wrote on 3/5/2010, 8:11 AM

I just installed Vegas 7.0e, and my VSTs were picked up just fine. It sounds like you set up the correct path, so the problem may be that there is a plug-in giving vegas a problem. Have you tried re-scanning for plug-ins. The older version of the plug-in scanner in vegas7 sometimes took a few passes to get the job done when plug-ins crashed.
drbam wrote on 3/5/2010, 8:54 AM
Thanks and yes I performed several re-scans. As noted in my original post, I can see the plugins that are being scanned as their names quickly pass by during the process. However, nothing shows up after the scan is completed. Like in Acid Pro 6, all of the VST plugs should show up in the window with a check by their name, correct?

FWIW, I did not experience any plugins "crashing". This was a new install on a new PC and I when I was trying to build a project in Vegas I noticed that the VST plugs weren't showing - hence my efforts to re-scan. Other things I tried were closing and reopening Vegas and even rebooting the system a couple of times.
iankennymusic wrote on 3/18/2010, 6:58 AM
I'm having the same problem with Vegas Pro 9.....Ha....
iankennymusic wrote on 3/18/2010, 7:32 AM
sorry,...should clarrify...I can pick up all my VSTs in Vegas 9...except my new Sonic Reality's Infinite Player (Kontact Player 2)...and its 30 gig of Drum Samples......but I dont think I'll be holding my breath for an answer here....lol
drbam wrote on 3/18/2010, 7:59 AM
Indeed, don't hold your breath. SonyMLogan's reply (which I appreciate) was on March 5th but there has not been a follow-up to my immediate response to him/her. I think I'm correct in that this forum is in an attrition process. RIP Vegas Audio . . .
Matthias King wrote on 3/18/2010, 3:19 PM
I don't have a solution for the OP, sorry about that, but @iankennymusic, you won't see that Infinite Player show up in Vegas, as Vegas doesn't load VST instruments. You'll need something like ACID to host your VSTi's and do MIDI.

Vegas does just about everything with audio, EXCEPT virtual instruments.

@ the OP, if you've pointed Vegas to the right folder in the VST tab in preferences, and rescanned and still no luck, I can't think of anything else to try, unfortunately, except maybe to move the plugins to a different folder, point Vegas to that one and rescan and maybe you'll get lucky.
drbam wrote on 5/31/2010, 9:45 AM
I'm bumping this in case there might be any insight or suggestions from SCS folks. I do have Vegas 8 and the VST plugins show up fine in it but still no luck with Vegas 7, which I need to use because I'm working with a collaborator that only has Vegas 7. I tried scanning again last night and all the VST plugins show up as they are scanned but after the scan is completed, there's nothing - nada!
willqen wrote on 7/1/2010, 5:39 AM
Sorry, I just caught your post;

I had this very same exact problem with Vegas 7.

What you need to do is first remove all your Sony software from your computer using windows program uninstall tool.

Then go to the Task Manager and shut off all unnecessary services and processes that you can find. If you accidentally shut off something important and windows freaks out, don't worry just reboot, or use one of the buttons on your computer case if windows completely hangs, windows just has to restart and all your services and processes will reappear, then you can start over shutting them down.

Then install Vegas 7e directly from the update. Don't go through ver after ver, like first ver7a then update to 7b then 7c, etc.,. For some reason ver 7 of Vegas liked to be the first Sony product installed on some systems and couldn't tolerate a lot of windows activity while it was installing. After Vegas installs correctly and sees your VST's, then do a fresh reinstall of all your other Sony software from their most recent updates.

I got this fix from tech support and was very happy when it worked.

Also some times, but rarely, it is also necessary to remove all references to Sony from your registry before re-installing Vegas. A good registry cleaner can do this for you if you find the fix doesn't work without it. just run the registry cleaner after you have uninstalled all your Sony software.

This fix saved my life, hope it works for you !

drbam wrote on 7/3/2010, 12:51 PM
Thanks Will. I appreciate your suggestion but doing an uninstall and then reinstall of all Sony programs is simply unacceptable for me. If this is the fix then I'll pass. Sony needs to wake up and take care of its customers by fixing their buggy software rather than continuing to suggest these unbelievably ridiculous workarounds.

So instead I'll keep urging my collaborator to migrate our projects over to Reaper which I have finally done after years of frustration with Vegas & Acid.

Geoff_Wood wrote on 7/4/2010, 1:55 AM
Um, you are complaining about installing in today's environment 'legacy' software, then not following the known remedy that even became unnecessary years ago ?! It's not even worth 20 minutes of your time (and not even one reboot) to achieve ?!

Have fun with Reaper, but at least try the current version of the product you are having problems with before spraying your venom which tars two versions subsequent to the one with the problem which was even updated to fix way back then.

jdexter wrote on 12/12/2010, 12:47 PM
I'm having the same problem with Vegas Pro 10.0a. Brand new computer, and just installed Vegas Pro 64 bit as the first piece of software. None of the VST plugins show up. Tried all the remedies mentioned earlier, to no avail. Had no problems with earlier versions of Vegas, on an older PC.
Steven Myers wrote on 12/13/2010, 5:50 AM
None of the VST plugins show up.

Your VST plug-ins are 64-bit versions, right?
jdexter wrote on 12/14/2010, 7:32 PM
Since I'm using some free VST plugins, I'm not sure if they are 64 bit or not. However, after more experimentation, I found that some of them will now load properly in Vegas, but most don't. I'm thinking now the ones that didn't load were VSTi plugins.
GrupoJyT wrote on 12/27/2010, 8:21 AM
Vegas, Acid and Sound Forge works fine with VST 2.2 Fx, but it does not support features in VST 3.0 standard, so if your Fx are VST3.0, you couldn't use it in Vegas
barfyman362 wrote on 4/26/2019, 4:23 AM

hi, i had the same problem. i do realize this was 9 years ago, but if you happen to have this problem

all u gotta do is right click the icon, and "run as administrator"

all your vsts will be there waiting.