waves crash in vv7

JHendrix wrote on 9/16/2006, 2:14 PM
im having crashes in 7...anyone else?

Seems it could be a Waves issue. I do have the lataest Waves updates...

Not sure which plug but i have a sesson with

reneq rendeessn rencomp renverb on busses- that is not crashing

and a session with

supertap, reneq, rendeess, rencomp, renverb , rbass, q4, q10, linEq, L2- that is crashing, and does not nor did it ever crash in VV6

I alwaysd use Stereo versions in VV


Spheris wrote on 9/17/2006, 8:53 AM
as far as I can tell - it looks like a calback crash - crash looks to be caused by multiple instances of the plugin interacting with the waveshells and the dx support routines ( waves really did shoot themselves in the foot by even bothering with vst support as they have already started backpeddling on the issue and hopefully will fix with a forthcoming version of tune that doesn't jimmy rig both rewire and some undocumented vst hook to just work)

remove references to the waveshells and the problem should stop there (as far as I know - the dx versions instantiate first and eliminate the need for the waveshells in the sony products anyway)

then remove both vstcache and dxcache entries from the registry and that should be it
JHendrix wrote on 9/19/2006, 3:46 PM
Just got this in another session

Sony Vegas 7.0
Version 7.0a (Build 115)
Exception 0x80000003 (breakpoint) IP:0xD98CA36
In Module 'Waves5.0.DLL' at Address 0xD950000 + 0x3CA36
Thread: ProgMan ID=0xBF0 Stack=0x201F000-0x2020000
EAX=0201f618 CS=001b EIP=0d98ca36 EFLGS=00000202
EBX=00000014 SS=0023 ESP=0201f610 EBP=ffffffff
ECX=0039d640 DS=0023 ESI=0e050ca0 FS=003b
EDX=0201f6c0 ES=0023 EDI=0039d640 GS=0000
Bytes at CS:EIP:
0D98CA36: CC F4 BE F9 E0 8D 0C 24 .......
0D98CA3E: EB 66 83 F8 01 75 2E 68 .f...u.h
Stack Dump:
0201F610: 0201F6C0 01F20000 + FF6C0
0201F614: 0201F618 01F20000 + FF618
0201F618: 00398790 00390000 + 8790
0201F61C: 55544553
0201F620: 00415F50 00400000 + 15F50 (vegas70.exe)
0201F624: 0D9DC340 0D950000 + 8C340 (Waves5.0.DLL)
0201F628: 0201F644 01F20000 + FF644
0201F62C: 00000007
0201F630: 0000000F
0201F634: 7C3A5665 7C3A0000 + 5665 (MSVCP71.dll)
0201F638: 00000005
0201F63C: 0039D640 00390000 + D640
0201F640: 0201F6C0 01F20000 + FF6C0
0201F644: FFFFFFFF
0201F648: 7C3A5686 7C3A0000 + 5686 (MSVCP71.dll)
0201F64C: 0D9DC340 0D950000 + 8C340 (Waves5.0.DLL)
> 0201F654: 0D9D7FFB 0D950000 + 87FFB (Waves5.0.DLL)
0201F658: 00000000
> 0201F65C: 0D98E823 0D950000 + 3E823 (Waves5.0.DLL)
0201F660: 0039D640 00390000 + D640
0201F664: 0201F6C0 01F20000 + FF6C0
0201F668: 0E0528B8 0E050000 + 28B8
0201F66C: 003972A8 00390000 + 72A8
> 0201F6B0: 00657079 00400000 + 257079 (vegas70.exe)
- - -
0201FFF0: 00000000
0201FFF4: 00519610 00400000 + 119610 (vegas70.exe)
0201FFF8: 00A7B160 00400000 + 67B160 (vegas70.exe)
0201FFFC: 00000000

How would I

remove references to the waveshells

do you mean deleate the wave shells from the VST folder that vegas looks at? Does it matter that I always choose Waves from the "Third Party" folder? (Actually, there is noting even in the "VST" folder when navagating to a plugin in VV , even though there are WaveShells in the VST folder.

then remove both vstcache and dxcache entries from the registry and that should be it


JHendrix wrote on 9/21/2006, 7:06 AM
To delete the DX Cache you should take these steps:

1. Click on Start > Run
2. Type: regedit
3. Now please go to HKEY_CURRENT_USER\Software\Sony Media Software\Vegas\7.04. Highlight the DXCache folder and delete it.
5. Close the Registry Editor window.
6. Restart you computer.
7. C:\Documents and Settings\"Your User Name"\Application Data\Sony\Vegas
8. Extract the folder "7.0" to your desktop.
9. Launch Vegas and see if this has any affect.
pwppch wrote on 9/27/2006, 7:43 PM
>>and a session with

supertap, reneq, rendeess, rencomp, renverb , rbass, q4, q10, linEq, L2- that is crashing, and does not nor did it ever crash in VV6<<

Can you be specific in how you have these Waves FX set up?

Which ones on what bus or tracks?

And specifics of the exact plugin and version you are using.

i.e. supertap means?
Super Tap 2 Taps Mod
Super Tap 6 Taps Mod

reneq means?
REQ 2 band, 4 band, or 6 band?

MacMoney wrote on 9/27/2006, 9:10 PM
Are you using them in a FX Chain?
If so what order?
Did you remove the Waveshell VST?

George Ware
JHendrix wrote on 9/28/2006, 12:36 PM
All latest Waves versions. download the file here:


same session is trouble free in 6 and crashes in 7. Its a 7 thing.

Yes, i removed the waveshells from the VST folder, however, I have yet to deleate the VST and DX cache....im paranoid about deleating from the reg.
MacMoney wrote on 9/28/2006, 6:41 PM
>Yes, i removed the waveshells from the VST folder, however, I have yet to deleate the VST and DX cache....im paranoid about deleating from the reg.

I know the feeling!

George Ware
pwppch wrote on 9/29/2006, 1:31 AM

Your project has allowed us to reproduce the problem.

We are working with Waves right now to identify the cause.

Thank you very much for providing the project.

JHendrix wrote on 9/29/2006, 3:32 AM
Thats great Peter, thanks
decrink wrote on 10/12/2006, 7:09 PM
Well, two revisions and I'm still crashing VV7 with Waves. Did the updates fix this for you guys?
pwppch wrote on 10/12/2006, 7:49 PM
Something to try:

In your Audio Device Preferences page, uncheck the

"Enable track buffering"


In most cases this has solved the problem with the Waves plugins.

Let us know if this solves the problem for you.


decrink wrote on 10/15/2006, 10:00 PM
First experiment worked! I brought in the veg that was crashing it out and it seemed to work, no crashes in a few minutes of use. Went back to projects that I'm finishing in VV6 and by adjusting the buffer on a few heavily laden Waves projects that were choking are running smoothly. Thanks for the tip.
donaldh606 wrote on 11/6/2006, 12:38 PM
Peter, thank you for the tip. I was having a similar problem in V7 and this seems to help.

agtm8 wrote on 11/7/2006, 5:10 AM

Still having problems......

taking away the "Enable track buffering" resolves Waves
stuttering but now if I,m playing audio, moving and envelope
or moving the plugins window, or zooming in-out, audio stuttering and
hipcups starts, it´s very dificult (almost imposibble) to work like that,
if I enable some "track buffering" it works better...

Please any help would be aprecciated.

Jay J wrote on 1/17/2007, 10:52 PM
I have the same issues with V7 and waves. The track buffer has helped although LinBroad and LinLow automation is useless. I get chopped audio when rendered. I went back and verified the same chopping in v6, although I didn't get the exceptions.

I will be submitting to waves. Sorry no solution.
Teetow wrote on 2/8/2007, 6:28 AM
Just chiming in - same problem. Using only Sony and Waves plugins.

Audio output is reduced to a series of lo-freq pulses - two of my buses show +593 dB peak output =) Bypassing all FX brings the output back to normal, but I get an exception as soon as I try to bring up the plugin chain dialog.

Track Buffering seemed to improve application response (no more semi-locking up), but the other issues remain. Let me know if you need the project file.
cchoy wrote on 2/12/2007, 5:48 PM
I'm using 7, and seem to be okay with most waves plugins... but i'm on 4.0....

Does anyone know if the DX or VST versions of the waves run better w/ Vegas?
donaldh606 wrote on 9/18/2007, 12:42 PM
I'm bringing this topic back up because in using the new Vegas 8 I've experienced the same behavior. I have unchecked the "Enable track buffering" and found that ver. 8 doesn't crash as often. However, I still have ver. 7-E installed and have had to "check" to "Enable track buffering" due to reoccurring audio stuttering post V-8 installation.
pwppch wrote on 9/18/2007, 11:22 PM
Make sure you have the latest and greatest from Waves. Waves has told us they fixed the problem that was causing these crashes.

donaldh606 wrote on 9/21/2007, 8:04 AM
Hey Peter, according to Wave website I am using the latest versions. And I had gone a few days without incident, but this morning tried to open a previous project and got the crash error below. Any suggestion you can offer is appreciated.

Sony Vegas Pro 8.0
Version 8.0 (Build 144)
Exception 0xC0000005 (access violation) READ:0x0 IP:0x0
In Module 'vegas80.exe' at Address 0x0 + 0x0
Thread: TrackRender ID=0x1004 Stack=0x576F000-0x5770000
EAX=0ed22d40 CS=001b EIP=00000000 EFLGS=00010206
EBX=0ee1dd90 SS=0023 ESP=0576f8b0 EBP=0576f9f8
ECX=0ed22cd8 DS=0023 ESI=0eefa6f8 FS=003b
EDX=0ed22cd8 ES=0023 EDI=00000000 GS=0000
Bytes at CS:EIP:
00000000: .. .. .. .. .. .. .. .. ........
00000008: .. .. .. .. .. .. .. .. ........
Stack Dump:
0576F8B0: 0EA47CEC 0EA40000 + 7CEC (MetaFlanger.dll)
0576F8B4: 00000000
0576F8B8: 00000000
0576F8BC: 0ED22D40 0ECF0000 + 32D40
0576F8C0: 0EEFA6F8 0EDF0000 + 10A6F8
0576F8C4: 0EEFA6F8 0EDF0000 + 10A6F8
0576F8C8: 00000000
0576F8CC: 3FF00000
0576F8D0: A0000000
0576F8D4: 00000000
0576F8D8: 076EB1C0 07630000 + BB1C0
0576F8DC: 00000000
0576F8E0: 0778DCD0 07630000 + 15DCD0
0576F8E4: 000011F8
0576F8E8: 00007148
0576F8EC: 00000000
> 0576F8FC: 7C90EE18 7C900000 + EE18 (ntdll.dll)
> 0576F900: 7C809E60 7C800000 + 9E60 (kernel32.dll)
> 0576F91C: 7C90EE18 7C900000 + EE18 (ntdll.dll)
> 0576F920: 7C9106F0 7C900000 + 106F0 (ntdll.dll)
> 0576F928: 7C9106EB 7C900000 + 106EB (ntdll.dll)
> 0576F92C: 78134EFE 78130000 + 4EFE (MSVCR80.dll)
> 0576F938: 78134F57 78130000 + 4F57 (MSVCR80.dll)
> 0576F9FC: 0E4926F9 0E490000 + 26F9 (Waves5.0.DLL)
0576FA00: 00000000
0576FA04: 0ED3648C 0ECF0000 + 4648C
> 0576FA08: 0EA53445 0EA40000 + 13445 (MetaFlanger.dll)
0576FA0C: 00000001
0576FA10: 0000AC44
0576FA14: 00000000
0576FA18: 0ED36418 0ECF0000 + 46418
> 0576FA48: 0EA79794 0EA40000 + 39794 (MetaFlanger.dll)
0576FA4C: 00001038
0576FA50: 0576FA64 05670000 + FFA64
> 0576FA54: 0EA79794 0EA40000 + 39794 (MetaFlanger.dll)
0576FA58: 0BF9FC60 0B9C0000 + 5DFC60
0576FA5C: 00000000
0576FA60: 00000000
0576FA64: 00000000
> 0576FA6C: 0EA6108B 0EA40000 + 2108B (MetaFlanger.dll)
- - -
0576FFF0: 00000000
0576FFF4: 0068D520 00400000 + 28D520 (vegas80.exe)
0576FFF8: 01DE2F18 01DE0000 + 2F18
0576FFFC: 00000000
pwppch wrote on 9/21/2007, 8:23 AM
Please fill out your system specs in your user profile.

donaldh606 wrote on 9/21/2007, 10:27 AM
Specs are there.
pwppch wrote on 9/21/2007, 12:49 PM
Don't see them. Make sure you set them to be visible.

donaldh606 wrote on 9/27/2007, 12:39 PM
They should be visable now. But haven't had an occurance of the problem in over a week. I think it may have been related to opening older edit lists. I have found that in opening some older edit lists from Vegas 8 I get slow downs and studdering of playback after 3 - 4 seconds of play, but no error messages.