When should GPU Acceleration be enabled?

Sidecar wrote on 9/2/2013, 5:09 PM
VP12 build 670 64bit 12gb RAM 16 threads

In the Preferences:Video tab you have the option to use or not use the GPU acceleration of the video card. In my case, an NVIDIA Quadro FX 580)

I notice when it's enabled, my footage has a hard time playing in real time.

When I turn the GPU off, the footage plays in real time.

Is the GPU acceleration for working with Boris BCC or some other graphics stuff? Is there an advantage to turning it off? Seems so to me.


Dan Sherman wrote on 9/3/2013, 10:17 AM
My experience would be,...never!
drmathprog wrote on 9/3/2013, 10:40 AM
A long time ago in a galaxy far, far away....
NormanPCN wrote on 9/3/2013, 10:47 AM
The GPU acceleration in the Video Prefs tab controls if Vegas uses OpenCL GPU acceleration for its own video effects and such.

Other tools such as Boris or NewBlue which are GPU accelerated have their own options to control if they use GPU.

Boris and NewBlue use OpenGL or acceleration and Vegas uses OpenCL. These APIs are distinct and if both exist on the same area of the timeline it causes some extra overhead to move between the two which may slow things down.
larry-peter wrote on 9/3/2013, 10:50 AM
When it works. These answers probably aren't helping you a lot if you're a new user, but issues with GPU acceleration have been beaten to death in this forum since SCS first incorporated it, so excuse the attitudes. We're all pretty fed up with it.

People are experiencing rendering problems, preview problems, crashes, etc., etc. with GPU enabled. Other users are able to use it fairly reliably, and the reasons why it works for some and not others has never been clarified. If you're using a modern, fast CPU in your system, you may not see performance improvements even if GPU acceleration can be enabled on your system. It seems to be an either/or thing, not where (as most of us would like) the GPU takes on the overload graphics processing that the CPU can't handle in real time.

You can only try it, and if/when problems arise, see if disabling GPU accel. solves them. Good luck.