Why the pause every one second when rendering WMV?

TeetimeNC wrote on 5/12/2008, 10:33 AM
I've been doing some WMV render tests, trying to get the fastest render for a given quality. I noticed that when rendering, the frame counter pauses every 30 frames (for 30 FPS, every 15 frames for 15 FPS - in other words, every one second of video). If I disable the audio stream, the pause goes away. Why would there be a pause like this when rendering audio? I've tried various audio templates under WMV but they all have this pause.

Anyone else experienced this? Any tips for speeding up the WMV render process? I'm using Vegas Pro 8.0b.



Nx wrote on 5/12/2008, 10:58 AM

I get the same behaviour. Using VP 8.0b. Tried various settings, but to no avail.

rs170a wrote on 5/12/2008, 11:12 AM
Jerry, I've noticed the same behaviour on my machine with both Vegas 7 & Pro 8.
This same discussion came up on the DV Info forum a year ago with no conclusions :-(

FrigidNDEditing wrote on 5/12/2008, 11:32 AM
I've always assumed it had something to do with the GOP ( seeing as how it's usually 30 frames between keyframes ), but I could well be wrong.

David Jimerson wrote on 5/12/2008, 11:50 AM
The pause is where it's writing the keyframe, so yes, it's a GOP issue. :)
Terje wrote on 5/12/2008, 7:42 PM
You should ask Microsoft about this. Sony uses the MS encoder, and the MS encoder, standalone, has the same behavior.
Chienworks wrote on 5/13/2008, 7:43 AM
Dave and David have it right. Try setting keyframes to different increments and you'll see the pause happens at those increments.

Dunno why anyone sees this as a problem. The encoder is just doing what it does, and it works.