macgregor wrote on 1/9/2005, 11:15 AM
Hello. I don know why when working in PAL and exporting to wmv if i touch any settings i cannot use 25 fps.

I mean, if i take for exaple the 256 and render the project it looks ok. But if i do minar changes as changing audio mode to mono for exaple, and i come back to the frame rate setting it moves automatically to 30 fps. Writing 25 would not fix the problem because as you move bacj 30 fps are again selected.
Anyone has notice this? how can i fix this problem?



taliesin wrote on 1/9/2005, 11:35 AM
Yes, seems to be a bug since many versions. And I wonder why none of the standard WMV presets offers 25 fps.

There's a way to go - anyway:

Do all your settings and enter the framerate of 25 fps at very last step. Now don't change to another tab, don't do anything than just hit "O.k.". Now it will be rendered with 25 fps.

To not have to use this workaround again and again - after you changed the framerate to 25 fps immediately enter a new preset name and save that preset. From now on you can simply recall your preset with 25 fps framerate. Even better: Now 25 fps even appears in the framerate drop-down list.
At least this works fine for me with Vegas 5 and WMV 9. Hope it also works on your system.

macgregor wrote on 1/9/2005, 12:10 PM
Nothing. As soon as i save the projet or i push ok and render the video it automatically sets up to 60 fps.

taliesin wrote on 1/9/2005, 12:17 PM
Mmh, sounds bad. And you use Vegas 5 and WMV 9?

Maybe someone else can help: Is there a way to share encoding presets so I could offer my WMV 25 fps template?

taliesin wrote on 1/9/2005, 12:19 PM
Ah, one thins I forgot. If you do like I described above (except saving the template) - true - the display of the encoder window switches back to 30 or 60 fps. But the rendered file itself should have 25 fps.

macgregor wrote on 1/9/2005, 12:50 PM
I get nothing. i have proven everything.

The only way to get 25 fps is using the default template. But if a change anything, the video will compress at 60 fps.

I can only edit audio settings without affecting this issue.
taliesin wrote on 1/9/2005, 1:19 PM
Oh, I just tested it once again. You are right. I now wonder how I got my individuell template saved in the past.
Hope somebody have a proper solution for us PAL victims ;-)

SonyTSW wrote on 1/9/2005, 7:34 PM
The frame rate field in WMV 9 custom is editable; you can type in 25.0 for PAL for example.

So you can customize one of the built-in presets by changing this value, then type in a new name for your template and hit the Save icon so you can use this template whenever you wish.

I'll add to our bug database that the PAL frame rate should be included in the dropdown by default.
taliesin wrote on 1/10/2005, 12:23 AM
Yes, you can enter 25 fps in the custom preset. But whenever you change any other adjustment value the framerate will be 60 fps when rendering then. There may be exceptions but in common there is no chance to render 25 fps when changing another adjustment. Don't rely on what you see in the encoder window display. Check the rendered file. 60 fps. I tested it with the custom preset having chosen 25 fps. I then used a custom image size and tried to save that preset. When I press the save-icon the frame-rate jumps back to 60 fps. If I click "o.k." instead of the save-icon I won't see the frame-rate jumping back but rendered output will be 60 fps and if I re-check the Video tab I see it's back to 60 fps.

macgregor wrote on 1/10/2005, 5:14 AM
Taliesin, you explained the whole problem perfectly.

Hope it fixes soon.

SonyTSW wrote on 1/10/2005, 7:59 AM

Thank you for the detailed explanation. We'll look into it.
SonyTSW wrote on 1/10/2005, 8:42 AM
I'm running Vegas 5.0b and I cannot repro this. Here's an example of something I tried:

1. PAL DV project settings, loaded a PAL avi file
2. Render As, select WMV 9
3. Choose the 256 kbps template, click Custom
4. Video tab, type in 25.0 for frame rate
5. Video tab, change image size to 160x120
6. Audio tab, change attributes to 48 kbps, 44 kHz stereo (just something different from the initial setting)
7. Click OK and render

The result is a 25 fps 160x120 WMV file with 44.1 audio.

I also tried changing the order of steps 4, 5, and 6. But I am always getting correct result.

[Edit: If you are relying on the Vegas Explorer tab to view the properties of the file, if the file was selected before you rendered then you'll need to refresh the explorer to see the updated properties]
taliesin wrote on 1/10/2005, 11:25 AM
I did exactly same procedure. But my rendered file has 60 fps.
Even - if I do step 1. to 6. and then go back to the video tab 60 fps is displayed again as frame rate.

I remember the "old PAL capture bug" ;-). There was an issue with PAL projects when Minimum Clip Length being activated. This made capturing always lose the media after capturing was done. Only way to override it was to completely deactivate Minimum Clip Length in the capture preferences.
I talk about this older issue because we reported this bug several times but no one in the United States could reproduce it, not even when using a PAL project with PAL DV source material. But anybody testing in the U.K. and Germany could. Then somebody from the Sony or Sonic Foundry team tried to set Windows to some kind of European base setting (sorry, don't know what exactly it was) and then he was able to reproduce the bug.

So maybe you only can reproduce that WMV render bug if you set your Windows system to a European country setting.

Hope we can sort this one out and thanks for the help anyway.

taliesin wrote on 1/10/2005, 11:32 AM
Maybe I should have added this info:

I tested it with Vegas 5.0b build 160 and Vegas 4.0d build 205 on Windows XP Home SP1. Same behaviour with both Vegas versions. (If it matters: Windows MediaPlayer 9 installed.)
I think it was same with Vegas 4 on Windows2000 Pro.

Redio wrote on 1/11/2005, 2:53 PM
Here’s a little pip from Denmark.

I have tried to produce this “bug”, but I can’t.

I have followed SonyTSW procedure and I am also getting correct result.

When I save a template with 25 fps, it stays correct at 25 fps when I make a new render.
All my rendered tests show up in Vegas Explorer with 25 fps.

Back in May 2004 I have also rendered two wmv-files, 1. 720z576 25 fps and one with 320x240p 30 fps. Why I rendered this with 30 fps I don't know. Also I don’t know if they were rendered with V4.0d or maybe V5.0a or b. plus WMP9 installed.

Hope it can help you.


Vegas 5.0d (build 194), Danish Win XP Sp2, and WMP 10 installed.

taliesin wrote on 1/11/2005, 3:02 PM
>> When I save a template with 25 fps, it stays correct at 25 fps when I make a new render.

If you don't change the parameters it's no problem (if you start with the custom template).

We have dozens of cases in our forum with same problems. I first thought I had the solution (the one I posted above) but seems like I was wrong.

SonyTSW, would be great if you could keep tracing the problem.

SonyTSW wrote on 1/11/2005, 9:55 PM
Yes, I do remember the "PAL capture bug". It happened when the Windows locale was set to a country where a decimal point is not a period (non-US format).

Tomorrow I will try changing my locale to see if I can now repro the bug -- thanks much for the tip!
taliesin wrote on 1/12/2005, 2:15 AM
I just got feedback from some other guys from our forum. They have a german local Windows setup but they cannot reproduce the bug. Only noticable difference on the system seems to be they use WindowsMediaPlayer 10. I use version 9. Still do not know which version the guy use who can reproduce the bug.
I will now update my WindowsMediaPlayer and see if it will change the WMV render situation in Vegas ...

farss wrote on 1/12/2005, 2:23 AM
For what it's worth I find that using WME is a better way to go. It's a bit of a monster to get your head around but it is free.
I'll have a fo down here and see if I can repo the problem, maybe it's got something to do with the way the water runs out of the sink.
taliesin wrote on 1/12/2005, 2:37 AM
Thanks for that tip. I would prefer using internal encoders. That's one point why I like Vegas. No need for external apps.

Still looking for a reason for this misbehaviour. I can't install WMP 10 on my system. My WinXP does not allow the install. Sometimes I really hate XP ...

taliesin wrote on 1/12/2005, 2:55 AM
I now could install WMP 10. But it does not solve the render problem. I have no further ideas for now what could be different on some systems that might cause the 25/60 fps trouble.

farss wrote on 1/12/2005, 3:19 AM
Well, tried it down under and it works just fine.
I think I did pretty much what SonyTSW said to do.
Started with the 256Kbps video template, went to Custom, Video and changed the frame rate to 25, changed the template name by adding "PAL" and saved it. Now the fps jumped back to 30 so I changed to to 25 again and the saved the template again and it stayed at 25.
Cancelled thhe render, started it again using the new template, rendered it out, dragged the wmv file into a new project and the media properties reports the frame rate as 25fps!

I do find any of the values hard to change logically, thats why I sometimes give up and use WME, you can control much more and it does seem to give better results.

taliesin wrote on 1/12/2005, 3:36 AM
Thanks for testing, Bob. Don't know what the difference and the reason is but I found a solution. Will post in a seperate posting.

taliesin wrote on 1/12/2005, 3:48 AM
I think I found a simple solution, though this one does not really explain the strange behaviour on some systems:

Just reinstall Vegas (or - because there is a fresh update to 5.0d available - install the update)!

I have a second system with Vegas installed on it. It is a VERY clean install. There is Windows XP Home, .NET-Frameworks and Vegas 5. No further installed software components.
On this system the 25 fps render (with modified settings) of WMV 9 worked fine. This made me curious.

I then downloaded the latest Vegas update 5.0d and installed the update on the system on which I had the WMV render trouble.
Checked the WMV render settings and everything is fine now!
I can type in 25 fps whereever I want, can modify any other setting, can switch the tabs, can save the new presets - I still have the 25 fps display and the render result also is 25 fps.

So I think the problem is a certain software or a certain driver which was installed AFTER the Vegas installation. I have no glue what software or driver this might be - too many installed meanwhile.

Now I hope MacGregor also can give us positive feedback when trying it ...

SonyTSW wrote on 1/12/2005, 9:11 AM
The 5.0d update added the PAL framerate to the WMV dropdown list so 25.0 should always work. But if you type in some other frame rate that isn't already in the list you may run into problems as noted above.