Vegas Pro 14 and Vegas2HandBrake

Kommentare

Skywatcher schrieb am 25.11.2016 um 22:06 Uhr

. . . . also, DebugMode Frameserver is "NOT" showing up in the "Render As" menu. I think that is the problem. Should I redo the whole installation process?

Skywatcher

Marco. schrieb am 25.11.2016 um 22:24 Uhr

Did you consider the infos given in the first post of this thread?

Skywatcher schrieb am 26.11.2016 um 00:11 Uhr

Yep! I followed that with the original build. It's when I uninstalled SVP13 when this happened.

Skywatcher

Skywatcher schrieb am 26.11.2016 um 03:05 Uhr

 * * UPDATE * *

I did a system restore back (before) I uninstalled Vegas 13. Everything is back working perfectly. In the future . . . I would like to uninstall Vegas 13 if I'm never going to use it again. For now . . . she rests.

Thanks again Marco!!! I appreciate you brother!!

Skywatcher

tripleflip18 schrieb am 28.11.2016 um 05:46 Uhr

Hi, i am wondering if anyone knows of a way to run 2 instances of Vegas 14 and at same time rendering 2 different files using handbrake at the same time... or 3 instances at the same time.  i got 22 cores intel and would benefit greatly if i was able to to 2 instances of rendering using handbrake at the same time!  Thank you guys!

Red Prince schrieb am 29.12.2016 um 22:20 Uhr

Copy file »Frameserver.x64.fio2007-config« from

»C:\Program Files\Sony\Vegas Pro 13.0\« (or path of appropriate Vegas Pro program folder)
to
»C:\Program Files\VEGAS\VEGAS Pro 14.0\«

I would, if such a file existed on my system. But I am certainly not going to buy Vegas 13 just so I can copy a file from it to my Vegas 14 path. I had Windows do the search for that file, and it is simply non-existent. Not even in my Vegas 12 folder, not anywhere.

He who knows does not speak; he who speaks does not know.
                    — Lao Tze in Tao Te Ching

Can you imagine the silence if everyone only said what he knows?
                    — Karel Čapek (The guy who gave us the word “robot” in R.U.R.)

Cornico schrieb am 29.12.2016 um 23:36 Uhr

Did you install  Frameserver 2.15 or Frameserver 2.14?
Appearing of that file in your Vegas 12 needs Frameserver 2.14 and using it once in Vegas 12

Red Prince schrieb am 30.12.2016 um 01:08 Uhr

2.15. I want it in Vegas 14, not 12. Besides, the link to 2.14 is dead, so 2.15 is the only one available.

Anyway, I have since read somewhere that when it asks you where to install the Vegas DLL, you must not accept the default but have to give it the path to your Vegas directory. So I did that. Now it finds and even loads the frameserver but nothing else happens. It never loads Handbrake.

I’m done with it. I only installed it out of curiosity and if it doesn’t work, it doesn’t work.

He who knows does not speak; he who speaks does not know.
                    — Lao Tze in Tao Te Ching

Can you imagine the silence if everyone only said what he knows?
                    — Karel Čapek (The guy who gave us the word “robot” in R.U.R.)

BruceUSA schrieb am 30.12.2016 um 01:16 Uhr

Any body able to frameserve 4K? I tried and it failed. Would be nice if we can do 4K with one click to handbrake.

Red Prince schrieb am 30.12.2016 um 04:43 Uhr

Any body able to frameserve 4K?

Aha, that may explain why I couldn’t get it to work. I have now tried again with a 1080p video and it went without a hitch.

He who knows does not speak; he who speaks does not know.
                    — Lao Tze in Tao Te Ching

Can you imagine the silence if everyone only said what he knows?
                    — Karel Čapek (The guy who gave us the word “robot” in R.U.R.)

Red Prince schrieb am 30.12.2016 um 05:07 Uhr

Actually, turns out I can frameserve 4k just fine. So, the problem was something else. But I went through the process of installing it all again, and this time it worked.

He who knows does not speak; he who speaks does not know.
                    — Lao Tze in Tao Te Ching

Can you imagine the silence if everyone only said what he knows?
                    — Karel Čapek (The guy who gave us the word “robot” in R.U.R.)

BruceUSA schrieb am 30.12.2016 um 05:36 Uhr

Actually, turns out I can frameserve 4k just fine. So, the problem was something else. But I went through the process of installing it all again, and this time it worked.

Red Prince.  Much appreciated.  You gave me the enthusiastic to try it again.  But I can't get it to work.  Can you verify the results HB clip, check in the property, details,  it is showing 3840x2160?

 

Red Prince schrieb am 30.12.2016 um 14:28 Uhr

Hello, BruceUSA, here is what MediaInfo says about the final result:

Video
ID                                       : 1
Format                                   : AVC
Format/Info                              : Advanced Video Codec
Format profile                           : High@L4.1
Format settings, CABAC                   : Yes
Format settings, ReFrames                : 1 frame
Codec ID                                 : avc1
Codec ID/Info                            : Advanced Video Coding
Duration                                 : 9 s 0 ms
Bit rate                                 : 8 840 kb/s
Nominal bit rate                         : 50.0 Mb/s
Width                                    : 3 840 pixels
Height                                   : 2 160 pixels

Display aspect ratio                     : 16:9
Frame rate mode                          : Constant
Frame rate                               : 24.000 FPS
Color space                              : YUV
Chroma subsampling                       : 4:2:0
Bit depth                                : 8 bits
Scan type                                : Progressive
Bits/(Pixel*Frame)                       : 0.044
Stream size                              : 9.48 MiB (97%)
Writing library                          : x264 core 148 r2708 86b7198
Encoding settings                        : cabac=1 / ref=1 / deblock=1:0:0 / analyse=0x3:0x113 / me=hex / subme=7 / psy=1 / psy_rd=1.00:0.00 / mixed_ref=0 / me_range=16 / chroma_me=1 / trellis=1 / 8x8dct=1 / cqm=0 / deadzone=21,11 / fast_pskip=1 / chroma_qp_offset=-2 / threads=12 / lookahead_threads=2 / sliced_threads=0 / nr=0 / decimate=1 / interlaced=0 / bluray_compat=0 / constrained_intra=0 / bframes=0 / weightp=2 / keyint=240 / keyint_min=24 / scenecut=40 / intra_refresh=0 / rc_lookahead=40 / rc=2pass / mbtree=1 / bitrate=50000 / ratetol=1.0 / qcomp=0.60 / qpmin=0 / qpmax=69 / qpstep=4 / cplxblur=20.0 / qblur=0.5 / vbv_maxrate=62500 / vbv_bufsize=78125 / nal_hrd=none / filler=0 / ip_ratio=1.40 / aq=1:1.00
Encoded date                             : UTC 2016-12-30 04:00:46
Tagged date                              : UTC 2016-12-30 04:00:46
Color range                              : Limited
Color primaries                          : BT.709
Transfer characteristics                 : BT.709
Matrix coefficients                      : BT.709
 

He who knows does not speak; he who speaks does not know.
                    — Lao Tze in Tao Te Ching

Can you imagine the silence if everyone only said what he knows?
                    — Karel Čapek (The guy who gave us the word “robot” in R.U.R.)

BruceUSA schrieb am 30.12.2016 um 17:26 Uhr

Red Prince.  Again thank you.

Red Prince schrieb am 30.12.2016 um 17:35 Uhr

You’re quite welcome.

He who knows does not speak; he who speaks does not know.
                    — Lao Tze in Tao Te Ching

Can you imagine the silence if everyone only said what he knows?
                    — Karel Čapek (The guy who gave us the word “robot” in R.U.R.)

BruceUSA schrieb am 30.12.2016 um 17:43 Uhr

Red Prince. I got it working now. It was my fault for not making sure it is display 3840x2160 before I click start HB. I was using a custom Youtube 1080P preset that caused the problem. I now made a 4K preset for it and it is now all good.

Red Prince schrieb am 30.12.2016 um 18:40 Uhr

Excellent! I’m glad you got it working.

He who knows does not speak; he who speaks does not know.
                    — Lao Tze in Tao Te Ching

Can you imagine the silence if everyone only said what he knows?
                    — Karel Čapek (The guy who gave us the word “robot” in R.U.R.)

Red Prince schrieb am 30.12.2016 um 21:54 Uhr

I should add that the main reason for me to use this is that I can finally have my 24 fps animations rendered at 24 fps instead of the 23.976 fps, which Vegas rudely insists on changing them to when I try rendering to mp4 directly from Vegas, even if the project is set to 24 fps (a thing that I find extremely annoying about Vegas, as they apparently never heard of film).

He who knows does not speak; he who speaks does not know.
                    — Lao Tze in Tao Te Ching

Can you imagine the silence if everyone only said what he knows?
                    — Karel Čapek (The guy who gave us the word “robot” in R.U.R.)

Nick Hope schrieb am 31.12.2016 um 17:11 Uhr

Handbrake 1.0.1 requires a couple of changes to the start_vegas2handbrake.bat file included with fs2hb_en_03.zip:

https://www.vegascreativesoftware.info/us/forum/handbrake-1-0-1-released-changes-i-made-to-frameserving-bat-file--105107/

Red Prince schrieb am 04.01.2017 um 18:23 Uhr

And just for the record, www.pismotechnic.com (for the file mount) seems to have vanished from the Internet today. Let’s hope it’s a temporary problem, though, according to my browser, it is not even in the DNS records. Which is very strange because the domain pismotechnic.com is not expired.

He who knows does not speak; he who speaks does not know.
                    — Lao Tze in Tao Te Ching

Can you imagine the silence if everyone only said what he knows?
                    — Karel Čapek (The guy who gave us the word “robot” in R.U.R.)

Red Prince schrieb am 04.01.2017 um 20:43 Uhr

It seems fixed now. 😀

He who knows does not speak; he who speaks does not know.
                    — Lao Tze in Tao Te Ching

Can you imagine the silence if everyone only said what he knows?
                    — Karel Čapek (The guy who gave us the word “robot” in R.U.R.)

Hoaxx schrieb am 06.02.2017 um 10:07 Uhr

Ran into trouble installing Send2Handbrake in Vegas Pro 14, maybe someone can help?

I have followed all instructions in the top post, but when I click on the Send2Handbrake toolbutton, I get the message:

C:\Program Files\VEGAS\VEGAS Pro 14.0\Script Menu\frameserve_scripts\Send2HandBrake.js(19) : Variable 'Timecode' has not been declared
C:\Program Files\VEGAS\VEGAS Pro 14.0\Script Menu\frameserve_scripts\Send2HandBrake.js(52) : Variable 'RenderStatus' has not been declared

Everything is working fine in Vegas Pro 13 and DebugMode is among the options in "Render As".

 

Edit: Got it to work finally. The solution was as strange as the error itself - all I did was open the Send2Handbrake.js file why Vegas was running, resaved it and now it miraculously works.

Still have some concerns, especially in regards to sound (48kHz > 44.1kHz. 24bit > 16bit) but I'll probably open a new question for that.

stew schrieb am 08.06.2017 um 06:27 Uhr

Hi, I just ran across this post, and Vegas2Handbrake looks very promising. I clicked on the link at the beginning of the thread, but it's asking me for a username/password in German. Is Vegas2Handbrake no longer available for download?