AC-3 Render as not registered message in Vegas 9

FixitMad0 wrote on 4/27/2016, 2:39 PM
Dolby Digital AC-3 Pro not working from under Vegas Pro 9 render as option.

The Fix:

Since I still could not find any help that worked, I did some digging around on my system and found this:

The ac3plug.dll under Vegas Pro 9 has a different file size than the same file located under the DVD Architect Pro 5.2 folder.

What I did is this:

I copied the ac3plug.dll located (on my system) under C:\Program Files (x86)\Sony\DVD Architect Pro 5.2\FileIO Plug-Ins\ac3plug


C:\Program Files (x86)\Sony\Vegas Pro 9.0\FileIO Plug-Ins\ac3plug

REMEMBER to First rename the ac3plug.dll under Vegas 9 to ac3plug.dll.old or something similar. I like to keep backups just in case. Do not have either DVDA or SVP running.

Once I performed this, AC-3 Render as NOW WORKS under Vegas Pro 9.

Just a note: This is on a Windows 7 x64 system that I tried this on and it is working.

Hopefully others will be able to get this working for their Paid For copies of Vegas and DVD Architect Pro


john_dennis wrote on 4/27/2016, 3:31 PM
Thank you for sharing your solution. This link exposes some of the idiosyncrasies of the order of installing Vegas Pro and DVD Architect. I think the issue has to do with Dolby and how the AC3 encoder is licensed. I have similar unnecessary herky-jerky playback issues with files containing ac3 on the iPad in certain wrappers with VLC.

Search words: install DVD Architect ac3

Search Forum : Vegas Pro - Video

Search: Any Date
FixitMad0 wrote on 4/28/2016, 4:33 PM
Hi John,

Thanks for sharing that link as well. I'm still not sure why this happened but I tried this on two different systems with the same result.

What clued me into the issue was looking at the About Dolby Digital AC-3 Pro File format Plug-in via Vegas and seeing that the Unlock key: was blank.

Copying my registered DVD Architect AC3plug.dll over, I now notice when I look at the About Dolby Digital AC-3 Pro Plug-in under Vegas the unlock key shows my key for DVD Architect instead of being blank.

I would have thought that with all the weird issues, SCS could have created some kind of copy utility or something. My install process was, Vegas Pro 9 first, then DVD Architect. I do not think that Vegas 9 was ever part of the Sonic Foundry line. Sonic Foundry stopped at Vegas 4 right when they sold it to Sony.

rraud wrote on 4/29/2016, 3:39 PM
As I recall VP and VMS has the Dolby 'studio' AC-3 encoder, whilst DVD Arc has the Pro' version which has more parameters. When installed, it should be usable VP, DVD-A and SF.