Audio cuts in and out with VMS 10

drguitar0001 wrote on 6/16/2010, 12:23 PM
A few weeks back, I came here complaining of video studdering when using a pretty powerful computer and VMS 8 Platinum when running HD video in the preview window. Folks told me to "wait until VMS 10 and all will be well". They were right. partially. The video runs smoothly in the preview window now, but the audio cuts in and out every half a second AND it is completely out of sync with the video.

I set up the preview window to be the same format as the original video and here are my computer specs:

Dell Studio XPS 435
Core i7 920
6gig ram
2 large SATA harddrives running at 7200
Realtek HD Audio ALC888s chip
ATI 4870 video

I updated all the drivers (even the audio drivers) to the most current ones.

What am I doing wrong?


MSmart wrote on 6/16/2010, 12:41 PM
You could go to the Audio Device preferences, Options > Preferences Audio Device tab and increase the Playback buffer and Track Buffer to see if that helps.

I haven't read your other threads so I don't know what video files/source you're using to address the sync issue. Maybe the above will help.
drguitar0001 wrote on 6/16/2010, 5:28 PM
I tried what you suggested and it did not make any difference at all. I can only guess that there is something silly that is keeping the program from working properly. Does anyone else have any ideas?

Markk655 wrote on 6/16/2010, 7:22 PM
You are referring to the preview window. If so, what is that set at? Have you tried other preview settings? Did that change help?
drguitar0001 wrote on 6/17/2010, 11:21 AM
I think I figured out why the audio is being chopped, but I do not know haw to remedy it. When I play the files outside of VMS 10, the audio is fine. It turns out that when I import the files into VMS 10, VMS chops the audio up so that every second there is a half of second of silence. So the problem happens during the import process.

Anyone have any ideas?
drguitar0001 wrote on 6/18/2010, 1:57 PM

No thoughts anyone? I emailed Sony support for an answer and am awaiting a response. It is a funny thing, I can open the same file in VMS 8 Platinum and the audio plays perfectly. The problem with VMS 8 is that the video studders in the preview window making it impossible to do any worth while editing.

Ivan Lietaert wrote on 6/18/2010, 2:07 PM
What is the source of your video?
MSmart wrote on 6/18/2010, 2:27 PM
Good point, video source and format has never been given.

However, I think the point is moot since the file plays fine in v8. I bet it's a v10 stability issue that hopefully will be addressed when the "a" patch is released. There is always an "a" patch.

Since you've reported it to tech support, I think you've done all you can until the patch is released.
drguitar0001 wrote on 6/18/2010, 5:07 PM
Video source is a Samsung HD camcorder that records in "H.264 HD " format (according to their specifications on their website). I believe the actual specific format is a standard H.264 (MPEG-4.AVC) according to the manual. The resolution of the file recorded is 1080/60i.

Any ideas?
Ivan Lietaert wrote on 6/18/2010, 9:30 PM
I would transcode the files with neoscene or mpeg streamclip.
Second possibility: render the sound only, ungroup and delete the original sound, and import the rendered sound instead. (a bit of pain if you have lots of events).
drguitar0001 wrote on 6/19/2010, 12:25 PM
Yep, I understand I can take lots of extra steps like splitting the file into separate audio and video, then code the audio into another format, then import them separately into VMS 10 and then resinc them so that they can be edited, but that seems like a lot of trouble if VMS 8 works fine with the files while VMS 10 seems to have probelms with the audio in the files.

Honestly, I may be asking too much, but it seems to me that a version of a program that is 2 versions newer should not have problems that did not exist in an earlier version. I guess my question should be, what changed to have the new version of the program have these problems and what settings need to be made in the program to rectify the problem?
Ivan Lietaert wrote on 6/19/2010, 2:18 PM
This kind of problem is usually cleared by adjusting the audio buffers.
You may want to change audio accelleration in Windows sound settings.
drguitar0001 wrote on 6/19/2010, 5:13 PM
Thank's for the reply Ivan. I already tried that both inside and outside the program. Still, that does not explain why this problem does not exist in VMS 8 and it does in VMS 10. For a moment, I thought it may be some sort of audio codec, but both programs would use the same codec unless the program itself uses its own internal codecs. In that case, that would explain the problem.
Ivan Lietaert wrote on 6/19/2010, 11:25 PM
Actually, I think both programmes do use their own codecs, they don't share them.
drguitar0001 wrote on 6/21/2010, 5:54 AM
Thanks Ivan, you may be right. I guess what concerns me most is that no one else seems to have this problem... this is stunning to me since my computer is a mass produced Dell. I will try to video record the problem and post it so that other folks can see what is going on.
Markk655 wrote on 6/21/2010, 8:42 AM
Just getting back to my original questions...what setting are you using for the preview window? Have you tried different ones?
drguitar0001 wrote on 6/21/2010, 11:54 AM
I had VMS 10 choose the format for the preview window and tried that first. The video was smooth and without stuttering, but the audio was chopped up "on, off, on, off...". Then I tried each of the other settings until I tried them all. The video worked in all of the settings, but the audio continued to stutter..

Any ideas?
Markk655 wrote on 6/21/2010, 12:34 PM
Just so I understand, you have tried lower res previews (such as Draft or Preview>Auto and made the preview box slower?

Do you have the preference set to show frame numbers for the preview? If you do, when you play the clips in the preview window, do you notice any dropped frames at all or is it always the correct frame rate (such as 29.97 fps for NTSC)? Just want to make sure that you aren't losing video without noticing too.

If you have a short file that you can upload, I can (and maybe others too) can check it out to see if we get the same behaviour.

Also, suggest to use Mediinfo and report back on video/audio formats explictly.
jonski wrote on 6/21/2010, 3:58 PM
drguitar0001 - you are not alone!
Mark - I'm not sure you're entirely "getting" what the problem here is.

It's not a question of preview size or speed or dropped frames, it's a question of the audio waveform actually chopped up wrong on import.
It works fine in Vegas 9, I even tried saving the file for you. Helpfully, it told me that "An error occurred. The reason for the error could not be determined".
How very helpful. Anyway, here's a screenshot of the chopped audio.
As drguitar says, it's exactly half a second of audio, then half a second of silence, and each half second of silence pushes back the audio by half a second so it gets more and more out of synch
Markk655 wrote on 6/21/2010, 6:25 PM
You are right - Not only did I not get it, I wasn't even close!

Does it happen to all of your media (if so are your camcorders the same)?

Can you upload a media clip that always gives you the the problem? Happy to have a look at it on my end. Also, what does mediainfo say about the media file in terms of properties?

What do the waveforms look like in the trimmer?
drguitar0001 wrote on 6/21/2010, 7:30 PM
Jonski, that is exactly the problem I am having. Is this a common problem and if it is, how come I have not been able to find other posts stating the same problem?

For those folks interested, I made a very low res video that shows the problem. First, I import a clip to VMS 8 Plat and there is no problem. Then I load the exact same file into VMS 10 HD and the problem become apparent. Finally, I show a screen shot of what VMS 10 does to the audio file.
drguitar0001 wrote on 6/21/2010, 7:47 PM
Here is the info you requested Mark:

Complete name : C:\Documents and Settings\Mike\Spring Concert\HDV_0005.MP4
Format : MPEG-4
Format profile : JVT
Codec ID : avc1
File size : 1.81 GiB
Duration : 15mn 6s
Overall bit rate : 17.1 Mbps
Writing library : SEC
@sec : UNG

ID : 1
Format : AVC
Format/Info : Advanced Video Codec
Format profile : Main@L4.2
Format settings, CABAC : Yes
Format settings, ReFrames : 4 frames
Format settings, GOP : M=1, N=30
Codec ID : avc1
Codec ID/Info : Advanced Video Coding
Duration : 15mn 6s
Bit rate mode : Variable
Bit rate : 17.0 Mbps
Width : 1 920 pixels
Height : 1 080 pixels
Display aspect ratio : 16:9
Frame rate mode : Variable
Frame rate : 59.940 fps
Minimum frame rate : 59.920 fps
Maximum frame rate : 59.960 fps
Color space : YUV
Chroma subsampling : 4:2:0
Bit depth : 8 bits
Scan type : Interlaced
Scan order : Top Field First
Bits/(Pixel*Frame) : 0.137
Stream size : 1.79 GiB (99%)
Title : HMX200
Language : English

ID : 2
Format : AAC
Format/Info : Advanced Audio Codec
Format version : Version 4
Format profile : LC
Format settings, SBR : No
Codec ID : 40
Duration : 15mn 6s
Bit rate mode : Constant
Bit rate : 128 Kbps
Channel(s) : 2 channels
Channel positions : Front: L R
Sampling rate : 48.0 KHz
Stream size : 13.8 MiB (1%)
Title : HMX200
Language : English

If you would like me to send you a sample video file, I can do that or you can grab a very short 2 second sample here: sample.MP4
Ivan Lietaert wrote on 6/21/2010, 9:05 PM
Ok, thanks to your example, I think I know what is going on: When audio plugins are not registered (or if the trial period ended), you'll will typically hear breaks like these, or even 'tuuuut'. I think you have some audio plugin active which you haven registered OR for which the registration went faulty.
So to start, go to the audio track and delete all the audio plugins (both for the track and for the event itself), and see if the problem is still there.
MSmart wrote on 6/21/2010, 9:51 PM
I found this thread:

I don't know if it applies but could this issue be related to QuickTime?
jonski wrote on 6/22/2010, 3:12 AM
ivan123 "[on the] audio track and delete all the audio plugins (both for the track and for the event itself), and see if the problem is still there."
Yes, still there.

MSmart: Read that, tried the dll, no better, and as for downgrading a third party app to an older, unsafe version just because a brand new commercial application relies on it, ain't gonna happen!

I've established it's only when using the mp4 from the camera - if I transcode it first, it's OK. But that ain't gonna happen either, as transcoding loses quality and takes time.

But it gets weirder - I dropped a transcoded mp4 onto the timeline to test this out. I then deleted the working file from the timeline, and dropped another mp4 from the camera on. Now, you ready for this? In the gaps where the camera file is chopped out, it was playing through the audio from the deleted clip! Here you go - don't know why, but Youtube doesn't seem to like the screencam file, but anyway, you can see enough to get the idea

You know, what I don't understand is that if I want to do a simple edit and save, I can download a tiny app for free called Avidemux and it works fine with all my files. Why can't Sony get it right?