Beware of QTF.

farss wrote on 11/10/2011, 5:41 AM
Having that Off by mistake caused me much grief. Really bad outcomes with mixed progressive and interlaced footage. The "P" ended up a juddery mess, half my cuts blinked and even the interlaced footage in parts was a bit juddery.
Not so obvious on the LCD monitors while editing but once burned to DVD and played back on a CRT TV, yuck.

Would be nice if Vegas had some mechanism to warn us that we're moving video around with quantization off. One ripple edit with it off can spell disaster.
On the other hand I haven't a clue why or when I turned QTF off :(

Bob.

Comments

PeterDuke wrote on 11/10/2011, 6:23 AM
To expand, Bob is referring to "Quantize to Frames". This is the first item in the Options menu. When QTF is turned on, there is a blue square enclosing its icon. You may have to look carefully to see it.

This is for Version 9. Other versions may have different indications. Version 11 has a tick when turned on with a blue square, and no icon or square when turned off.

Question: Why did SCS provide this trap? When would you want to turn QTF off? An audio only project?
vtxrocketeer wrote on 11/10/2011, 6:49 AM
I've turned it off for audio only projects where I need to synchronize audio tracks at the sample level. Otherwise, especially for video projects, I leave it on. And I've gotten 'stung' when I forget that it was off!

-Steve
amendegw wrote on 11/10/2011, 6:55 AM
"I've turned it off for audio only projects..."fwiw:



...Jerry
Marco. wrote on 11/10/2011, 9:12 AM
I once used to have "Show Unquantized event start" and "Show Unquantized event end" set to "TRUE" in the (int.) preferences. Thus draw a warning red line at Event edges which does not quantize to frames. There is no difference between audio and video events though. You either indicate any kind of events or none of them.

johnmeyer wrote on 11/10/2011, 9:39 AM
In addition to the hidden "internal" preference setting, which I too have set to true, and which immediately tells you that you're getting into trouble, I also have the old "Quantize to Frame" script which can correct the problems you've created. You still have to look at each even boundary, which can take quite a while on a long project, but it's still a lot faster than having to go back to an earlier version of the project and re-edit.

Wasn't there some change in how Vegas worked -- I think starting in Vegas 10, which I dont' use much -- where you could edit audio events at the sample level without turning off quantize?
vtxrocketeer wrote on 11/10/2011, 11:04 AM
@Jerry: thanks! I overlooked that check-box, which now explains why I was able to slip audio events in my video projects irrespective of the frames. I thought I had mistakenly unchecked QTF.

-Steve
jerald wrote on 11/10/2011, 11:47 AM
Hi, Bob,
I found that there is an available toolbar button for QTF that can be added to the toolbar via menu Options|Customize Toolbar.

I added the button to my toolbar so I can visually check (and change) the setting at any time without having to open a menu.

Jerald
farss wrote on 11/10/2011, 1:24 PM
Thanks Jerald,
I shall definately add that toolbar button.


Now that I've got this project from hell out the door and had a sleep on it a more signifcant realisation has dawned on me, no pun intended.


Apart from the QTF trap I had an exceptionally hard time avoiding having Vegas 9e crash on me during this project and that is most unusual. In fact the only way to get some stability was to load the footage from the Z5 camera into a V8 project and then open the saved V8 project in V9.

Thing is V8 had QTF On and V9 didn't. The QTF setting is not stored in the project file, it is an application environment variable. To further compound the number of variables I'm very certain that the Z5 camera records HDV with a subtle difference to the HC5. Footage from the HC5 was not a problem, only footage from the Z5. The Z5 may have had "Fast Record" enabled. I say this because the way Vegas had split the clips during capture was different for the HC5 footage and the Z5 footage.
With unquantized Z5 footage on the T/L V9e would crash the very instant I tried to trim the tail of a clip but not the head. What I've learned from this exercise is that the precise type of footage might be a very significant determining variable between Vegas working without a problem and becoming crash central.

Bob.
johnmeyer wrote on 11/10/2011, 1:34 PM
What I've learned from this exercise is that the precise type of footage might be a very significant determining variable between Vegas working without a problem and becoming crash central.That's another interesting observation. I say "another" because yesterday someone tracked down an instability on their system to having the "close media files when not the active application" preference enabled (which is the default). By un-checking this, that person achieved better stability.

In both these cases -- if either of them actually are pointing to a problem, rather than just being some action that coincidentally happens to correspond with the problem going away -- it appears that the instability can be caused by the way in which Vegas is asked to read the media. In once case, it is asked to re-read media which may have been altered by another application, and in your case, it is asked to read media which may not line up with expected frame boundaries.

So, based on what I'm reading -- although I haven't been able to do any tests because my trial expired just as Sony released this new version that may finally work with my video hardware -- I would give the following advice to anyone who is experiencing crashing:

1. Uncheck the "close media .." check box.
2. Make sure QTF is enabled before you start your project.
3. Enable the hidden quantize display setting so events will display red edges if they are not quantized. Run the Quantize to Frames script to fix this problem before proceeding with further editing.
4. Do not capture HDV with scene detection enabled (this one I have seen myself: it totally screws up the boundaries).

Perhaps others can add more.

Dan Sherman wrote on 11/10/2011, 1:39 PM
As a curious child I went to bed wondering where the sun goes when darkness blankets the earth.
All night I struggled to find the answer to the whereabouts of the sun.
Finally, it dawned on me!

Anyway I guess the lesson learned hear is more down to earth.
Leave QTF enabled, always and forever.
gwailo wrote on 11/10/2011, 1:41 PM
@amendgw

I leave that check box off on my audio projects for 1 important reason

It will let you edit to sub-frames BUT.....

If you move the clip to a new track, the starting edge of the clip is forced back on to the nearest frame, which often messes up sync

I would love if Sony corrected this behaviour, then I could just leave the option on

so I too have put the QTF button onto a toolbar so I can see it / toggle it on /off
NickHope wrote on 11/11/2011, 3:46 AM
+1 for the QTF toolbar button and "Show Unquantized event start" and "Show Unquantized event end" set to "TRUE" in the (int.) preferences. The discovery of that internal preference has been absolutely invaluable for me as I run some timelines with mixed 50i and 60i when I'm rendering for stock. I have that preference set in both 8c and 10e.
Zelkien69 wrote on 11/11/2011, 8:53 AM
I thought this was a warning for "Beware of QuickTime Files" Who can't relate to that?
Former user wrote on 11/11/2011, 9:41 AM
nick,

Thanks for that tip. I never knew that warning existed and I have had problems with files ending on nonquantized areas. That is a great option.

Dave T2