BlackMagic Decklink, Intensity, and Vegas 8

ForumAdmin wrote on 10/25/2007, 4:23 AM

Beta drivers for Vegas 8 are available from the Decklink website now:

Since these are beta drivers, neither company is going to accept support calls, but we both would like to know about your experience.

It is fine to park the info in this forum, in this thread.

Please make sure you list your system specs when you describe your experience, and if there's a problem please list a precise step-by-step repro.


Vegas dev team


John_Cline wrote on 10/25/2007, 1:12 PM
Vegas seems to recognize the Intensity Pro just fine and I can use it as a preview device. This is GREAT!

However, there is still the problem with Vegas and Intensity Pro MJPEG files which has existed since the release of Vegas Pro v8. I am assuming that it is related to the somewhat non-standard MJPEG files which the Intensity generates and the new MJPEG decoder in Vegas Pro 8. The decoded image is squished to 50% of its original vertical heaght and is displayed on the bottom half. (See image below.) Blackmagic MJPEG files used to act the same way in Virtual Dub, but Avery Lee, the author of Virtual Dub, found a specific workaround for this problem. (The source code for Virtual Dub is readily available.)

Otherwise Vegas works with the Intensity's YUV files just fine (and always has.) I am THRILLED that BMD and Sony have gotten together to integrate the Intensity Pro into Vegas.


John_Cline wrote on 10/26/2007, 12:36 AM
Am I the only one that has tried these new beta drivers with their Intensity Pro card????
MattWright wrote on 10/26/2007, 1:21 AM
Hi Sony and support

I am still having some problems, I have one system using a Deckling HD-Pro card running XP32 with 32 bit drivers of 6.6 and everything works great (well the display output anyway).

My problem is I also have a MultiBridge Pro box, attached to an XP64 bit system using the 6.6 XP64 drivers, and in this set-up Vegas can not see the Decklink card at all.

If you need me to test or Beta test anything, PLEASE let me know, I would be more than willing to spend some time to try and get this working.

farss wrote on 10/26/2007, 2:39 AM
The Intensity card seems to fill a very niche need, it was kind of interesting when it first came out but there's so many easier to use alternatives now.
Aside from that I can find no documentation on how to use it with Vegas, either from BMD or SCS.

I'll certainly be testing the new drivers with Digibetacam, I'm glad we've eventually got 10bit support.

MarkFoley wrote on 10/26/2007, 5:06 AM
I have one on the way...was just waiting for the drivers to be developed
Bill Ravens wrote on 10/26/2007, 6:13 AM

"....Easier to use alternatives...."
Such as?
willlisub wrote on 10/26/2007, 6:13 AM
I have vegas 8a and Intensity Pro

I just spent 3-4 hours messing with it.

Using Black Magics capture program, Media Express,
I still can't use the mjpeg files. They are squished as per John Clines previous post.
I can use the uncompressed files.

Haven't tried the preview out, but will. I currently used a 28" Viewsonic 1920x1080 computer monitor for previewing and it works fine.....

Can't capture via the Intensity Pro from within Vegas. Have to use Media Express from BM.

Had installation problems. Don't know how I fixed it but will outline my experience to help developers.

System is Windows XP Pro, overclocked quad pro, 4 GB Ram. I have many applications on this machine, so it's not a simple editing workstation. XP is current upgrades within last 10 days.

Vegas 8.0a was running fine.
Removed 1.7 Intensity drivers and app, rebooted, then installed the Intensity 1.8 with the BM Beta for Vegas.

Went tp launched Vegas 8.0a, I got the following error message.
An error occurred starting Vegas PRo
Error 0x80070002 (message missing)

Failed to initialize script host.....

I removed the intensity 1.8, tried to launch Vegas and got same error message.

Reinstalled both 1.7 and 8.0a a few times. Same error message. I manually deleted any registry entries for Black Magic.

Went and installed Vegas 8.0 and tried both 1.7 and 1.8 Intensity drivers. Vegas would launch.

Then loaded Vegas 8.0a and got same error messages.

Then went and deleted everything including the registry Black MAgic entries from the software section in two locations.

Am working now with the following sequence.
Removed Vegas 8 and Intensity. (Vegas 7 is still on machine)
Install Vegas 8.0. Remove it.
Install Vegas 8.0a
Install Intensity 1.8

It now works.

However, when I launch Capture Video from within vegas and select BlackMagic Decklink for capure device, I get a black screen. Can't capture anything other than the black screen from live camera Canon HV20 with hdmi....

I can go to Intensity capture (Media Express), and capture in either of their formats.

As stated above, the uncompressed works in Vegas just fine.
The Motion JPEG, comes in squished in Vegas, no matter what HD format I set the project to or whatever aspect ratio I set.

If I play the Motion JPEG files in Microsoft's media player, it scales properly.
If I play the Mition JPEG in a VLC player, I get the vertical 50% squish. That is width seems proper, but he height is squished to about 1/2 height.

quoka wrote on 10/29/2007, 1:11 AM
ALSO just spent 3 or so hours trying to get it running.

Run XPx64 SP2 on Xenon Nitro Dual Core Opteron 275 (4x processors).
Have Vegas7.0e on system, been running faultlessly with Decklink.

Installed and run VP8a OK.
(We install Vegas & all our apps into a separate disk partition to keep it away from the OS- have been doing this for years with Vegas)

Installed "DeckLink 6.6 x64.msi" and it runs OK with the BM "Deck Control" utility that comes with the driver - so this means the system has installed the decklink card and recognises it.

Started VP8a and go to the video devices tab and it doesn't see DeckLink - it sees "win sec display, AJA, ieee" but no DL.

Reinstalled V8 & BM drivers in different order, restarted many times but not recognizing we have the card installed.

Have noticed that BMD 6.6 has separate folders in its install directory for "Fusion/Photshop/Premiere" - but not Vegas(?).
Also V7 had a "DecklinkVideodevice.dll" in its 'Video Hardware Drivers' folder - but this isn't in the equivalent VP8 folder.
Can someone tell me what file(name) is supposed to be where(folder?) for VP8 to recognize the card.

Confused. Any help from Development Team greatly appreciated. Will bow down on knees and grovel to get attention as we desperately want to get 10bit capture and editing working.
quoka wrote on 10/29/2007, 6:20 PM
Has any one had a Decklink card working with VP8?
(using the new 6.6 BMD driver)
Frustrating lack of info from Blackmagic & SCS.
Do understand that BMD is supposed to be looking after integration, but there isn't the slightest amount of info on how to install succesfully.
We run XP_x64 with Decklink, as well as XP.
Sooooo Close.... yet so far!!
willlisub wrote on 10/29/2007, 9:32 PM

Beta drivers for Vegas 8 are available from the Decklink website now:

Since these are beta drivers, neither company is going to accept support calls, but we both would like to know about your experience.

It is fine to park the info in this forum, in this thread."

The above is from the first post and from the Sony Dev Team......
I posted my findings, and watched for a few days with no other comments or answers....

I came to the conclusion that this topic wasn't much interest to folks.

I have built over 150 video editing systems and most of the times stuff works or I can figure it out. This doesn't work and I'd bet it's an install issue. My setup is standard for Vegas and it doesn't work. I tired numerous times. I'm not willing to build a fresh machine to start from scratch. I'll wait a little longer before putting the intensity card on the resale block.

Hope to hear something soon.

To bad the interest is so low.

Please make sure you list your system specs when you describe your experience, and if there's a problem please list a precise step-by-step repro.


Vegas dev team
quoka wrote on 10/30/2007, 12:47 AM
Have now tried to get Decklink working on a standard 'XP' machine.(another 3 hours spent.... my previous post was for XP_x64))

Running XP Pro (32bit) on a Xenon Nitro Dual Xeon 3.4. (this is a qualified machine on BMD's website) Have massively fast HD's.

Decklink5.6/V7e has worked perfectly since year dot.(PAL mode)
Upgraded to V8.0e. Installed Decklink driver 'win_6.6'
(Had to change order of install to get decklink recognised - like willisub)
PREVIEW onto SDI monitor works - PAL

PTT/Capture issues -
CAPTURE: Use 'Internal Video Capture'
Get NO device properties - looks like it defaults to NTSC?, plus have nowhere to put in offsets.
Have to turn on 'Preview on external monitor' to get Capture to work.
Had to change setting in Windows Control Panel(settings) for Decklink to 'set black ref on video output in capture' - otherwise video is jumping all over the place and controller is inconsistent.
Have control of Digibeta deck - can Play and Shuttle.
Step backwards/forwards works, but wont show video when device is stopped - as checked in Capture Prefs option.
Timecode displays have a semi-colon (not a normal colon) on last frames field.(this may have always been there, just never noticed)
Cue to timecode works.
'Length' of clip is wrong - seems to revert to NTSC(30fps) time code.
In: 00:01:00;00 - Out 00;01:01;00 gives Length:00:00:00;28 - not ;25.
(BMD always had the out 1 frame wrong in their Deck Control utility.)
When Capturing it does a capture but then at end has error message:
"Failed to capture clip 'Clip 003.avi': Inaccurate timecode detected."
This could be because something has defaulted to NTSC, not PAL.
It then deletes the file.

Using a BM10 bit Quicktime file captured using the BMD Deck Control utility - 30 secs long.
Device type: Blacmagic Decklink - NO PROPERTIES(again)
Tried outputting SONY YUV 10bit
Deck control worked but when it came to output it crashed:
As it started outputting (Sony YUV) only black was on the the output. This only lasted a second before crashing.
Error message:
Sony Vegas Pro 8.0
Version 8.0a (Build 179)
Exception 0xC0000005 (access violation) READ:0x0 IP:0x9C03E19
In Module 'DeckLinkVegas.dll' at Address 0x9C00000 + 0x3E19
Thread: ProgMan ID=0x668 Stack=0x303F000-0x3040000
EAX=00000000 CS=001b EIP=09c03e19 EFLGS=00010202
EBX=00000000 SS=0023 ESP=0303fddc EBP=02c71c3c
ECX=054a3010 DS=0023 ESI=01b35d08 FS=003b
EDX=009a7b1c ES=0023 EDI=0303fe4c GS=0000
Bytes at CS:EIP:
09C03E19: 8B 08 50 FF 51 1C 3D 76 ..P.Q.=v
09C03E21: 32 31 30 8B 8E 48 06 00 210..H..
Stack Dump:
0303FDDC: 02C71C3C 02A90000 + 1E1C3C
0303FDE0: 0935BAF8 09240000 + 11BAF8
0303FDE4: 0023C208 00140000 + FC208
0303FDE8: 0023C228 00140000 + FC228
0303FDEC: 00809E68 00400000 + 409E68 (vegas80.exe)
0303FDF0: 00000000
0303FDF4: 02C71C3C 02A90000 + 1E1C3C
0303FDF8: 00000004
0303FDFC: 02C6E2EC 02A90000 + 1DE2EC
0303FE00: 7C80FF98 7C800000 + FF98 (kernel32.dll)
0303FE04: 01B3639C 01B30000 + 639C
0303FE08: 00000001
0303FE0C: 13590000 13590000 + 0
0303FE10: 00000000
0303FE14: 00000000
0303FE18: 00000000
> 0303FE4C: 006A7AA0 00400000 + 2A7AA0 (vegas80.exe)
0303FE50: 00000430
> 0303FE54: 006A914C 00400000 + 2A914C (vegas80.exe)
0303FE58: 0303FF10 02F40000 + FFF10
0303FE5C: 00000000
0303FE60: 00000000
0303FE64: 0023C440 00140000 + FC440
> 0303FE6C: 09C9A4A4 09C00000 + 9A4A4 (DeckLinkVegas.dll)
0303FE70: A606F974
0303FE74: 0303FE98 02F40000 + FFE98
> 0303FE78: 09C97F13 09C00000 + 97F13 (DeckLinkVegas.dll)
0303FE7C: 00000001
> 0303FE80: 09C043A7 09C00000 + 43A7 (DeckLinkVegas.dll)
- - -
0303FFF0: 00000000
0303FFF4: 00525180 00400000 + 125180 (vegas80.exe)
0303FFF8: 00AD8658 00400000 + 6D8658 (vegas80.exe)
0303FFFC: 00000000

Hope this all helps as it seems to be tantalizingly close to working.
All programs have teething problems so quite happy to try again when a fix or help info becomes available
OH WELL Back to Vegas 7, 10 bit still alludes us.

quoka wrote on 10/30/2007, 12:59 AM
Just re-read what I posted, need to amend one point on PTT.
Did output using "PAL SD YUV" (8bit) and had the same crash.

I'm feeling like a lone ranger here (land down under)
farss wrote on 10/30/2007, 3:05 AM
"I'm feeling like a lone ranger here (land down under)"

I wish I didn't have so much else on my plate or I'd have a bash at it too.
Bob, (also from down under)
ForumAdmin wrote on 10/30/2007, 8:54 AM
Beta driver update 10/30/07

Blackmagic Design does not include Vegas support in the 64-bit version of their installer. Please keep in mind that Vegas does not officially support any 64-bit OS variant at the present time.

Support for Vegas in the DeckLink 6.6 beta release (32-bit) works best with Vegas 8.0. In Vegas 8.0a the property pages that allow you to configure the DeckLink settings in Vegas do not appear. Both companies are working together to resolve this issue.

quoka wrote on 10/30/2007, 8:08 PM
Thanks ForumAdmin/SCS,

Would have been nice to know not to use 8.0a before I devoted so much time to it, I suppose you also found out the hard way.
The following is from the BMD Driver download page, please note it says "XPx64" - "Sony Vegas 8 support (Beta)"

>DeckLink 6.6 for Win XP x64, Server 2003 x64, Vista 64bit
>25 October 2007
>This software update adds: Sony Vegas 8 support (Beta), >improved support for Adobe Creative Suite 3 Production Premium, >Analog input anti-alias filter control on DeckLink HD Extreme and >various stability and performance improvements. Please check the >included "read me" for more information.
>Download 10.84 MB
This was probably just a typing oversight on their behalf.

Very aware that you don't support 64-bit OS, but thought I would try as VP8 runs fantastic under XP_x64.(not game to try Vista!)
Looking forward to getting it working so we can move onto VP8, Decklink, 10 bit files, 32 bit images...... all the good things in VP8.
Let me know if you want me to try versions/configurations.



willlisub wrote on 10/31/2007, 5:37 PM

Thanks ForumAdmin/SCS,

yes, it would have saved me 4-5 hours of wasted time also if I'd known to use 8.0 instead of 8.0a.

What did I do wrong other than to try to get it working.......

Hard to believe a little text file with the download couldn't have been included to tell what versions have been tested.

quoka wrote on 10/31/2007, 11:41 PM
Just an Update....... from BMD.
Great to see progress and response. I have happily tested and spent time and will again as soon as an update comes out.
All a step closer to having an app that we can proudly say is Pro and as good as any other NLE.
Viva Vegas!!!! Bring on 64bit!!!

>Yada, Yada ....
>........... but they needed to be compiled on 8a.

>So either late this week or early next, we will have a new version of the
>driver (6.6.1 I think) that will be compiled on the Vegas 8a version. That
>should work as it is supposed to.

>Sorry for the wait on that.

>Joshua Helling
>Director of Support
>Blackmagic Design Inc.
GaryAshorn wrote on 11/2/2007, 4:46 PM
So Decklink is getting things together with Sony to make it all work? Which card are most using? I have followed this for way to long and I really need Vegas to talk to my RS422a decks. I want to frame accurately insert and edit back and forth from capture to PTT with my decks on component output. I have looked at their cards and want to add it if I can make them all work like I did with my other system. I was looking at the Decklink SP but may go Extreme to move on to the HD world. If you get this working it will be great. Thanks

MattWright wrote on 11/9/2007, 11:59 AM
Hi There.

I have just downloaded and tried BlackMagic Drivers versions 64 bit 6.6.1, in XP64, and just as I suspected it did not work, with the same probklem as before, the preview device just does not show up in Vegas as an option.


After looking around I noticed that in the Vegas8 directory, in the "Video Hardware Drivers" directory, that there was no refernce to Decklink at all.

I compared this to a system that worked, running XP32 and the 32bit drivers and there was a file there called "DeckLink Vegas.dll"

So just a complete lucky try, I copied this file onto the 64bit system, and hey Presto, it only worked, I can now get the option to select the Multibridge as a preview device and, to my complete surprise I even get an output which seems to work. Although not 100%, but it works.

So my conclusion is that the 64bit drivers supplied by Decklink just do not install correctly, or they do not put this dll into the correct place.

I will have a really good look at this Monday, but at least we may be able to get an output from the Decklink now in 64bit systems.

Quoka if you PM me, I can send you the dll which sort of worked, basically the thing which didn't work was if I selected an HDV 1440x1080 50i Project in Vegas it would only preview in SD mode, but if I selected a 1920x1080 50i project it would output perfectly in HD.

This is fantastic, at least I feel I am getting somewhere, I brought this MultiBridge Box over a year ago, and have been fighting ever since with Vegas to get it to work.

What I can't understand is that I have been in communication with BlackMagic over this issue for a quite a few weeks now, and it would seem a simple problem, but they haven't managed to come up with any suggestions.

Matt Wright
heehaaw wrote on 11/9/2007, 1:36 PM
Contrary to what has previously been mentioned that there is little demand/interest in getting Blackmagic decklink/ multibridge pro working seamlessly with Vegas 8. I can assure you that the debate going on via DVX100 users group, Creative Cow, VASSt etc. seems to indicate there is significant interest from numbers of pro's and 'amateurs' . I have spoken extensively to dealers of the Blackmagic line in the UK and emailed blackmagic re the technical problems (which they are working on). But there's the feeling that Sony have passed the buck. Surely its in the interests of Sony and blackmagic to make this duo sing in harmony. If it did seamlessly, both would sell like 'hot cakes'. Vegas works wonderfully with multiple formats and standards all we need to do is get Blackmagic and Sony (sorry Vegas) to talk to each other....
John_Cline wrote on 11/9/2007, 2:03 PM
v1.8.1 of the Intensity Pro drivers have been posted as of today, November 9th. v6.6.1 of the DeckLink and Multibridge drivers have been posted as well.


(NOTE: I just installed the Intensity drivers and the issue of the Intensity MJPEG files being displayed at 1/2 vertical size that I mentioned in a message above has not yet been resolved.)
willlisub wrote on 11/10/2007, 1:59 PM
I have gotten the same results.

Uncompressed shows up in Vegas 8 just fine.
MJPEG is still 1/2 size on the vertical

The MJPEG plays back properly in the windows media player, but is also squished in the VLC player.....

It sure isn't much fun testing releases that don't work.

I wish someone from Sony or Black Magic would jump in here and tell me they have a Vegas setup with MJPEG video that is properly displayed.....

John_Cline wrote on 11/10/2007, 3:06 PM
A new feature in Vegas Pro v8 is a built-in MJPEG decoder and Vegas Pro v8 will properly decode MJPEG files created with the PicVideo MJPEG codec. As I mentioned above, Avery Lee (the author of Virtual Dub) discovered that BMD MJPEG files are non-standard and implemented a fix in Virtual Dub's built-in MJPEG decoder, I would think that Sony could do the same with Vegas.

Perhaps there is a way to disable the built-in MJPEG decoder in Vegas and have it use the Video for Windows Black Magic MJPEG codec instead. Vegas v7 wouldn't even recognize the video stream in a BMD MJPEG file, at least v8 is seeing it, but just not handling it properly.

While it's certainly nice to be able to use the Intensity Pro for video preview in Vegas, what I really need is for Vegas to handle Blackmagic MJPEG files properly! I would think that this would be an easy fix.

bsizeluv wrote on 11/11/2007, 9:15 AM
Since few people have commented here in this thread, I thought I'd offer my two cents and confirm that my experience with the latest Intensity driver (1.8.1) with beta support for Vegas 8x and Vegas 8a running on 32bit XP preciselly mirrors that of willlisub and John Cline. I look forward to future updates ironing out these issues as I purchased both products upon learning of BMD's intention to support content capture via Vegas 8x.