Build 373 - Instantly crashes when importing Prores422 media

MarcAndreBilodeau wrote on 11/23/2020, 12:07 PM

Hi all!

Just updated Vegas to latest build (373).
I tried importing my Prores422 files and as soon as I click on a prores media file, boom, Vegas crashes.

I have not changed anything, everything was working just fine with the other build. I eve edited a video this weekend and everything was fine.

Any clue of what is going on?

Error log provided here :
 

Extra Information
   File:                C:\Users\marca\AppData\Local\VEGAS Pro\18.0\dx_video_grovel_x64.log
   File:                C:\Users\marca\AppData\Local\VEGAS Pro\18.0\svfx_video_grovel_x64.log
   File:                C:\Users\marca\AppData\Local\VEGAS Pro\18.0\svfx_Ofx1_1_plugin_x64-'de.magix_StyleTransfer' (0, Multiple Contexts).log
   File:                C:\Users\marca\AppData\Local\VEGAS Pro\18.0\svfx_Ofx1_1_plugin_x64-'de.magix_StyleTransfer' (0, Filter).log
   File:                C:\Users\marca\AppData\Local\VEGAS Pro\18.0\svfx_Ofx1_1_plugin_x64-'de.magix_Colorization' (1, Multiple Contexts).log
   File:                C:\Users\marca\AppData\Local\VEGAS Pro\18.0\svfx_Ofx1_1_plugin_x64-'de.magix_Colorization' (1, Filter).log
   File:                C:\Users\marca\AppData\Local\VEGAS Pro\18.0\ocio_x64.log
   File:                C:\Users\marca\AppData\Local\VEGAS Pro\18.0\dx_grovel_x64.log
   File:                C:\Users\marca\AppData\Local\VEGAS Pro\18.0\gpu_video_x64.log

Problem Description
   Application Name:    VEGAS Pro
   Application Version: Version 18.0 (Build 373)
   Problem:             Unmanaged Exception (0xc0000005)
   Fault Module:        C:\Program Files\VEGAS\VEGAS Pro 18.0\vegas180.exe
   Fault Address:       0x0000000000000000
   Fault Offset:        0x0000000000000000

Fault Process Details
   Process Path:        C:\Program Files\VEGAS\VEGAS Pro 18.0\vegas180.exe
   Process Version:     Version 18.0 (Build 373)
   Process Description: VEGAS Pro
   Process Image Date:  2020-10-27 (Tue Oct 27) 05:36:20

Comments

MarcAndreBilodeau wrote on 11/24/2020, 8:27 AM

Here is one of the file that is causing Vegas to crash.
https://wetransfer.com/downloads/bb0dbc948c08b212a5ca38b6f03c1bdf20201124132951/8b27ed041258c5f69c4c08111901249b20201124133015/4ab7bb

I think it may have to do with the Embedded proxy system with the camera.
The file is prores422 but there are embedded proxies for playback, and those are H265.
Maybe it is this double video system that causes vegas to crash...

Also, here is the MediaInfo for the file.
-----------

General
Complete name                            : E:\JSB\Jsb grands jardins\CFAST\DCIM\A005\A005C0022_20200715014622_0001.MOV
Format                                   : MPEG-4
Format profile                           : QuickTime
Codec ID                                 : qt   2004.06 (qt  )
File size                                : 1.58 GiB
Duration                                 : 31 s 765 ms
Overall bit rate mode                    : Variable
Overall bit rate                         : 428 Mb/s
Encoded date                             : UTC 2020-07-15 05:46:22
Tagged date                              : UTC 2020-07-15 05:46:22
com.zcam.camera.prepend                  : v0
CameraMaker                              : Z CAM
CameraModel                              : E2-F6
com.zcam.camera.sn                       : 501D0050134
com.zcam.camera.fw                       : 0.96
com.zcam.camera.movieType                : MOVIE
com.zcam.camera.lut                      : Z-Log2
com.zcam.camera.iso                      : 400
com.zcam.camera.storage                  : AVpro256
com.zcam.camera.aperture                 : F2.8
com.zcam.camera.lensType                 : TAMRON SP 70-200mm F/2.8 Di VC USD G2 A025
com.zcam.camera.lensFocalLength          : 200mm
com.zcam.camera.focusDistance            : 3441mm
com.zcam.camera.nd                       : clear
com.zcam.camera.whiteBalanceMode         : Manual
com.zcam.camera.whiteBalanceKelvin       : 5600K
com.zcam.camera.whiteBalanceTint         : 0
com.zcam.camera.sharpness                : Weak
com.zcam.camera.noiseReduction           : Off
com.zcam.camera.projectFps               : 23.98
com.apple.proapps.shootingRate           : 23.98
com.zcam.camera.captureVfr               : Off
com.apple.proapps.cameraName             : A
com.apple.proapps.reel                   : 005
com.zcam.camera.battery                  : 15.5V
com.zcam.camera.temperature              : 26.6°C
com.zcam.camera.shutterSpeed             : 1/120
com.zcam.camera.splitIndex               : 0
com.apple.proapps.clipID                 : A005C0022_20200715014622_0001
com.zcam.camera.hash                     : 4876

Video #1
ID                                       : 1
Format                                   : ProRes
Format version                           : Version 0
Format profile                           : 422
Codec ID                                 : apcn
Duration                                 : 31 s 698 ms
Bit rate mode                            : Variable
Bit rate                                 : 387 Mb/s
Width                                    : 4 096 pixels
Height                                   : 2 160 pixels
Display aspect ratio                     : 1.896
Frame rate mode                          : Constant
Frame rate                               : 23.976 (24000/1001) FPS
Color space                              : YUV
Chroma subsampling                       : 4:2:2
Scan type                                : Progressive
Bits/(Pixel*Frame)                       : 1.826
Stream size                              : 1.43 GiB (90%)
Writing library                          : ZCAM
Language                                 : English
Encoded date                             : UTC 2020-07-15 05:46:22
Tagged date                              : UTC 2020-07-15 05:46:22
Color primaries                          : BT.709
Transfer characteristics                 : BT.709
Matrix coefficients                      : BT.709

Video #2
ID                                       : 2
Format                                   : HEVC
Format/Info                              : High Efficiency Video Coding
Format profile                           : Main@L3.1@Main
HDR format                               : SMPTE ST 2086, HDR10 compatible
Codec ID                                 : hvc1
Codec ID/Info                            : High Efficiency Video Coding
Duration                                 : 31 s 740 ms
Bit rate                                 : 32.8 Mb/s
Width                                    : 1 280 pixels
Height                                   : 674 pixels
Display aspect ratio                     : 1.899
Frame rate mode                          : Constant
Frame rate                               : 23.976 (24000/1001) FPS
Color space                              : YUV
Chroma subsampling                       : 4:2:0
Bit depth                                : 8 bits
Bits/(Pixel*Frame)                       : 1.584
Stream size                              : 124 MiB (8%)
Language                                 : English
Encoded date                             : UTC 2020-07-15 05:46:22
Tagged date                              : UTC 2020-07-15 05:46:22
Color range                              : Limited
Color primaries                          : BT.709
Transfer characteristics                 : BT.709
Matrix coefficients                      : BT.709
Mastering display color primaries        : R: x=0.060000 y=0.330000, G: x=0.300000 y=0.150000, B: x=0.640000 y=0.600000, White point: x=0.312700 y=0.329000
Mastering display luminance              : min: 0.0000 cd/m2, max: 0 cd/m2
Codec configuration box                  : hvcC

Audio
ID                                       : 3
Format                                   : AAC LC
Format/Info                              : Advanced Audio Codec Low Complexity
Codec ID                                 : mp4a-40-2
Duration                                 : 31 s 765 ms
Bit rate mode                            : Variable
Bit rate                                 : 128 kb/s
Maximum bit rate                         : 256 kb/s
Channel(s)                               : 2 channels
Channel layout                           : L R
Sampling rate                            : 48.0 kHz
Frame rate                               : 46.875 FPS (1024 SPF)
Compression mode                         : Lossy
Stream size                              : 487 KiB (0%)
Language                                 : English
Encoded date                             : UTC 2020-07-15 05:46:22
Tagged date                              : UTC 2020-07-15 05:46:22

Other
ID                                       : 4
Type                                     : Time code
Format                                   : QuickTime TC
Duration                                 : 31 s 698 ms
Frame rate                               : 23.976 (24000/1001) FPS
Time code of first frame                 : 01:46:22:00
Time code, striped                       : Yes
Title                                    : 005
Language                                 : English
Encoded date                             : UTC 2020-07-15 05:46:22
Tagged date                              : UTC 2020-07-15 05:46:22

 

RogerS wrote on 11/24/2020, 9:43 AM

Thanks @MarcAndreBilodeau I confirmed that it crashes the latest build of Vegas upon import. Does it have an option not to embed the proxy file?

I am jealous of how much metadata this camera saves. Sony is stingy in comparison!

MarcAndreBilodeau wrote on 11/24/2020, 9:53 AM

Thanks @MarcAndreBilodeau I confirmed that it crashes the latest build of Vegas upon import. Does it have an option not to embed the proxy file?

I am jealous of how much metadata this camera saves. Sony is stingy in comparison!

It has indeed alot of metadata saved in the files :)

I tried to turn off proxies and tried again but yet, still crashes.

So, I did a rollback of my system and got back to Build 334 and it works again now.
Pretty frustrating..

Anyways, will wait next time before updating the software.
Thanks for confirming the issue, do you know who I should refer to to have the engineers have a look at the problem to hopefully have it working back in the net update?

Have a great day,

Marc

harry-worth wrote on 11/24/2020, 10:08 AM

Does not crash on my system. Works on V17 and V18

.

MarcAndreBilodeau wrote on 11/24/2020, 10:12 AM

Does not crash on my system. Works on V17 and V18

.

What build?

It crashes on Build 373.

I rolled back to Build 334 and it works again.

Problem is it craches with latest update.

andyrpsmith wrote on 11/24/2020, 10:16 AM

just having a go to see how it goes on my system

andyrpsmith wrote on 11/24/2020, 10:27 AM

Crashes V18, V17 & V16 don't crash but I cannot load the clip to timeline.

andyrpsmith wrote on 11/24/2020, 10:31 AM

OK by enabling legacy HEVC encoding V18 does not crash but still cannot load it to the timeline.

MarcAndreBilodeau wrote on 11/24/2020, 10:33 AM

Thanks @MarcAndreBilodeau I confirmed that it crashes the latest build of Vegas upon import. Does it have an option not to embed the proxy file?

I am jealous of how much metadata this camera saves. Sony is stingy in comparison!

Would you mind trying with Legacy HEVC encoding?

andyrpsmith wrote on 11/24/2020, 10:34 AM

I can play the clip in trimmer but only the sound. Also same in Power DVD it only plays sound not video.

andyrpsmith wrote on 11/24/2020, 10:45 AM

I'm playing with happy Otter to transcode to MP4

andyrpsmith wrote on 11/24/2020, 10:48 AM

Yes can play it Video and sound. Look at that worth the $64 black Friday purchase.

andyrpsmith wrote on 11/24/2020, 10:49 AM

Looks like a massive hot tub lake, love the mist

set wrote on 11/24/2020, 3:26 PM

I can confirm this media crashes in my VP18b373, but not in VP17b452.

And, this is not a 'similar' ProRes that we probably knew.

*Left mediainfo data is my prerendered Magix Intermediate - and right side is your media sample.

Recorded with Z-CAM E2-F6 ?

I believe the HEVC part that causes crash.

Last changed by set on 11/24/2020, 3:34 PM, changed a total of 2 times.

Setiawan Kartawidjaja
Bandung, West Java, Indonesia (UTC+7 Time Area)

Personal FB | Personal IG | Personal YT Channel
Chungs Video FB | Chungs Video IG | Chungs Video YT Channel
Personal Portfolios YouTube Playlist
Pond5 page: My Stock Footage of Bandung city

 

System 5-2021:
Processor: Intel(R) Core(TM) i7-10700 CPU @ 2.90GHz   2.90 GHz
Video Card1: Intel UHD Graphics 630 (Driver 30.0.101.1191)
Video Card2: AMD Radeon RX470 4GB VRAM (Driver Version
21.30.23.04 / 21.Q4.Dec3 / 30.0.14011,2006)
RAM: 32.0 GB
OS: Windows 10 Pro Version 21H2 OS Build 19044.1586
Drive OS: SSD 240GB
Drive Working: NVMe 1TB
Drive Storage: 4TB+2TB

 

System 2-2018:
ASUS ROG Strix Hero II GL504GM Gaming Laptop
Processor: Intel(R) Core(TM) i7 8750H CPU @2.20GHz 2.21 GHz
Video Card 1: Intel(R) UHD Graphics 630 (Driver 30.0.101.1191)
Video Card 2: NVIDIA GeForce GTX 1060 6GB GDDR5 VRAM (Driver Version 472.84)
RAM: 16GB
OS: Win10 Home 64-bit Version 20H2 OS Build 19042.1415
Storage: M.2 NVMe PCIe 256GB SSD & 2.5" 5400rpm 1TB SSHD

 

* I don't work for VEGAS Creative Software Team. I'm just Voluntary Moderator in this forum.

DavidKamatoy wrote on 11/25/2020, 4:25 AM

I am not sure about Prores422 but Ive had similar issues and so per my last post Ive been transcoding footage into Cineform AVI using Adobe media encoder before using vegas. Everything was fine until just recently, but maybe I have just been not pushing the 373 build.

In general this is kind of weird. One of the reasons many people used Vegas back in the day was that you could edit Canon and multiple formats without transcoding. While we all realized it was probably better to transcode footage, the system didn't crash all the time.

Hope we can all get through the bugs.

Moving on...

RogerS wrote on 11/25/2020, 6:30 AM

@DavidKamatoyThat doesn't have much to do with this thread on a ProRes file with HEVC embedded in it. My understanding is that Cineform has issues in a post-32 bit world as it works through the deprecated QuickTime decoder. Here are some alternatives: https://www.vegascreativesoftware.info/us/forum/version-17-and-cineform--117795/?page=3

harry-worth wrote on 11/25/2020, 10:04 AM

Just updated to 373... File loads OK... Added a bit of contrast to see the nice scenery

RogerS wrote on 11/25/2020, 7:33 PM

Just updated to 373... File loads OK... Added a bit of contrast to see the nice scenery


What's different about your system? Legacy HEVC enabled? Do you have other settings changed from defaults?

NickHope wrote on 11/26/2020, 12:57 AM

For me, it opens in VP17 build 452 with qt7plug.dll (Quicktime). It opens in VP18 build 373 with mxhevcplug.dll if I have "Enable legacy HEVC decoding" checked in the File I/O preferences. Otherwise it hangs/crashes VP18.

harry-worth wrote on 11/26/2020, 3:06 AM

I don't have anything special about my system.. Just default.. One thing I did find out is that if I do NOT enable the Depreciated QuickTime plugin, the video it detected at 4096x2160. 23.976 and loads OK

If I enable the QuickTime plugin, Vegas does not prompt to say if I want to use those detected setting, so if I just add a small image ( 640x480 ) then the video just assumes that size as well.... but I guess the res is 1280x720 as that is also in the Meta listing and could be the proxy?.

The picture is how it is detected without QT enabled.. Not sure what actually going on.

 

 

harry-worth wrote on 11/26/2020, 3:36 AM

Ops... I forgot that it takes on the old settings, so in File I/O I do have Legacy AVC and Legacy HEVC both enable...