Cineform and Vegas: two cats in a bag?

vtxrocketeer wrote on 12/19/2011, 2:04 PM
This is NOT a criticism of either cat. I just wonder if they get along anymore.

I'm a long time user of Vegas and Cineform (NeoScene) as my preferred intermediate codec for multi-generational edits. Starting at Vegas 10, 32 or 64 bit, compatibility with Cineform avi's presented increasingly prickly but not intractable issues.

In Vegas 11 ( Build 425) my Cineform-based projects got real twitchy, but still I managed to edit end render. I turned off GPU support and that helped much (likely because I have an older GPU).

Now I installed Build 510/511 and Vegas suddenly can't/won't render to a Cineform intermediate ("codec not found" or words to that effect). Ever. Uninstall, reinstall Cineform to ensure the latest codec version. Same. I switch to Lagarith -- no problem; butter smooth renders. Back to Cineform, won't render. Vegas sometimes crashes, but mostly just gracefully tells me that it can't locate a correct codec. Huh?

I'm sure this will invite posts of folks with no problems -- that's OK by me. My point is to draw attention to the TREND: anecdotal forum reports here and elsewhere seem to validate my suspicion and present woes that Vegas and the Cineform codec are like two cats in a bag.

I spent some time today taking a hard look at Lagarith and UT, among other lossless avi codecs. But I have MOUNTAINS of Cineform files that I will need to access in the future and, dangit, I paid for a license for working software. (Also, I have finite amounts of storage; Cineform is real nice in this regard.)

What say others, especially as to Build 510/511 and Cineform?

-Steve

Comments

Laurence wrote on 12/19/2011, 3:24 PM
As much as I hate to say it, I have to go all the way back to Vegas 9 to use Cineform reliably.
vtxrocketeer wrote on 12/19/2011, 3:44 PM
Laurence, "reliably" catches my point. I don't see posts of Cineform/Vegas utterly failing to work together or always working, just not working reliably. I swear it's the only codec I have that works some of the time. <sigh>

At the moment, I'm also trying to claw my way out of cineform's activation labrynth after deactivating and uninstalling. Good gosh, how arcane could it possibly get? If find my way out, then I have to worry again about renders.

Hrrmmmm...
Serena wrote on 12/19/2011, 3:54 PM
Sony has provided this advice on the Vegas / Cineform co-habitation:
"We do have a known issue listed which matches this issue in our database - to be resolved in a future update of the application.

The response on the escalation indicates that the problem with intermittent black frames on Cineform AVI files has been going on for a long time. The behavior is consistent with memory over-usage when working with a lot of uncompressed AVI's that the codec cannot handle. If you are using uncompressed CineForm AVIs the best advice for a work around is to use as few clips in your project as possible, and before attempting a render, close and re-open the project."

In detail I find this confusing, since it seems unlikely that Neo (the codec) is having difficulties and take it to mean that Vegas has memory handling problems that Sony hope to fix sometime. They might mean that the rendering codec (say MPEG2) has memory problems, but again I don't see why that should be so. Just Vegas, I should say.
Is the problem worse in V11? I've given up V11, for the time being.

vtxrocketeer wrote on 12/19/2011, 5:02 PM
Serena, I'm not even at the point of getting black frames. This is a showstopper. Literally.

I managed to reinstall and activate a fresh, updated copy of NeoScene and the Cineform codec. I rebooted, loaded a single event (a Cineform avi or HDV) into my build 511 timeline, clicked to render to Cineform...BAM. Failed. Same as before: "No compatible video codec was found."

I rendered out to a Blu-ray compliant MPEG-2. Also to Lagarith (again). Both went very smoothly.

Argh. Anyone else? I haven't reverted to Build 425 or to 10.0.

EDIT: rolling back to Build 425 did NOT fix the problem. Also, trying the same in 10.0(e) similarly failed. The next most recent Vegas version was 8 for me, and I'm not going back that far. So, I still can't render out to a Cineform intermediate. Now I'm really stuck. Something global must have changed upon (1) updating Vegas, (2) Cineform codec, or both. Ludicrous.

I hate to be a sole whiner when perhaps something about my system caused the problem. But here...uh-uh. Cineform in 10.0(e) worked for me. Now it doesn't. It also worked in Build 425. Now it doesn't.
malowz wrote on 12/19/2011, 6:11 PM
since the beginning i had problems with cineform. even trying to get help here, trying to explain problems got no result.

solution? Canopus HQ codec. im using for about 4 years i think, NEVER had a problem. works 100% all the time. its VBR quality-based and even got alpha channel ;P

too bad canopus don't sell it separately...

modified a few batch render script plus code from a bunch other ones. put video on timeline, run script, select destination folder, and it convert to intermediate. HD>HD or HD>SD in a few clicks.
Serena wrote on 12/19/2011, 7:04 PM
Just tried a render to avi using Neo YUV/filmscan1 and that went OK in b510.
vtxrocketeer wrote on 12/19/2011, 8:02 PM
Thanks, Serena. Those are my preferred CF settings, too. I guess it's hit and miss. I'm somewhat confident that a HDD reformat and fresh install of everything would help. But, shucks, I don't have 5h to kill.

I just installed and tried the UTVideo Codec. Wow. Really nice and stable. Butter smooth. I couldn't make Vegas crash. But the avi files are enormous, about 3x the size of Cineform avi's.

Steve
Marc S wrote on 12/20/2011, 12:56 AM
I've found Vegas and Cineform combo to be troubling since Vegas 9 and Vegas 10. I've stayed away from Vegas 11 so I can't comment on that. From numerous interactions with Cineform tech support I came to the conclusion that it seemed to be more of a Sony problem and that there is not much of a working relationship between the two companies. In addition, since Cineform was purchased by GoPro they seem to have very little development of the codec. We used to get updates of the time, now almost never.

I'll probably be looking another codec in the future because Cineform files rendered in Vegas still do not work properly in other programs such as After Effects (the black levels jump from 0IRE to 7.5 IRE) so the whole idea of a multi-program codec does not work when using Vegas and Cineform.
NickHope wrote on 12/20/2011, 3:03 AM
With regard to Vegas compatibility for 3rd-party codec .avi files, the wheels fell off at version 9.0d. Since then there has not been a version that didn't demonstrate serious compatibility problems, including slow loading of files (9.0d to 10.0a) or black clips (10.0b onwards, and to some extent pre-10.0b).

You can try replacing C:\Program Files\Sony\Vegas Pro 10.0\FileIO Plug-Ins\aviplug\aviplug.dll with a version from 9.0c or earlier.

As I use Lagarith and UT-video-codec files in my projects, I am currently experimenting with the aviplug.dll files from 9.0a and 9.0c in 10.0e (32-bit). Haven't made my final choice yet though.

Amendegw posted a screengrab the other day that made me think the file might now called aviplug2.ll in V11. Can't find it now and haven't got V11 myself.

Some incomplete notes:

aviplug.dll Versions:

Vidcap 8 - 1.2.0.4129

Vidcap 10 - 1.2.0.4129

Sound Forge 9 - 1.2.0.7372

DVDA 4.5 - 1.2.0.9525

DVDA 5.2 - 1.2.0.12443

Distributed on Creative Cow from 32-bit 10 - 1.2.0.12529

-----

8.0c - 1.2.0.8505

9.0a? - 1.2.0.9787 (recommended by SCS to fix slow avi load)(64 bit version is 1.2.0.9786)

9.0b - ?

9.0c - 1.2.0.10486 (Tom Pauncz & Tim Tyler say this fixes slow avi load)(I get some UT-video black clips)

9.0d - 1.2.0.11664. Slow load first appears.(64-bit version = 1.2.0.11663)
Notable fixes/changes in Version 9.0d
* Added support for timecode in XDCAM EX AVI/DV files.
* Fixed a smart render issue with MXF PAL DV rendered to AVI PAL DV.
* Fixed an issue that could prevent audio from appearing for certain AVI files.

9.0e -
Notable fixes/changes in Version 9.0e
* Fixed an issue that caused AVI files to load slowly. (MIGHT NOT HAVE WORKED)

10.0a - Slow load still exists. Roll back to 1.2.0.9787 works.

10.0b - Appears to fix slow load, but not documented. Black clips???

10.0c - Loads fast. Black clips had appeared by now. Was a quick SonyAVC-only fix.

10.0d - Loads fast (VanLazarus & Brian Standing says black clips problem exists).

10.0e - 1.2.0.13249 - loads fast but black avi clips (64-bit = 1.2.0.13250).
amendegw wrote on 12/20/2011, 4:33 AM
"Amendegw posted a screengrab the other day that made me think the file might now called aviplug2.ll in V11.Nick, is this the screengrab you're referring to?



"Original Filename: avi2plug.DLL" - What does that mean? I did a windows search of my c: drive and could not find an avi2plug.dll.

...Jerry

System Model: Alienware Area-51m R2
System: Windows 11 Home
Processor: Intel(R) Core(TM) i7-10700K CPU @ 3.80GHz, 3792 Mhz, 8 Core(s), 16 Logical Processor(s)
Installed Memory: 64.0 GB
Display Adapter: NVIDIA GeForce RTX 2070 Super (8GB), Nvidia Studio Driver 527.56 Dec 2022)
Overclock Off

Display: 1920x1080 144 hertz
Storage (12TB Total):
OS Drive: PM981a NVMe SAMSUNG 2048GB
Data Drive1: Samsung SSD 970 EVO Plus 2TB
Data Drive2: Samsung SSD 870 QVO 8TB

USB: Thunderbolt 3 (USB Type-C) port Supports USB 3.2 Gen 2, DisplayPort 1.2, Thunderbolt 3

Cameras:
Canon R5
Canon R3
Sony A9

NickHope wrote on 12/20/2011, 4:57 AM
Yes thanks Jerry. No idea what "Original filename" refers to. So it looks like it's still called "aviplug.dll" in VP11.

For those with problems, I think it's worth replacing aviplug.dll with an old one from 9.0a to 9.0c and seeing what happens (all at your own risk of course!). You can always just switch it back without losing anything, as long as you keep good backups of your data.
amendegw wrote on 12/20/2011, 5:47 AM
This is interesting, the Version now seems to track the Vegas Build number:



...Jerry

System Model: Alienware Area-51m R2
System: Windows 11 Home
Processor: Intel(R) Core(TM) i7-10700K CPU @ 3.80GHz, 3792 Mhz, 8 Core(s), 16 Logical Processor(s)
Installed Memory: 64.0 GB
Display Adapter: NVIDIA GeForce RTX 2070 Super (8GB), Nvidia Studio Driver 527.56 Dec 2022)
Overclock Off

Display: 1920x1080 144 hertz
Storage (12TB Total):
OS Drive: PM981a NVMe SAMSUNG 2048GB
Data Drive1: Samsung SSD 970 EVO Plus 2TB
Data Drive2: Samsung SSD 870 QVO 8TB

USB: Thunderbolt 3 (USB Type-C) port Supports USB 3.2 Gen 2, DisplayPort 1.2, Thunderbolt 3

Cameras:
Canon R5
Canon R3
Sony A9

vtxrocketeer wrote on 12/20/2011, 6:22 AM
It's some cold comfort to know that I'm not alone.

Replacing the aviplug dll from 9 is an interesting (to me) workaround, but since I never had 9, it's not a workaround for me. Anyway, it just strikes me as folly that you'd have to dig into the guts of Vegas to cajole cooperation from a codec that you PAID for when, in contrast, free codecs like Lagarith and UTVideo work just fine.

So far I really like UTVideo. Most of my media sits on a fast RAID, so timeline performance in Vegas, even at Best/Full, isn't a problem. It is when the media sits on one of my slower RAIDs, however. That is to be expected with such gargantuan UTVideo avi files. I guess the tidiness of files is the only aspect of Cineform that I'm going to miss.

Steve
NickHope wrote on 12/20/2011, 7:44 AM
The Avid DNxHD Quicktime is another viable, free option as a near-lossless intermediate you might try.

In 10.0e am getting trouble with black clips with UT-Video codec, in certain scenarios that I'm trying to establish a pattern for. It's looking like the 9.0c aviplug.dll doesn't fix it for me.
vtxrocketeer wrote on 12/20/2011, 7:50 AM
Nick, do your avi woes manifest themselves as (a) black clips appearing on the timeline, (b) rendered black clips, (c) isolated black frames within otherwise normal clips, or (d) combo of the above?

I might as well keep an eye out for more trouble.

Thanks for the tip on the DnxHD codec. I'm aware of it and am keeping it in mind.
NickHope wrote on 12/20/2011, 8:38 AM
(a) black clips appearing on the timeline (but of course they would also render black from those black clips).

There is a thread on it here.

I still haven't established a repeatable pattern for it, but in my case it's related to using Lagarith or UT-video on the timeline, and may be related to having a 2nd copy of Vegas open, or some of the file also open in an external application. I seem to be able to fix it by restarting Vegas and reopening the project.
vtxrocketeer wrote on 12/20/2011, 9:38 AM
Thanks, Nick. Got it.

My unhappy discovery comes in the middle of a major project with all Cineform avi media events. While I'm able to still edit, I'll have to render to UTVideo for further processing. At that stage, I guess I'll find out whether the black bug will bite me, too.
diverG wrote on 12/20/2011, 2:52 PM
Cineform + Vegas seems pc build sensitive.
I have VP10 & 11 on a Tosiba i5 laptop and Vegas & cineform (v554) work smoothly as I would expect.

On my main machine I was plagued this either the odd black clip or black bits within a clip. In the end I uninstalled cineforn 554 and went back to v261 and then installed later versions on top. I find that v323 works OK.
I took this up with Jake Segrave of cineform but in the end it came down to if it works leave it at that. There is to be no more development beyond v554.

I’m slowly coming to the conclusion that VP is a tool to render out to Avid DxHD and the boot into XP and go back to using Avid 7v2.

Sys 1 Gig Z370-HD3, i7 8086K @ 5.0 Ghz 16gb ram, 250gb SSD, 2x2Tb hd,  GTX 4060 8Gb, BMIP4k video out. (PS 750W); Vegas 18 & 19 plus Edius 8WG DVResolve18 Studio. Win 10 Pro (22H2) Bld 19045.2311

Sys 2 Gig Z170-HD3, i7 6700K @ 3.8Ghz 16gb ram, 250gb SSD, 2x2Tb, hdd GTX 1060 6Gb, BMIP4k video out. (PS 650W) Vegas 18 plus Edius 8WG DVResolve18 Studio Win 10 Pro (22H2) Bld 19045.2311

Sys 3 Laptop 'Clevo' i7 6700K @ 3.0ghz, 16gb ram, 250gb SSd + 2Tb hdd,   nvidia 940 M graphics. VP17, Plus Edius 8WG Win 10 Pro (20H2) Resolve18

 

David Newman wrote on 12/21/2011, 7:43 PM
We aren't fighting -- clever thread title though. While there does seem to be some bugs that are impacting CineForm support in Vegas, we haved work with Sony to enable closer CineForm integration with Vegas than other immediate codecs. In Vegas 9, CineForm appeared and was accessed just like Lagarith/DNxHD/etc, as a Video for Windows or QuickTime codec, while these APIs are old and proven, they are inherently 8-bit (QT with some exceptions -- hacks,) and yet Vegas was now 32-bit stuck with 8-bit I/O. In Vegas 10/11 they moved to using the CineForm SDK, bypassing 8-bit VFW, getting more speed and more control over quality. More now with 3D support, which CineForm natively handles. We feel pretty confident that the SDK is robust as it is used by 25+ vendors now, although the Vegas implementation is unique so we continue to work with Sony Vegas's engineering team when issues arrise.

David Newman
Sr. Dir. Software Engineering at GoPro (a.k.a. CTO, CineForm.)
Laurence wrote on 12/21/2011, 8:46 PM
There is nothing like having to comb through an entire render, eyes peeled looking for an odd black frame here and there only to miss it and have it jump out at you later. Looking over all the raw footage looking for black frames, then looking over a finished project, a couple of seconds at a time afraid to blink, is just way too stressful. As much as I would like to use your product, I simply can't anymore. If I were you, I would be taking this VERY seriously.
David Newman wrote on 12/21/2011, 9:16 PM
Laurence are you addressing me? Black frames is known to be a codec independent issue within Vegas, happens with many formats, and I hope Sony is taking it that seriously (and it is a total PITA.) We take very seriously anything we can address on our end. I made the post above to explain both that CineForm/GoPro is committed to quality and a good working relationship with all NLE vendors, and how CineForm is integrated in to Vegas which limits what we can address. The thread suggested CineForm wasn't working with the Sony team, and that is not the case. Find a bug in the codec and we will fix it as fast as we can. The fault you mentioned is not a failure in any of our components -- I wish it was, as then I could fix it.
Serena wrote on 12/21/2011, 9:31 PM
Just to bore again with an old analogy: the F-111 fighter-bomber was the breaking point for airframe and propulsion integration. Responsibilities for airframe and engines were assigned to different firms and when significant performance problems were encountered the airframe people blamed the engines and the propulsion guys blamed the airframe design. This matter of who was responsible for the integration of the two systems was a tired old debate, but after the F-111 debacle contracts specified responsibility.
The Vegas/Cineform problem seems to be related, each company being comfortable that their own product is flawless and that the responsibility for fixing integration problems lies with the partner. It is something of a breakthrough that Sony accepts that memory handling needs to be improved.
vtxrocketeer wrote on 12/21/2011, 9:54 PM
David, thanks for chiming in. I had hoped my very first sentence made for a neutral post, but I can understand that it might have suggested uncooperative partners. That was not my intent (nor is it my understanding).

At this point, with no workable solution between the *combination* of Cineform and Vegas on my end, I have that sinking feeling from adolescence when the girl says,"Let's just be friends." Time for me to move on because it ain't working out. If a total system reformat and install of software is the cure, or if Sony somehow figures out how to make the codec work reliably, then I'll come back.
Laurence wrote on 12/21/2011, 10:22 PM
Thanks David. I get black frames with both Cineform and some .mov formats that I get stock footage in. What you're saying makes sense. Whatever it is, every time I use a format that gives me random black frames it is just horrible. It's like I am introducing needles into the haystack that I am working with. It is a real show stopper of a problem.

As it seems to be Sony's problem, I sure do wish they would fix it. They are doing quite terrible damage to your product's reputation by leaving it broken.

Is there some way you could patch around the limitations of whatever mistake is in the Sony code? I really miss using Cineform and judging by the fact that this problem has lasted through several generations of Vegas now, I have my doubts that they are ever going to fix it if it is left up to them.