EricLNZ wrote on 9/21/2023, 6:50 AM

Please provide more information. In what way did your codec(s) fail?

Kauko-Suominen wrote on 9/21/2023, 7:33 AM

Trying opening mp4 or mts files to copy timeline come error: the activation of codec failed.

Kauko-Suominen wrote on 9/21/2023, 7:34 AM

How can I change codec if it is wrong.

Kauko-Suominen wrote on 9/21/2023, 7:42 AM

I found it. I renamed compoundplug directory. It helps............

Kauko-Suominen wrote on 9/21/2023, 7:49 AM

But only mts audio opened. So not solved but obviously codec is wrong.

Reyfox wrote on 9/21/2023, 7:52 AM

Have you tried resetting/uninstalling/reinstalling VP16?

Kauko-Suominen wrote on 9/21/2023, 7:58 AM

Yes, twice. But no succes. I installed Microsoft HEVC codec earlier but I removed it. Maybe it went totally?

Reyfox wrote on 9/21/2023, 8:26 AM

The M$ HEVC codec would possibly only affect those created files. The other ones should have loaded fine.

Since things aren't "working" for you now, you can try using Revo Uninstaller Free to uninstall VP16. I've used it in the past when regular uninstalling didn't work with other software, Vegas has been no problem. But it looks for leftovers in the registry and leftover folders that are often missed by using M$ uninstall.

Make sure you have your activation number ready.... and you do this uninstall at your expense....

Last changed by Reyfox on 9/21/2023, 8:27 AM, changed a total of 1 times.


Vegas Post 365 (Currently VP21)

Win 11 Pro

AMD Ryzen 9 5950X 16 cores / 32 threads

32GB DDR4 3200

Sapphire RX6700XT 12GB Driver: 22.5.1, testing 23.11.1

Gigabyte X570 Elite Motherboard

rraud wrote on 9/21/2023, 10:04 AM

Revo Uninstall

+11.. and use the "Advanced" scan mode. If you have other Vegas software installed, try not to delete 'shared' items. Revo gives you the option to choose which of the pertinent files to remove.

I have been using Revo Uninstall for 10+ years on 99.999% of uninstalls. Revo Uninstall has pro and freeware versions. The free version is adequate in most cases unless a 'forced' uninstall is.needed.

Kauko-Suominen wrote on 9/21/2023, 10:45 AM

Revo did not help.

Reyfox wrote on 9/21/2023, 11:11 AM

...did not help how.... you uninstalled, deleted the leftover folder and registry items, installed Vegas and still nothing?

When you install, give your serial number, drop a file that needs the necessary codec that comes with the software but not initially installed, you should be prompted to download and install.


Last changed by Reyfox on 9/21/2023, 11:12 AM, changed a total of 1 times.


Vegas Post 365 (Currently VP21)

Win 11 Pro

AMD Ryzen 9 5950X 16 cores / 32 threads

32GB DDR4 3200

Sapphire RX6700XT 12GB Driver: 22.5.1, testing 23.11.1

Gigabyte X570 Elite Motherboard

Kauko-Suominen wrote on 9/21/2023, 11:14 AM

Yes, right so I did. And no help.

Reyfox wrote on 9/21/2023, 11:18 AM

I don't have VP16 installed and am out of ideas... sorry.

Kauko-Suominen wrote on 9/21/2023, 11:43 AM

Thank you anyway for advices. This is an very strange problem. Must be a Vegas bug because other users have too. I hate like this.

Reyfox wrote on 9/21/2023, 11:55 AM

What other users have this bug? I've never had it in any version from 14-21.

Kauko-Suominen wrote on 9/21/2023, 12:08 PM

They have codec activation problems. In this site and google seach. Now it is also indicated in V16.

RogerS wrote on 9/21/2023, 12:17 PM

It's quite unusual. I had 16 installed without issue. The program isn't blocked by a firewall, is it?

Custom PC (2022) Intel i5-13600K with UHD 770 iGPU with latest driver, MSI z690 Tomahawk motherboard, 64GB Corsair DDR5 5200 ram, NVIDIA 2080 Super (8GB) with latest studio driver, 2TB Hynix P41 SSD, Windows 11 Pro 64 bit

Dell XPS 15 laptop (2017) 32GB ram, NVIDIA 1050 (4GB) with latest studio driver, Intel i7-7700HQ with Intel 630 iGPU (latest available driver), dual internal SSD (256GB; 1TB), Windows 10 64 bit

VEGAS Pro 19.651
VEGAS Pro 21.108

VEGAS 4K "sample project" benchmark:
VEGAS Pro 20 "Ad" benchmark:

j-v wrote on 9/21/2023, 12:25 PM

Maybe it is a Windows security problem.
When Vegas has to activate a codec that has not earlier been used and Vegas has to pay for the use of that codec, your hardware on which Vegas is installed has to make contact to the internet to load that codec.
So look into your Windows settings and if needed allow it.

met vriendelijke groet

Camera : Pan X900, GoPro Hero7 Hero Black, DJI Osmo Pocket, Samsung Galaxy A8
Desktop :MB Gigabyte Z390M, W11 home version 23H2, i7 9700 4.7Ghz,16 DDR4 GB RAM, Gef. GTX 1660 Ti with driver
546.01 Studiodriver and Intel HD graphics 630 with driver
Laptop  :Asus ROG Str G712L, W11 home version 22H2, CPU i7-10875H, 16 GB RAM, NVIDIA GeForce RTX 2070 with Studiodriver 546.01 and Intel UHD Graphics 630 with driver
Vegas software: VP 10 to 21 and VMS(pl) 10,12 to 17.
TV      :LG 4K 55EG960V

My slogan is: BE OR BECOME A STEM CELL DONOR!!! (because it saved my life in 2016)

fr0sty wrote on 9/21/2023, 9:11 PM

Do not rename folders like that, it will break other features in VEGAS.



AMD Ryzen 7 1800x 8 core 16 thread at stock speed

64GB 3000mhz DDR4

Geforce RTX 3090

Windows 10


ASUS Zenbook Pro Duo 32GB (9980HK CPU, RTX 2060 GPU, dual 4K touch screens, main one OLED HDR)

Kauko-Suominen wrote on 9/22/2023, 6:10 AM

What is the name of application that does Vegas codec activation. It is maybe firewall causing this problem. What happens when I have Microsoft HEVC codec in PC. I disapled firewall but no succes activating. Vegas 10 pro works fine all the time.

Kauko-Suominen wrote on 9/23/2023, 4:11 AM

How can I fix this? Reinstallation don't help.

Reyfox wrote on 9/23/2023, 6:05 AM

Did you try reinstalling the trail VP21?

jetdv wrote on 9/23/2023, 8:51 AM

The error message is talking about VST. I'd try removing third party VSTs out of the C:\Program Files\VSTPlugins folder and see if it would start then.

Kauko-Suominen wrote on 9/25/2023, 1:36 PM

I have reinstalled Vegas16 and Vegas21 trial version again, but nothing helps toV16 codec activation. V21 trial works correct. I installed Vp16 and Vp21 trial version on the other PC and both work correctly. This is incomprehensible. I also cleaned the register carefully from time to time. No C:\Program Files\VSTPlugins folder in my PC.