Confusion on NewBlue plugins

Kalvos wrote on 10/8/2008, 6:48 PM
Hi all,

I have VMS Platinum 9.

Some of the NewBlue FX have a watermark. The registration seems to have half-worked. And Cartoonr won't register at all. Every answer code I get fails. I took this up with NewBlue, but their tech help was useless -- as is their reg system, apparently. It just sends me back to the website where I fill in all the information over and over again, and then receive a useless code (yes, I copy and paste).

The FX marked MSPP are fine, the ones marked MSP have the watermark, and nothing marked Cartoonr is anywhere to be found.

I would like either to be able to use these FX or delete the ones that are watermarked and get rid of the clutter.

Clues?

Thanks,
Dennis



Comments

OhMyGosh wrote on 10/9/2008, 9:21 AM
Hi Kalvos,
I had a similar question several weeks ago that no one answered, and I didn't want you to feel the same rejection ;( I wish I had an answer for you but I don't. I couldn't get the effects to work forever, and then when I did, they had that stupid watermark. Sony blamed NewBlue, and of course they blamed Sony. I have the 9 Pro version if that makes a difference. After several weeks I uninstalled Vegas and NB all the way to the registry, reentered the code off the card, and now it seems to work fine, but I haven't really used it since then, but the couple of tests I did seemed to work. On mine, I haven't found any labled MSPP, only MSP. I know I wasn't much help, just wanted to let you know 'been there, done that.' Good luck. Cin
Kalvos wrote on 10/9/2008, 10:52 AM
Cin,

Thanks for the commiseration. :)

I'll just leave things as they are. The plugins are really not that interesting. Free is good if it doesn't cost time. Sony's products install and register perfectly (even since the old pre-Screenblast days). Not that it matters to NewBlue, but I'll look elsewhere for FX when it actually comes to exchanging money!

Dennis

Himanshu wrote on 10/9/2008, 6:58 PM
Well, paid software is not free of buggy registrations either. I had so much trouble with Pinnacle Studio Titanium Edition v10's registration for their MPEG-4 encoder. They sent me quite a few codes, but it still doesn't work to this day, although the MPEG-2 encoder registered perfectly and works. Eventually I asked for a full refund. They agreed, but lazy me I still haven't sent them my receipt to get my money back.
Eugenia wrote on 10/9/2008, 7:05 PM
I can't move my Newblue plugins on my new Vista PC either. The registration part of things are buggy as hell. I inserted the serial numbers as found in the card that came with my Sony software, but it still has watermarks. Even the CartoonR, which is **free**, doesn't show up without the watermark (just because I am not logged in as admin on the system -- for security reasons).

I hope that company dies or Sony doesn't do business with them again until they straighten up their act.
Kalvos wrote on 10/9/2008, 7:21 PM
Cartoonr doesn't even show up. I just downloaded it again (I finally got a response from tech support to my last question) and it goes through the same deal -- send info, get email response, copy/paste unlock key, then nothing, no next button. Cancel is the only option.

I bet their system chokes on my hyphenated name. Some poorly configured systems choke on anything but 26 letters and ten numbers. My bank couldn't produce a debit card with the hyphen, so there's a space on the card -- you should see how some websites get confused by a space in a last name!

Dennis

Tollkuhnator wrote on 10/9/2008, 7:46 PM
Are these the NewBlue effects packaged with VMS 8 (MSP) or the New Blue transitions packaged with VMS 9 (MSPP)? If registering the effects or transitions packaged with VMS 8 or 9, you must have the corresponding VMS version installed before you install and register the plugins.
Kalvos wrote on 10/9/2008, 7:53 PM
These are the ones packaged with VMS9.

Unless the installation of VMS9 took the plugins along from the VMS8 installation, then both MSP and MSPP were provided. I installed only the material on the original Sony VMS9 DVD.

I uninstalled VMS8 a few minutes ago, and there was no difference in VMS9 or the plugin collection. They are all still there in VMS9.

(Slightly off-topic: What are those little icons to the left of some of the effects and transitions? There are mostly bluish rectangles, one with two different rectangles, and one with a whitish rectangle.)

Dennis

ritsmer wrote on 10/10/2008, 1:58 AM
Just to inform you that the NewBlue FX's etc. work without any problems in VMSP Pro 9.0a and full Vegas 8.0c on my machine - XP SP2 (as I had to roll back from SP3 as it gave my machine a malignant brain inflammation - not only concerning Vegas but generally)
Himanshu wrote on 10/11/2008, 1:00 PM
Dennis asked:
Slightly off-topic: What are those little icons to the left of some of the effects and transitions? There are mostly bluish rectangles, one with two different rectangles, and one with a whitish rectangle.

[Update] From the Vegas Pro manual, "Applying Video Effects" section. Of course the icons don't show in the text below:

Not all video plug-ins are capable of multithreaded rendering. Plug-ins that do not support multithreaded rendering are displayed with a yellow icon in the Plug-In Manager and Plug-In Chooser windows and with this icon in the Video FX window.

Also wanted to add that Cartoonr works for me in SVMS Platinum v8.
OhMyGosh wrote on 11/1/2008, 8:49 AM
Just found this, if anyone is still struggling, or even cares :/

Q&A
I just purchased a NewBlueFX plug-in and installed it on my computer. It
shows up in my NLE, but it draws the NewBlueFX logo over the video frame. How do I remove this watermark?

In order to remove the watermark, you must activate the product first. To do so, run the "Manage Activation" program that is installed along with the plug-in. You can find this application from the Windows Start menu.

For example, to activate NewBlue Motion Blends, go to Start->Programs->NewBlue->Motion Blends->Manage Activation. Then, paste your serial number into the form. Ta-da! No more watermark.


Yeah, I'll bet 'Ta-da' my a......... ;) Cin
Ivan Lietaert wrote on 11/1/2008, 12:35 PM
I installed the cartoon plugin, which is free, with VMS8 without a problem. Just follow the steps and registration instructions carefully. It works.
Eugenia wrote on 11/1/2008, 4:30 PM
It doesn't work for me on my Vista, because I don't run as an admin. Only the admin can use the CartoonR plugin without the watermark. The same goes for other Newblue plugins too. Very poor engineering.
ritsmer wrote on 11/1/2008, 4:43 PM
Perfectly right - but it is not new in Vista: When I install games for the children on their Windows XP machine most games will not install unless the childs user account has administrator rights too....

... and childrens useraccounts with administrator rights really invite all %€#"§ (pardon my french) virus's etc.
Eugenia wrote on 11/1/2008, 5:06 PM
Yes, a lot of apps have the problem. On Mac OS X is exactly the same btw. It's about the kind of developers who do this kind of development. They are not accustomed in writing multi-user software.

Look at the unix developers. There are extremely few cases of bugs that happen if you don't run as "root" user. Because their culture and experience is different than the Windows/Mac developers who probably run as admins themselves all the time. In Unix, unless there's a good reason to run as an admin, you just don't do it. And if you go to an IRC channel to ask for help and you happen to mention that you run as root, they kick you out immediately.

All my new PCs with Windows and Mac don't run as admins anymore, on purpose. For security reasons. It's just that developers haven't transitioned to that mentality yet. Even Vegas had many problems originally up to Vegas 7. The $999 Cineform Neo4k software even have such bugs too (I filed 2-3 to them a month ago about it).
Markk655 wrote on 11/7/2008, 6:12 PM
Not sure if this has been resolved yet. I see the same thing. In Vista32 (as admin), I get CartoonR and MSPP without watermarks, but MSP from V8 is still watermarked.

I have a support ticket in with Newblue in teh hopes of straightening it out.

@OhMyGosh - You missed the note at the bottom of the KB article: "Note: This does not apply to free or bundled products (such as Cartoonr or plugins that ship with your video editor."

Also, in case people are having trouble with MSPP/watermrksin V9, you may want to look at: http://www.newbluefx.com/index.php?option=com_easyfaq&task=view&id=16&Itemid=123

Markk655 wrote on 11/7/2008, 7:09 PM
Problem solved....

For the NewBlueFX MSP pack to be activated in SVMS Platinum V9, here is what you have to do. NewBlue Support was right on the money with their guidance on this one. As an FYI , this was done on a Vista32 cpu.

1. Uninstall current copy of MSP (you can keep SVMSP V9 installed)
2. Install V8 and register it. Running the plugins in V9 before registering v8 won't work.
3. Install the MSP pack and fill in registration info
4. Not sure if this is needed, but I checked all MSP/MSPP plugins in V8 at this point in the process.
5. I checked all plugins working in V09
6. Uninstalled v8.
7. Checked V9 again and they still work.