Creating a still from video

stevefoobar wrote on 5/16/2008, 12:03 AM
I want to do something that should be easy on the surface, but I can't figure it out and the help files aren't helping.

I want to take a video clip, isolate just one frame, then use that single frame to create a static video sequence that is perhaps 5 seconds long.

In Pinnacle Studio this takes two clicks and about 2 seconds to accomplish, but I'm not sure how to do it in Vegas.



Chienworks wrote on 5/16/2008, 3:51 AM
The most straightforward way in Vegas is to create a still image from that frame. Find the frame you want in the preview window. Set the display to Full/Best quality. Click the little floppy disc icon above the right corner of the preview. Save the frame as either a .jpg or .png file. This file shows up in your project media pool. Drag it onto the timeline.
stevefoobar wrote on 5/16/2008, 2:31 PM
Thanks...that worked. Amazing that I never thought to click on that diskette icon! :-)

My only concern is that you can't control the quality of the jpg image when you save it this way, but oh well...I guess I just hope it's not too compressed by Vegas.

Thanks again.

Chienworks wrote on 5/16/2008, 8:19 PM
It's about as close to lossless as JPEG gets, very similar to the highest quality setting of any decent digital camera.
MSmart wrote on 5/16/2008, 11:11 PM
In Pinnacle Studio this takes two clicks and about 2 seconds to accomplish,

It's about the only reason why I still keep it around.
ritsmer wrote on 5/17/2008, 12:44 AM
So when you need a still, you start up the Pinnacle Studio, imports the videoclips to it and then save the stills to some folder and then changes to VMS and imports the stills there?
MSmart wrote on 5/17/2008, 2:41 AM

It seems to me that stills captured from VMS are more jaggied than those grabbed from Pinnacle Studio. I don't know if it's because VMS doesn't deinterlace the frame capturing only one field or if Pinnacle Studio does a better job of antialiasing the frame. Either way, IMO, Pinnacle Studio captured images look better than those from VMS.

A couple interesting links:
richard-amirault wrote on 5/19/2008, 6:48 PM
"Set the display to Full/Best quality. "

Are you sure this is necessary? I thought the display was *only* the display, and when you capture a still you are capturing from the file on the timeline .. not the image on the screen.
Chienworks wrote on 5/19/2008, 7:16 PM
I'm sure it's very necessary. The still comes from the preview display and is not generated from the timeline.
MSmart wrote on 5/19/2008, 8:26 PM
I'm sure it's very necessary. The still comes from the preview display and is not generated from the timeline.

Then is must not be displaying both fields. When setting it to Best/Full, I still see jaggies. Preview window says 720x480x32, 29.979i. The "i" stands for "interlaced", correct? If so, then that means its displaying only one field, yes? If yes, then I guess I'll continue to use Pinnacle Studio for my frame grabs.
MSmart wrote on 5/20/2008, 12:09 AM
Preview window says 720x480x32, 29.979i. The "i" stands for "interlaced", correct? If so, then that means its displaying only one field, yes?

I think my suspicions are correct. If you choose any size other than Full, you get 29.970p (progressive).

So it seems to be a lost cause, higher resolution preview results in capturing one field only, lower the preview size to get progressive but you capture at a lower resolution.

Am I missing something here?
dibbkd wrote on 5/22/2008, 4:03 AM
I've done something kinda cool with this, it makes it look like you're taking a picture. Click on the link below, then the "Camera Flash Effect in Sony Vegas" link:[/link]

Chienworks wrote on 5/22/2008, 4:30 AM
I'm not sure why you would think that "i" means it's only displaying one field. I don't see any logical progression there. "i" means it's interlaced, yes. But an interlaced frame consists of two fields. It's displaying both of them. The preview can be effected by your project's deinterlace settings, but unless your settings specify ignoring one field, they'll both be there.
MSmart wrote on 5/22/2008, 3:31 PM
Thanks for clearing that up.

However, I still think Pinnacle Studio screen grab JPEGs look better than those from VMS so I'll continue to use that "tool" when needed.
OhMyGosh wrote on 5/23/2008, 9:29 AM
Ok, here is my two cents worth. I will let everyone tell me what's wrong with it, but it works for me ;) When I want the best possible frame grab of course I go to the preview window and change to 'Best (Full)'. The next step is what makes all the difference for me. I temorarily change my project properties for 'field order' from 'lower field first', to 'none (progressive scan)'. I then grab the frame and go back to my original settings and I have a much better picture. Try doing it with a frame that has lots of movement and interlace lines. Save it the original way first, then change to progressive and save again, and see if that isn't far better. As for the link on how to enlarge and reduce jaggies via PhotoShop, it won't come close to either Genuine Fractals 5 or PhotoZoom Pro 2. Try the free downloads and see if you don't agree. As for dibbkd and your 'Camera Flash Effect' it was great, just loved it, but wish you would have done a 'How To' ;< Thanks for the other good stuff in there as well. I look forward to playing with some of it. Let me know if any of this makes any sense. Take care. Cin
MSmart wrote on 5/23/2008, 1:21 PM
The next step is what makes all the difference for me. I temorarily change my project properties for 'field order' from 'lower field first', to 'none (progressive scan)'.

Hmmm....... that leads me to believe that the preview window IS only showing one field.

This Taking a snapshot inside Sony Vegas tutorial also suggest changing project properties to Progressive.

Thanks for the tip. I may be able to leave that other tool in the toolbox after all.
Tim L wrote on 5/23/2008, 2:03 PM
Here's what I *think* is happening, but these are just my hunches:

If your preview display is set for Good or Best, and your display is full size (ie 720x480 NTSC), you are seeing both fields -- so you will indeed see interlaced "comb" artifacts on a freeze frame if there is any motion in the source video.

If your display is set for Preview quality (or the other, worse one), and set for full size (720x480), you are only getting one field with simple line doubling. That is, only the odd lines, for example, but each line occupies two rasters: 1, 1, 3, 3, 5, 5, etc. (I think I read this somewhere in Vegas/VMS help files.) This results in a pretty chunky/blocky display, but no comb artifacts.

If your preview display is set for half size or lower (360x240), you are only getting the lines from one field (odd or even?), so the display is not particularly blocky, and no interlace combing, but is a much lower resolution.

Now, if you change your project to progressive, I bet Vegas is automatically de-interlacing your video when it puts it into the Preview Display, assuming you have a de-interlacing method specified. "Blend Fields" (use both fields) here might give you a slightly more detailed picture, but if there is significant motion in the video at that point, then "Interpolate Fields" (use one field, calculate missing lines using the lines above and below) might look better. I will have to give this a try -- I never thought of it before.

One thing I have tried in the past is right-clicking the video event, selecting Switches, and then temporarily selecting "Reduce Interlace Flicker". This does some line-to-line averaging on the video image, which helps smooth things out a bit. But don't forget to disable the Reduce Interlace Flicker setting when you are done getting the snapshot.

Tim L
Chienworks wrote on 5/23/2008, 4:10 PM
Near as i can tell from my reading and experimenting, Tim L is spot on.
OhMyGosh wrote on 5/23/2008, 8:56 PM
Thanks for the info Tim. I do a lot of video with action in it, and I have to deal with the interlace lines often. I tried your suggestion of using the switch of 'Reduce Interlace Flicker' and it worked good. I couldn't tell the difference between that, and the method I had been using, and it might be a tick quicker. My question is you say 'But don't forget to disable the Reduce Interlace Flicker setting when you are done getting the snapshot.'.......Why? What would it hurt if you left it on for the whole project? Would it produce a better final project, or will the TV fix those lines on its own? Thanks. Cin
Tim L wrote on 5/23/2008, 9:29 PM

I think "Reduce Interlace Flicker" is generally intended for still photos or graphics with fine detail, when viewed on an interlaced (CRT) type TV.

Maybe you've had a still photo in a video that you burned to DVD, and watched on a TV, and the still photo (or fine text) looked real shimmery or, well, flickery. This occurs when you have light-colored detail that is only a pixel or so high, so it appears only in an odd scanline or an even scanline. Consequently, it acts like a little point of light that is blinking on and off 30 times per second -- i.e. its there when the odd field is displayed, but not when the even field is displayed, then its back again when the odd field is displayed.

Note that this flickering is highly image dependent. Probably not likely to occur with an outdoor shot of kids playing in leaves, but I've seen it really bad on a photo from inside a church, where the gloss of the tops of the pews produced very fine horizontal highlights, which flickered like crazy when viewed on my (very old) TV.

The reason this interlace flicker isn't a problem with video from your camcorder is that camcorders actually perform some of this averaging internally, before the image is even recorded to tape.

Reduce Interlace Flicker does some averaging between the fields or softens the image in some way, so that the very fine detail appears also, to some extent, in the adjacent lines of the opposite field. Hence it is there for both the even and odd fields, and you get rid of the blinking on-and-off effect. (Or at least I think this is what is happening -- very much speculation on my part.)

If you enable this RIF setting for a *video* clip, and then display this video on an interlaced display, you will end up with some ghosting or blurring of the image. It might not be real obvious on the computer display (or maybe it is, I can't remember), but I did it by accident once, and the resulting video looked kind of like a double-exposure, or like anything in motion had weird blur or motion trails to it or something.


Edit: "Would it produce a better final project, or will the TV fix those lines on its own?"
Yes, the TV *does* fix those lines on its own. In essence, we see the interlaced lines on the PC screen -- and they look horrible, of course -- because the PC screen is actually merging two pictures taken 1/60 second apart into a single image. But on the TV (assuming an interlaced TV), those two pictures taken 1/60 second apart are displayed 1/60 second apart. Since you never see the two fields at the same instant in time, you never see these comb teeth artifacts on your TV.

The early TV designers only had enough bandwidth to transmit 30 pictures per second to your TV. But they wisely (I think) chose to use that same bandwidth to transmit 60 "half pictures" per second. So getting 60 image updates per second gives you smoother, more fluid motion.

Pretty much all the TV shows you've watched all your life operate this way. If you brought one of these shows into Vegas, you would see the same "comb teeth" interlace artifacts on your computer screen. But you must keep in mind that we see this ONLY when we take video that is indended to be viewed in motion, and we freeze it on the computer screen.

Edit #2: I had a bunch of places that said "1/30 second" when they should have said "1/60 second". Fixed them.
MSmart wrote on 5/23/2008, 11:41 PM
Very interesting dialog here. Thanks for the added input, Tim.

Since I mentioned that I thought Pinnacle Studio created better stills than VMS, I went to find out how Pinnacle Studio does it and found this in their knowledge base:

[ quote ] If the still images in your project (that you created with the Studio frame grabber, jitter on playback) it is typically caused if there is motion in the frame of video you grabbed for the still.

You can reduce/eliminate this jitter (flicker) by checking the option called "Reduce Flicker" in the Frame Grabber toolbox.

A frame of video is comprised of 2 fields that are interlaced. If the Reduce Flicker option is not selected, Studio grabs both fields of video. If there is lot of motion in the frame, this will cause the two fields to be different, producing flicker.

If the Reduce Flicker option is selected, Studio grabs one field and then doubles it to produce a full frame.

Because only one field is used the "Reduce Flicker" option does reduce the video resolution. [ /quote ]

It basically reiterates what Tim wrote. The key point, to me, is that P Studio can grab both fields in one step where-as with VMS it seems you have to do all these extra steps to improve the quality of the frame grab.

I agree, it all starts with a frame where the camera is as motionless as possible.

With the information gleaned from this thread, I'll have to do side-by-side testing with the two apps to compare frame grab image quality. But first, I have to finish a multi-cam edit project.

Added: The Vegas knowledge base on the subject makes no mention of fields or interlace HERE
Tim L wrote on 5/24/2008, 8:37 AM
If Pinnacle is simply doing line-doubling of a single field to eliminate flicker and combing artifacts, you should be able to get the same results in VMS by setting your preview window to "PREVIEW (FULL)" while saving the snapshot - very easy to do.

Try the same exact frame (use timecode) in both VMS and Pinnacle and compare the results, and let us know what you think.

I always struggle with trying to get a good still frame, using Alt-Left Arrow and Alt-Right Arrow to step a single frame at a time, looking for the frame with little or no movement. I know this can be a frustrating process.
Chienworks wrote on 5/24/2008, 11:18 AM
Consider too that most video is shot with an effective shutter speed of around 1/60 to 1/80th of a second. That's not really great for sharp images. Try that shutter speed with a handheld 35mm SLR camera and see what kind of image you get. Now imagine doing it with a point & shoot Minox camera shooting an 8x6mm image on ultra high-speed film without enough light .... and you're approaching the best that a typical video camera can do.
Tollkuhnator wrote on 5/24/2008, 12:29 PM
If you have Photoshop or Elements, try Filter->Video->De-Interlace on your captured frame.
MSmart wrote on 6/8/2008, 12:09 AM
I think I have to eat crow...... 1) both fields are captured 2) frame grabs from VMS are every bit as good as Pinnacle Studio (one less "tool" to worry about now).

Changing project properties to Progressive results in softening the image too much IMO, leave it interlaced. Then...

If you have Photoshop or Elements, try Filter->Video->De-Interlace on your captured frame.

Yes, that's the key. I knew about this and have used it before. Thanks for reminding me. Use the interpolate option not duplicate.

I thought I would share a trick I learned for lightening dark photos (or frame grabs): Make dark photo pop. (it works great)