Found One Cause of Slow Playback Speed

johnmeyer wrote on 4/10/2011, 6:51 PM
I was trying to help solve a problem in this thread:

Multicam - will upgrading CPU help?

The short version is that I found -- MUCH to my surprise -- that the project de-interlace setting makes a HUGE difference in playback speed in 10.0a. I thought this discovery was important enough to set up a separate thread.

Here's the longer version of what I found and how I found it.

To help the OP, I did a quick test with four cameras in Vegas 10.0a (although using HDV, not AVCHD which is what the OP in the other thread was using) and found that I could not sustain full frame rate -- even with the files on different drives -- unless I changed the quality of the preview window all the way down to "Preview - Auto." I have a 3.2 GHz 8-core i7 computer, with a 9800GT video card (although I don't think the card has much to do with anything in this case).

I don't remember having such a problem before in multi-cam edits.

Keep reading -- it gets more interesting.

I then put the same exact streams into Vegas 8.0c, arranged them into a multi-cam tiled preview and got perfect 29.97 fps playback, even using Best preview quality. I have both 8.0c and 10.0a set to the same preview window size (640x360x32) with Simulate Device on and Scale Video off.

Hmmm.....

So, I saved the 8.0c project and opened it on 10.0a.

Guess what?! You can't guess?

Well, this project played perfectly at full framerate, even at Best Auto!!

To summarize: if I create the project in 8.0c, and then open that project (VEG file) in 10.0a, it plays fine. But, the same exact four HDV files placed directly on the timeline in 10.0a, DON'T play correctly.

I explore further ... did something get broken between 8.0c and 10.0a, or do I have a default setting that is different between the two?

So, I start by looking at the project properties for the 8.0c and 10.0a versions of this multi-cam project and they appear to be identical ...

... whoops, looking a second time, I notice that the deinterlace method in 8.0c is set to "interpolate" whereas the deinterlace method in 10.0a is set to "blend." I am not sure what the defaults might be when each version is installed, but those happen to be the defaults on my particular configuration. So, I change the deinterlace method in 10.0a to interpolate and, voilà, I get full-speed playback even at best quality.

So that is the big finding: the deinterlace method in the project settings in 10.0a affects playback performance, and it affects it A LOT! Setting deinterlace method to "none" in 10.0a also produces full frame rate. Only "blend" seems to cause a problem.

But, being the engineer that I am, I kept going. I switched back over to 8.0c to see if it behaves the same way if I change the deinterlace method to blend.

It does not!! In 8.0c, the deinterlace method has no effect whatsoever on preview speed.

So, somewhere between these two releases something got changed and, perhaps, broken. I don't know what else might be attached to this code and how it might affect other aspects of the product.

So, I hope this helps others with playback issues. For other issues with playback, I have posted before these four suggestions for getting the fastest possible timeline preview speed:

Four rules for fast preview speed

[edited to fix error noted by Grazie (below) ]

Comments

Grazie wrote on 4/10/2011, 8:01 PM
Great analysis John. You need to inform Sony.

So, VP8 is "acting"' like some form of antibiotic. It either cures/kicks VP10 into shape, or maybe the Blend method is being scuppered and ignored?

In any case, you should really inform SCS.

I think, and if I've understood your analysis, you may need to edit your double deinterlace reference:"[i]So, I change the deinterlace method in 10.0a to deinterlace and, voilà, I get full-speed playback even at best quality.[/I]" Yes?

Grazie

Grazie

PC 7 64-bit 16gb * Intel® Core™i7-2600k Quad Core 3.40GHz * 2GB NVIDIA GEFORCE GTX 560 Ti

PC 10 64-bit 64gb * Intel® Core™i9 - 3.3GHz * 40Gb NVIDIA  GeForce RTX 2070

Cameras: Canon XF300 + PowerShot SX60HS Bridge

johnmeyer wrote on 4/10/2011, 8:44 PM
So, VP8 is "acting"' like some form of antibiotic. No, VP8 actually has nothing to do with it, other than the lucky fact that in my case, the default de-interlace settings happened to be different in my 8.0c installation than in my 10.0a installation. I say "lucky" because if they had been the same, I never would have thought to change them in VP10.0a.

... if I've understood your analysis, you may need to edit your double deinterlace referenceThanks for catching the error in my original post. I went back and fixed it, leaving a note that I had edited my original post.

... you should really inform SCS.As for notifying SCS, I sent a bug report, with a link to my post. Unlike others in this forum who have reported problems with SCS support, I have always had great response from the SCS team when I have reported a bug, so I am confident they'll see it and hopefully do something about it. In my bug report, I suggested that they might want to look further to see if this change in behavior might be affecting other aspects of the program. After all, to those who read the forums regularly, there sure have been a LOT of discussions about how Vegas handles (or doesn't handle) de-interlacing, with various people seemingly reporting different things (or at least that is how it sounds to me). I can certainly say, with 100% confidence, that the playback behavior was not affected by the de-interlace setting in previous versions, but IS affected by this setting in 10.0a.

johnmeyer wrote on 4/10/2011, 8:50 PM
P.S. For those who want to test this, here is a link to the 8.0c VEG file:

test four cameras.veg

Just open this up, and when it reports that it can't find media, substitute some 1440x1080 HDV or AVCHD clips. If you only have 1920x1080 clips, use those, but remember to change the project properties to match. Then, set the preview to Best-Auto, 640x360x32, Simulate Device Aspect Ratio ON, Scale Video to Fit Preview Window OFF. Play the video and note the fps reported in the lower right corner of the preview window. Then, change the De-interlace Method in the Project Properties from Interpolate to Blend.

In 8.0c, you should see no difference in playback speed. In 10.0a, the speed will drop significantly. It will be interesting to hear if 10.0c performs any differently.

Nick Hope wrote on 4/10/2011, 11:32 PM
John, in 8.0c I get 7-9 fps regardless of whether it's interpolate or blend.

In 10.0c with interpolate it starts at 8-16 fps and then slows down quite quickly to 2-4 fps as it plays.

In 10.0c with blend it starts at 1.5-2.0 fps and slows to 0.5 fps.

In 10.0c with either deinterlace method the fps will climb gradually to 29.90 fps if I set up a short loop and play it repeatedly, as Vegas does its internal pre-rendering/caching.

If I have 1 track of plain HDV on the 10.0c timeline then I get 29.70 fps regardless of the preview settings. When I add colour correction to it then it slows down to 5-15 fps but I don't see any real difference in fps between blend and interpolate.

So yes, "blend" really seems to handicap 10.0c if you have resizing going on.

And there is also this separate problem I have of fps slowing down during playback.

My dynamic RAM preview in 10.0c is set to 350MB, which as far as I remember was the default.

When I installed 10.0 on my laptop the default deinterlace method was "blend". I made a careful note of that because I wanted to know it for my web video tutorial. I would say that "interpolate" would be a much better default setting.
amendegw wrote on 4/11/2011, 3:47 AM
So... is the problem with the Muli-Cam or the "Blend"?

Could this be good news? Could it be that SCS has upgraded (dare I say, "fixed"?) its deinterlace algorithm and now we need to go back and re-visit all the resize/deinterlace issues seen in the past - using the "Blend" setting rather than "Interpolate"?

Maybe just wishful thinking!

...Jerry
megabit wrote on 4/11/2011, 6:48 AM
John,

Does it matter whether the footage is interlaced or progressive?

Piotr
johnmeyer wrote on 4/11/2011, 8:41 AM
So yes, "blend" really seems to handicap 10.0c if you have resizing going on.Yes, that is the key: remember this all started in another thread when the OP was trying to edit a six-camera shoot, and was getting terrible performance with playback.

As to what other issues are involved, including whether progressive footage would have the same issue, I don't know: I don't get paid to do testing for Sony. I'll let them (or other people here on the forum) do that testing. However, I can tell you for sure that I could only get about 10 fps playback in Best-Auto with Blend in 10.0a, but easily got 29.97 fps with the same settings, just by changing from Blend to Interpolate. I was using HDV footage from my Sony FX1 (interlaced footage).

In 8.0c, these settings made no difference, and playback was always 29.97 with four cameras scaled (using track motion) to fit in four "tiles" in the preview window (see my VEG file).

musicvid10 wrote on 4/11/2011, 8:52 AM
"In 8.0c, these settings made no difference, and playback was always 29.97"

That supports some testing I did quite a while back. Looking at it only superficially, perhaps Sony is still using a simple discard for "interpolate," but may be playing with some more complex algorithms for "blend" than they were before, and is being bitten by the time bug, which anyone who has ventured into deeper waters is well aware of.

So that raises the question, are there any visible differences in motion between 8.0c and 10.0x with "blend," all other things being equal?
Adam L. wrote on 4/11/2011, 4:25 PM
Hello, OP from the other thread asking about upgrading CPU. I tried using Interpolate and it only nets me about a 1-2 FPS increase. Followed the 4 steps in the other thread, and it was a little better. But here's what I found was the real deal-breaker:

If I have more than 2 streams, my frame rate drops like a rock. Two streams and I get almost 24 FPS (footage was shot in 24p). Add a third and it drops to 8 FPS! Here's the kicker: the assertion that moving a file to another drive doesn't hold true in my case. I tossed one of the clips onto my 2nd drive. Verified that the project with 2 streams was hitting 24 FPS (both of the clips on the same drive), then undid multicam, added the 3rd clip (which was on a different drive), and re-created multicam tracks using all 3 clips. Started the preview, BAM... 8 FPS still! :(

Seems that my machine's configuration will only let me get away with 2 clips in a multicam project, at least with AVCHD. I still haven't tried a different compression type. I think I am going to get that quad core CPU though, it's not very expensive, and it sure as heck won't hurt to get a faster proc. I'll update this thread once I get it and let you know if I can add more than 2 clips and still get a decent frame rate.
Nick Hope wrote on 4/11/2011, 11:27 PM
So that raises the question, are there any visible differences in motion between 8.0c and 10.0x with "blend," all other things being equal?

No. I just checked that out by rendering Stringer's driving clip using blend in 8.0c and 10.0c and the output is absolutely identical (compared at full/best by muting tracks on a progressive timeline).
Nick Hope wrote on 4/12/2011, 12:11 AM
As my computer is pretty old and slow I can get some significant comparisons just with a single track of HDV 1080-60i, so I did some more testing...

HDV 1080-60i on an HDV 720-30p timeline at best/full:

8.0c / interpolate: 11.5 fps
8.0c / blend : 8 fps
10.0c / interpolate: 25 fps
10.0c / blend: 18 fps

HDV 1080-60i on a 640x480i timeline at best/full:

8.0c / interpolate: 10 fps
8.0c / blend: 10 fps
10.0c / interpolate: 20 fps
10.0c / blend: 20 fps

Some conclusions with regard to single-track interlaced HDV:

1. For deinterlacing and/or resizing 10.0c previews faster than 8.0c.
2. For deinterlacing and resizing the proportional speed drop from interpolate to blend is not significantly greater in 10.0c than in 8.0c (both around 30%).
3. For resizing only there is no difference between interpolate and blend.

So I guess this points the 10.0-slow-blend blame at multiple video tracks or track motion.

Dynamic RAM preview was 128 in 8.0c and 350 in 10.0c, which I think are the defaults. I played around a bit with that setting and it didn't seem to have a significant affect.
johnmeyer wrote on 4/12/2011, 8:02 AM
Nick, that is useful testing information, but it sounds like you didn't try scaling multiple streams using track motion. When I put four different 1440x1080 HDV clips on four tracks, and scaled and moved each so I ended up with a four-tile display in the preview window, I got at least a 3:1 ratio in performance between blend and interpolate. I say "at least" because I can't get faster than 29.97, so with interpolate, I don't know whether I was just on the edge of getting full frame rate, or whether I had "room to spare."

Still haven't heard back from Sony ...
Nick Hope wrote on 4/12/2011, 8:15 AM
John, I'd already tried that the day before using your project. Results are a few posts further up. The ratio here in 10.0c is something like 6:1 but that's quite hard to measure as the fps jumps around a bit and slows down during playback.
rmack350 wrote on 4/12/2011, 10:04 AM
I'm beginning to lose the thread here. Let me recap if I can.

If you look at the descriptions of deinterlace methods in Vegas Help you'd probably be able to guess that Blend mode is more CPU intensive than Interpolate mode. So you'd expect to see a bigger CPU hit when using Blend deinterlacing. If your CPU isn't fast enough you'll see diminished playback performance using Blend (with "None" being the least demanding mode)

Okay. Simple. Better playback if you set your project's deinterlace mode to Interpolate or None.

Beyond that, it sounds like Vegas 10 performs differently from Vegas 8. If the demands are fairly simple then Vegas 10 appears to have better playback but if you have multiple tracks of resized video like in a PIP or multicam setup then Vegas 10 has a much harder time keeping up, especially in Blend mode.
---------------------------------------------------------------------------------
I tried this out with a few AVCHD clips from my GH1. I don't have 8 installed but certainly VP10 bore out the observation that Blend is slower than Interpolate, which should be no surprise.

I'm running VP10c-64 on a i2500 with 8GB installed. Project set to match the media.

Other observations...on my first try of the test I used just one AVCHD clip for all four events. Playback was rock solid at 29.97. After that I shot 3 more random shots and used the four different clips for the four events. Playback was less than 29.97 all around and much worse in Blend mode. I don't recall the numbers but probably around 14 in Blend and 25 in Interpolate.

I also played a little with RAM preview because I new that subsequent tests would use cached frames. With RAM preview at zero playback was abysmal. With RAM preview set up to 128 even a first pass of playback was much better. (I first played back at something like good/quarter to try to wipe out the cache for Best/Auto). So zero RAM preview is bad.

I'd love to tie this to my pet peeve about Vegas automatically deinterlacing stills saved from the Preview window in VP 9 and 10. You can't turn this off except be changing to a progressive template, the project deinterlace settings have no effect. Unfortunately (for me) I can't tie them together. What I'd look for might be something like double-deinterlacing. I don't believe that's happening but if I was a programmer I'd want to be sure that wasn't having an effect. somehow.

Rob Mack
Laurence wrote on 4/12/2011, 9:48 PM
I just want to thank you John. I have been so frustrated lately because my core2duo laptop hadn't been keeping up to my HDV previews since upgrading to Vegas 10. This same computer had been working fine up until Vegas 10. Now by simply turning off the deinterlace (I always render to interlaced and do any deinterlacing with Handbrake anyway) and previewing at either half or quarter resolution again, I am back to full frame rate previews and can hold off for another year or so on a computer upgrade. Thank you, thank you, thank you!
Laurence wrote on 4/12/2011, 9:49 PM
It really seems to me like if you are rendering at half or a quarter resolution, that there should be no deinterlacing going on during preview anyway. Why the heck is this setting even having an effect on preview frame rate!?
johnmeyer wrote on 4/12/2011, 11:36 PM
Laurence,

I don't recommend setting the project properties deinterlace setting to "none." I think this can have adverse effects on the render if you are starting with interlaced footage. The tests I did suggest "Blend" is the culprit and that if you set it instead to "Interpolate," all is well.

If you do set it to "none," make sure you do a test render on a small portion of video and then view it on the destination display before you proceed, just to make sure the render looks OK.

As to what other things may be affected by this anomaly that crept in somewhere between 8.0c and 10.0a, I asked Sony this question in the trouble ticket I submitted a few days ago. Still no word from them.
fausseplanete wrote on 4/13/2011, 1:09 AM
Not directly in-line with the thread, but hopefully useful, especially the last couple of comments:

I've also been doing some tests, coincidentally, based on Vegas 9.0e.

In the past, for various versions, I found playback best for Good/Half, worse for other settings. I also found the framerate displayed on Preview window to be inaccurate: sometimes it says full framerate (in my case PAL 25fps) but it sure looks jerky to the eye...

Most of my recent tests have focussed instead on rendering, but as reported above for playback, Preview RAM setting makes a big difference. 0 is worst, 128 is better and 1024 is slightly better again.

For a current multicam project with 4 cams (3 HD, one SD) all on one USB disk, it was painful to edit on a MacBook Pro (2009 2-core, BC-W7-64, V9.0e-64) until the cams were migrated to 3 separate disks. and further, those (two) cams that were AVCHD/MTS were converted to CineformNeoHD/AVI. Result: smooth! Presumably a RAID5 NAS would be an even better alternative (to multiple disks). At the very least, that would avoid the pain of keeping drive letters consistent (they can get altered when letters conflict etc.).

Incidentally, now I have it upgraded to 8GB RAM, it renders the same speed (almost identical) under Parallels 5. Haven't yet tried Parallels 6.

On a Mac desktop (BC-XP, V9.0e-32) with RAID, it just "walked through" the same multicam with original AVCHD files. Converting them to Cineform just made the transitions nicer.

Now that raises another issue. Playback speed is not the only thing. It's hard to judge how good a cut is when the NLE hiccups on change of stream (from one video file to another). Good stream-switching performance means less preview rendering. So for productivity I'm using the Mac desktop, the laptop is only good for mobility.

There are so many variables here that getting sufficient consistency ("in the dark") for comparison experiments may be an issue.
Laurence wrote on 4/13/2011, 4:54 AM
Setting the deinterlace method to "none" will bite you if you are resizing interlaced footage. I would select a deinterlace method before an SD downrez or any other resize.
rmack350 wrote on 4/13/2011, 10:15 AM
When it comes to keeping removable drive letters consistent, I generally set those drives as upper letters like X Y and Z. That way they never conflict with things like USB sticks or new drives.

Using a NAS array doesn't seem like a recipe for happiness. Even if the array is fast you're still accessing it over ethernet. Better to have something attached more directly, either by Firewire, eSATA, Thunderbolt (assuming you have a new MacBook), or if you need central storage you might be looking at a fibre attached SAN, although that last will be pretty expensive. USB is okay but afaik it incurs some CPU overhead. I assume that's still the case with USB 3.0.

I think there are aggregated ethernet solutions that can work as well, if you need central storage, but these don't seem terribly common.
Adam L. wrote on 4/13/2011, 8:42 PM
And now for the follow-up. I went ahead and bought a Core 2 Quad Q9650 3GHz CPU. It's more expensive than some of the faster CPUs out there, but it also saved me from having to upgrade the RAM, motherboard, and then reinstalling the OS and all my software. This is obviously the last upgrade I can get away with, but it should also last at least another year and a half (maybe two.)

Anyway, with the new CPU in place, I can now multicam edit 3 clips simultaneously. I was hoping for 4, but oh well. Clips are 1080p 24 FPS AVCHD. With 3 and Best (auto) I get a little under the frame-rate and dips to around 19 FPS. There's not much difference until I switch to Draft (auto) and then I get rock solid 23.976 FPS. If I use 2 clips for multicam it's rock solid 23.976 FPS even with Best (auto).

So yeah, CPU upgrade made a huge change.

As far as contributing to multicam performance increase, if nobody mentioned this I found that there are HUGE drops in FPS as VP10 switches the take and on the time-line tries to make new thumbnail clips. I went in to Video Preview Preferences and changed "Thumbnails to show in video events" to "None" and viola, no more churning as I switched takes during a multicam edit. Was smooth as silk!
Nick Hope wrote on 4/14/2011, 7:10 AM
So, quoting John and adding the couple of new points, we now have...

6 Guidelines for Fast Preview Speed

1. Match project properties exactly to your source footage. Use the "match" feature to do this. Failure to have these settings correct is the biggest reason for slow timeline playback.

2. Don't use higher preview resolution than necessary. Use Auto instead of Full, and use "preview" or "good" instead of "best," especially when smooth timeline performance is more important than being able to see every last detail.

3. Turn off "scale video to fit preview window." This doesn't make a huge difference, but it helps.

4. Make your preview window smaller.

5. Set "Deinterlace Method" in "Project Properties" to "Interpolate" instead of "Blend".

6. Try setting "Thumbnails to show in video events" in "Video" preferences to "None", especially for multicam projects.

[EDIT 17th March 2013: Adding number 7, which made a big difference on my 30p timeline containing 60p footage]

7. Set video events to "disable resample". Use right click > switches, or use one of these scripts.

[EDIT 22nd April 2015: Adding number 8]

8. Reboot the computer. Try this first.
johnmeyer wrote on 4/14/2011, 10:14 AM
Good update Nick. The "thumbnails" addition is particularly good and I appreciate the person who took the time to track that down and then post.

Every time the playback cursor on the timeline reaches the rights side of the timeline window, I instinctively recoil slightly, knowing that the playback will slow down and glitch until those thumbnails are redrawn. I forgot there was a preference to turn that off. If that helps multi-cam switching performance, that is going to be especially useful to remember.