Getting "contrails" in rendered Dance-DVDs

earthrisers wrote on 12/26/2013, 12:42 PM
I've been producing DVDs for clients for a number of years, using Vegas Pro and DVD Architect. Recently for the first time, I'm starting to see artifacts -- "contrails", kind of -- in some dance-scenes that involve fast motion of white/light-costumed dancers. This hasn't happened before, even when I've had to create DVDs at a lower bitrate that I'm using for these current productions.
(For example, the artifacts occur on a DVD I mastered at 5,500,000 bits. I've had complete success with lower bitrates, in the past.)

I'm baffled, so far. The artifacts don't seem to appear when I play the MPG file within DVD Architect --- which would seem to imply that the problem begins in the disc-burning phase of the workflow, but I'm not yet positive. I'm just posting this in case anyone has experience with this happening, and has any insights to offer. Thanks in advance...

Comments

earthrisers wrote on 12/26/2013, 12:50 PM
I should add... I'm on Vegas Pro10 and DVD Architect Pro5, which I've been using successfully since they first came out.
Windows7, 32bit machine, which I've also been using successfully for several years. I did replace the DVD burner within the last 6 months or so, so that is definitely a possible "suspect."
And I'm burning to good ol' DVD, not BluRay -- none of our customers seem to want BluRay.
farss wrote on 12/26/2013, 12:53 PM
If you play the DVD in a PC do you see the same problem?

Bob.
earthrisers wrote on 12/26/2013, 1:00 PM
...and another bafflement: I don't see the artifacts when I view the BURNED DVD on my computer. But I definitely do, when it plays in the DVD player that's connected to my main TV set.
And I know it's not a problem specifically with that DVD player, because I just received a complaint-email from a customer, noting the same artifacts when she plays her copy of the DVD.

I'm having a hard time even figuring out what to investigate next...
farss wrote on 12/26/2013, 1:08 PM
It could be a product of "motion flow" that's built into many new HDTVs.

Was the camera shooting interlaced or progressive?

Bob.
earthrisers wrote on 12/26/2013, 1:15 PM
I'm currently reviewing the DVD on the PC and trying to look very closely... far as I can tell so far, the problem does NOT appear when playing in the computer's DVD drive.

...??
earthrisers wrote on 12/26/2013, 1:20 PM
The camera was shooting interlaced.

I saw a reference in a recent forum post about a software utility that converts interlaced footage to progressive. That stuck as a mind-tickle as I continue to try to figure out this problem. ...but I haven't yet investigated at all the possibility of converting to progressive.
(And again, my bafflement stems largely from the fact that I'm using the same equipment -- including the TV -- that I've been using successfully for at least two years.)
earthrisers wrote on 12/26/2013, 1:43 PM
I take it back about the artifacts not showing up on the computer.
I just Re-rendered (to ac3 and mpg2, at 5,000,000 bits) the project that the customer is complaining about (a Nutcracker Ballet performance), and now when I review the program in DVD Architect, the artifacts are very noticeable.

Next, gonna try splitting the ballet into two acts and rendering at DVD-A's "default" bitrate, which I think is 6,000,000.
dxdy wrote on 12/26/2013, 1:52 PM
As long as you are splitting into two disks, go for the max - 9,200 kbps. You should have plenty of room.

Are you rendering VBR or CBR? Try VBR if you haven't already, with a minimum of at least 8,000.
johnmeyer wrote on 12/26/2013, 2:59 PM
This is not at bitrate problem, so don't waste your time rendering to two DVDs.

I strongly suspect a problem with the interlace settings.

First, go to the project settings and makes sure that the "deinterlace method" is set "interpolate." "Blend" will also work, but you will have HUGE problems if this is set to "none."

Next, go to the Render As dialog and start with the MPEG-2 codec, and make sure to choose the default "DVD Architect NTSC Widescreen video stream" template (I assume you are shooting HD and then rendering to DVD). Then, in the Render As dialog, change ONLY the average bitrate and absolutely nothing else.

Finally, if you need more help, in Vegas, position the cursor at the start of a section of the video that is producing the artifacts and from that point create a region approximately 10-15 seconds long. Post that short video clip and provide a link in this thread. I'll take a look and see what is going on. Also, while you're at it, post the original VEG file of your project and let us know the specs of the original video (e.g., HDV NTSC) and the camera used.
earthrisers wrote on 12/26/2013, 3:08 PM
Thanks for all the responses so far.
I should have mentioned that non, we're not downconverting from HD to SD... we're shooting with Sony FX-1000s, at standard definition. No customers ask for HD, and many don't have Blu-Ray players anyway. Everyone is satisfied as long as the pic is widescreen, which of course it is.
I'm following up on some of the suggestions above, and will see, step by step, what happens. I'll post some more, as I learn anything useful or come up with more specific questions.
Rainer wrote on 12/26/2013, 3:38 PM
... and just to cover all possibilities, did you at any time have a frame rate change and not disable frame blending?
earthrisers wrote on 12/26/2013, 4:58 PM
No, regarding framerate change & blending (at least, not as far as I'm conscious of that).
I continue experimenting, and it keeps getting more confusing, although some patterns are beginning to emerge.
Latest observations:
(1)The disc is regular DVD, not Blu-ray.
(2)The artifacting is terrible and very evident when I play the DVD on the TV-connected player that I've used for my reviewing/testing for the past couple of years -- but the footage plays WITHOUT apparent artifacts if I play the DVD in my TV-connected Blu-ray player.
(3)I rendered a 25-second clip of the male-dancer solo that has some of the worst artifacting. I simply rendered it to another AVI file.https://dl.dropboxusercontent.com/u/24198048/Ballet%20male%20solo.avi

(a)The resulting avi clip looks perfect if I view it in Vegas
(b)The avi clip is badly artifacted ("contrails", breakups) if played in MSoft Media Player.
(c)The avi clip is badly artifacted if played in the Quicktime Media Player.
(c)The avi clip plays just fine, with no artifacts, in VLC Media Player.
(d)The avi clip plays just fine if reimported into Vegas... and if I RErender that one, the results with the next-generation avi are exactly the same as in (a through d).

(4) I rendered the male-solo AVI to MPG format twice, once at DVD-A's default bitrate settings and once at 9,500,000 bits. Then I burned both mpg files to a new DVD. (Links: https://dl.dropboxusercontent.com/u/24198048/Ballet%20male%20solo.mpg and https://dl.dropboxusercontent.com/u/24198048/Ballet%20male%20solo-9500bits.mpg
(a)The DVD plays perfectly with no artifacts (both clips) when I play it in VLC Media Player on my computer.
(b)The DVD plays with horrible artifacts (both clips) when I play it in the TV-connected DVD player that has been our normal review-player.
(a)The DVD plays perfectly with no (or very subtle) artifacts (both clips) when I play it in the TV-connected Blu-ray player.

The VEG file for the one ballet-solo clip is here:
https://dl.dropboxusercontent.com/u/24198048/_Ballet%20male%20solo%20Vegas%20project%20file.veg

SIGH.....
-Ernie


farss wrote on 12/26/2013, 5:44 PM
OK, downloaded the AVI file.
There is most certainly something wrong with it:

1) Why is there a black border around it?
2) Viewing it field by field I'm seeing interlace aliasing which should NOT be there.



[edit]

Just checked this again and Vegas had me somewhat fooled. When I Disabled Resampling for the clip the dogs teeth in the frame grab above are gone but now I'm seeing every field duplicated i.e. the even and odd field are identical, truly strange.

Bob.

earthrisers wrote on 12/26/2013, 5:57 PM
Thanks, Bob.
The black border is on purpose... I "track-motioned" the scene to lessen the risk of chopping off the dancer's feet.
Could track-motion be the culprit? What I'll to do next is go back and check all the scenes that had the artifacting, and see if I had TM'd all of them or not.

Off the top of my head, I doubt that TM is the full explanation --
(1)Why would the artifacting not show up in ALL video players & not only in some?
(2)I also used TM on another project involving little-kid ballet dancers, for doing PIP when we had one cam doing pan-closeups and the other cam holding wide. I don't recall artifacting in that project. But I'll have another look at that one, too, to see if maybe there just wasn't much motion going on in those scenes, as opposed to the fast-motion scenes in the project I've been talking about.
And I will surely check the artifacted scenes in that particular production I've been talking about, and see if TM was used in all the relevant scenes.
Thanks a bunch for having a look.
And do let me know if anything else occurs to you in the middle of the night!
Happy New Year.

farss wrote on 12/26/2013, 6:01 PM
Earthisers,
see my edit above.

Track motion can do some strange things but I cannot explain what I'm seeing as explained in my edit above. Certainly if what I'm seeing is what's being put onto your DVDs weird things could happen depending on the player and the TV.

Bob.
john_dennis wrote on 12/26/2013, 6:02 PM
The project file that you uploaded had the Deinterlace Method set to None. See johnmeyer's post. See this.

Also, set render quality to Best.

Personally, I'd lose the track motion. Seems to me with interlaced video, it's hard enough to get the fields to line up when the input matches the output exactly.

My main system:
Motherboard: Asus X99-AII
CPU: Intel i7-6850K
GPU: Sapphire Radeon RX480-8GB
RAM: Corsair Dominator (4 x 4 GB) DDR4 2400
Disk O/S & Programs: Intel SSD 750 (400 GB)
Disk Active Projects: 1TB & 2TB WD BLACK SN750 NVMe Internal PCI Express 3.0 x4 Solid State Drives
Disk Other: WD Ultrastar/Hitachi Hard Drives: WDBBUR0080BNC-WRSN, HGST HUH728080ALE600, 724040ALE640, HDS3020BLA642
Case: LIAN LI PC-90 Black Aluminum ATX Full Tower Case
CPU cooling: Corsair Hydro series H115i
Power supply: SeaSonic SS-750KM3 750W 80 PLUS GOLD Certified Full Modular Active PFC Power Supply
Drive Bay: Kingwin KF-256-BK 2.5" and 3.5" Trayless Hot Swap Rack with USB 3
Sound card: Crystal Sound 3 on motherboard. Recording done on another system.
Primary Monitor: Asus ProArt PA248q (24" 1920 x 1200)
O/S: Windows 10 Pro 22H2, Build 19045.2130

Camera: Sony RX10 Model IV

https://www.youtube.com/user/thedennischannel

earthrisers wrote on 12/26/2013, 6:16 PM
Thanks some more, Bob...
As I look at the scenes I MotionTracked, I'm seeing a very convincing correlation between my use of that tool, and the fast-motion scenes that have the bad contrailing.
I've only used TM sparingly in past, and didn't realize it produced such awful side-effects.
Next thing I'll study, now that our "crunch season" is just about done (it WAS done, except now I have to re-render two performances of this ballet and re-create the videos and make about 60 duplicates and re-mail them...) -- is other, more dependable ways to accomplish what I was using TM to accomplish. I think there are other forum strings on that topic. I'll go poking around in the next few days.
Thanks again, VERY MUCH. It's a major pain to have to re-do all this work, but a MUCH lesser pain than not knowing what was causing my problem.
-Ernie
farss wrote on 12/26/2013, 6:45 PM
Earthrisers,
John Dennis above is probably on the money about your project's De-interlace Method.

When you use Track Motion you are scaling the image and Vegas will de-interlace, having the method set to None is going to give bad results, set it to Blend and that should fix your problem.

Bob.
johnmeyer wrote on 12/26/2013, 8:09 PM
Yup, my original supposition is correct: you turned off deinterlace and then did some sort of re-sizing. If you follow my original recommendation of setting the deinterlace properties to "interpolate," the problem will completely go away.

You should absolutely never set the project properties deinterlace method to "none" when dealing with interlaced video. Never.

The reason why you might have gotten away with this mistake in the past (although the video will still suffer) is that you didn't do any re-sizing. However, as soon as you use track motion, even if you keep everything at 720x480 from the source to the final render, there is still re-sizing going on in order to move things around. The horrible artifacts that you see when you separate the video into fields, as Bob (farss) showed in his post, are classic artifacts and show, with 100% certainty that this is your problem.

So, make the change, render the project, and deliver the DVDs!

BTW, it's nice to hear a live orchestra. Not many productions can afford that these days.
musicvid10 wrote on 12/26/2013, 9:03 PM
This may not be the only problem, but Bob's screenshot is a deasd giveaway.
Set your rendering quality to Best.
earthrisers wrote on 12/26/2013, 10:31 PM
Thanks again to everybody. Have remastered the DVD and am preparing to duplicate and mail the copies for everyone who ordered.
RE THE LIVE ORCHESTRA... Great you noticed that. Yes, it's a real pleasure to have live music in the performance. Although on the other hand, it's more challenging to get a good audio recording from a live orchestra than it is to get a from-the-soundboard patch of a recorded accompaniment.
A couple of years ago for this same ballet performance, I took a patch from the in-house sound system to my camera for the orchestra audio. There was a terrible hiss when the orchestra was playing softly -- house system must have had some heavy-duty compression in place. Took some Izotope magic in post to fix that.

I learned from that to set up my own "redundant" audio equipment for this performance and others like it. I have my own mics down by the orchestra, feeding a Zoom H6 recorder, and then in postproduction I integrate that audio into the video (along with just a bit of near-cam shotgun audio to sweeten the ambience without getting too much of people's coughing and shuffling, etc.),
earthrisers wrote on 12/27/2013, 7:51 PM
With ongoing thanks to forum colleagues...
No further problem just now, but I just wanted to share a clip of this beautiful move from the Pas de Deux in the Nutcracker Ballet we shot earlier this month.
The company is the Footworks Youth Ballet (Oxnard, California), the orchestra is the Footworks Community Orchestra, and the dancers are Madison Hendricks and Evan Swenson.
I love watching ballet, even if it's through a 3-inch screen...
https://dl.dropboxusercontent.com/u/24198048/Pas%20de%20Deux%20spectacular%20move.mp4
johnmeyer wrote on 12/27/2013, 9:44 PM
Yup, that's the original Petipa choreography, and I've seen dozens of dancers do exactly that move. If those are members of your Youth Ballet, then I am completely blown away and totally in awe. I usually only see that quality when the company hires guest artists for the famous pas de deux in the last act.
earthrisers wrote on 12/28/2013, 9:55 AM
Good call... The male dancer was indeed a hired professional.
Thanks for the historical note, too - I didn't know about the original choreography. And it's the first time I'd ever seen the move, after video recording a couple dozen or more (amateur) performances of that ballet.