How to change how often timeline jumps ahead

riredale wrote on 12/29/2013, 6:45 PM
So load up a project and play it. The scrubber moves across the window, and just before reaching the end Vegas puts up the succeeding part of the timeline and the scrubber starts off at the left side of the window.

Fine. I want to know how to adjust Vegas so it switches to a new view before the scrubber reaches the very end of the line. I'm certain there must be a special adjustment in the Internal tab for this.


john_dennis wrote on 12/29/2013, 8:11 PM
Set Smooth Scroll Trackview to TRUE.
ritsmer wrote on 12/30/2013, 3:11 AM
In case somebody wonders where that setting is - click:
In the field "Show only prefs containing" write: Smooth scroll trackview
Doubleclick the Value field
type TRUE
click OK
... and voila.

relaxvideo wrote on 12/30/2013, 3:32 AM
I also changed "video seekscrub update interval"
to 10ms, so faster preview with some material.
Also updated preview every X frames to 1.

What else change you at internal settings for
faster/better editing?

#1 Ryzen 5-1600, 16GB DDR4, Nvidia 1660 Super, M2-SSD, Acer freesync monitor

#2 i7-2600, 32GB, Nvidia 1660Ti, SSD for system, M2-SSD for work, 2x4TB hdd, LG 3D monitor +3DTV +3D projectors

Win10 x64, Vegas21 latest

Geoff_Wood wrote on 12/30/2013, 3:56 AM
It's been bugging me too, thanks for the pointer. But there must be a reason - maybe a resources hit ? Will test !

riredale wrote on 12/30/2013, 10:12 AM
No, that's not what I had in mind.

The smooth scroll seems cool for a while but I find it a bit unnerving, and it takes a lot of processor power compared to the conventional "next piece / next piece / next piece" process.

All I'm seeking is the setting that tells Vegas when to jump to the next piece.
Steve Grisetti wrote on 12/30/2013, 10:24 AM
What are your hardware specs?

What model of camcorder did you video come from and what format and resolution is it?

And what is your Vegas project's properties? Have you ensured that your project properties match your source video for most efficient playback?

Is your Preview monitor quality set to Draft/Automatic to ensure that your system isn't getting bogged down trying to create a high-quality preview?

It may be that your system is just overwhelmed with trying to play the video back.
riredale wrote on 12/30/2013, 9:41 PM
Steve, thanks for the questions, but I'm afraid I haven't explained myself well enough.

When one plays a video on the timeline, the scrubber moves along until reaching the edge. At that point Vegas brings up the next part of the timeline and the scrubber begins at the left edge and marches across again.

All I want to do is to tell Vegas to advance to the next portion of the timeline BEFORE the scrubber reaches the extreme end of the timeline window.

So as such this has nothing to do with camcorder format, project properties, or system horsepower. I'm sure it's some secret setting within Vegas, but so far I can't find it. Oh well, it's not a big deal.
kairosmatt wrote on 12/31/2013, 5:49 AM
I'd actually like to set it so it doesn't jump ahead at all, or maybe just jumps to the courser once playback has paused. I find it the timeline update distracts me from the video. I may try the scroll thing but I don't what to take a performance/framerate hit.

Chienworks wrote on 12/31/2013, 7:37 AM
Hmmmm. Somehow, i do this all the time and then have to press the | key to start it scrolling again. Sadly, i'm not sure exactly what i do to make it stop scrolling. If i did know, i'd stop doing it. If i figger it out i'll let you know.

This conversation sounds very familiar. I seem to think we've had it before, possibly in the Sound Forge forum.
riredale wrote on 12/31/2013, 12:05 PM
Chienworks: THANK YOU!

Not related to my original question, but this business of trying to get Vegas to follow the scrubber again has been an issue for me forever. So, hitting the backslash (\) key does it! I'm sure it's documented in some obvious place in the help file but I never saw it.

I found that if Vegas is playing then hitting the tracks will cause the flashing "focus line" to move to that spot and Vegas will no longer follow the scrubber as it continues on its merry way down the timeline. Hitting the blank area just above the timeline or anywhere below the tracks will move the scrubber to that point and continue playing.
FilmingPhotoGuy wrote on 1/6/2014, 1:58 PM
I simply turn the mouse wheel 1 notch then it centers it's self.