How to fix a file with variable frame rate?

sasiuk wrote on 1/23/2017, 4:18 PM

Hi,

 

I have lot of video files from my Samsung J5 in MP4 1080P 29.97 fps, shotted with Cinema FV5.

I have only one file that is in variable frame rate: 29.693 fps to 30.323 fps (MediaInfo).

Under Vegas Pro 14 (built 211), this file put on the timeline have as an echo effect that could be similar to a frame order error, while I am on a file recorded in progressive mode. I don't understand why?

 

I tried to fix this by activating the quantize option, but defect is not corrected. Same after a rendering   in 29.97 fps and allowing the source to adjust the frame rate.

What would be the manipulation to eliminate this defect?

Thanks a lot for your help.
 

DeDe
(French user).

Comments

set wrote on 1/23/2017, 4:32 PM

Try Disable Resample

Right click on the event clip > Switches > Disable Resample

sasiuk wrote on 1/23/2017, 5:01 PM

Try Disable Resample

Right click on the event clip > Switches > Disable Resample

Thanks a lot, work fine!

DeDe.

Nick Hope wrote on 1/24/2017, 2:20 AM

While disable resample will eliminate the frame blending, it will likely mean that occasionally a frame will get skipped. This might not really be noticeable. However if you have a variable-frame-rate video that is near to constant frame rate (as most of these phone videos usually are), and you want to convert to a genuinely constant-frame-rate file in which all the individual frames within the video stream quantize correctly on your timeline with no skipped frames, then read this: https://www.vegascreativesoftware.info/us/forum/how-to-quantize-frame-for-frame-many-events--102055/

The version of the script I am currently using to do this for my Samsung Galaxy Note 2 footage is here. In this version the target frame rate is set to 30p (29.97). You can manually change that if you wish.

sasiuk wrote on 1/24/2017, 9:53 AM

Thanks a lot Nick for your alternative method.

Switches -> Disable Resample corrected my blend frame defects.

This morning I tested another method. Right click on the clip, properties -> Video Events -> Playing Frequency -> Align on project image frequency. Result seems to be good. (My translation could be approximate).

Vegas Pro 14 Screenshots (in French).

DeDe

set wrote on 1/24/2017, 2:48 PM

That is Properties > Video Events > 'Playback Rate' > 'Conform to Project Frame Rate' in English version.

sasiuk wrote on 1/25/2017, 7:45 AM

Thanks!

AlesCZ wrote on 5/1/2019, 1:33 PM

If I'm not mistaken, the new Vegas version supports VFR. Yes? I have now found that I no longer need to adjust the video speed, and that a video that is close to NTSC(like 29.953...) has the right frame rate, 29.970. :)