Issue when scrolling through video / audio tracks

Zyg wrote on 7/5/2024, 8:46 AM

I'm currently using Vegas Pro Edit 21 (Build 300) and still kind of new to the software.

I'm unsure if this is an intended feature or not, but when scrolling to the bottom of my audio / video tracks it automatically moves to the top track when I let go of ctrl. I'm just wondering whether this is an intended feature or some sort of bug..

Comments

Dexcon wrote on 7/5/2024, 8:55 AM

The latest build of Vegas Pro 21 is build 315. I'm not getting that problem in VP21b315 when using Ctrl-mouse scroll.

Cameras: Sony FDR-AX100E; GoPro Hero 11 Black Creator Edition

Installed: Vegas Pro 16, 17, 18, 19, 20 & 21, HitFilm Pro 2021.3, DaVinci Resolve Studio 18.5, BCC 2023.5, Mocha Pro 2023, Ignite Pro, NBFX TotalFX 7, Neat NR, DVD Architect 6.0, MAGIX Travel Maps, Sound Forge Pro 16, SpectraLayers Pro 11, iZotope RX10 Advanced and many other iZ plugins, Vegasaur 4.0

Windows 11

Dell Alienware Aurora 11

10th Gen Intel i9 10900KF - 10 cores (20 threads) - 3.7 to 5.3 GHz

NVIDIA GeForce RTX 2080 SUPER 8GB GDDR6 - liquid cooled

64GB RAM - Dual Channel HyperX FURY DDR4 XMP at 3200MHz

C drive: 2TB Samsung 990 PCIe 4.0 NVMe M.2 PCIe SSD

D: drive: 4TB Samsung 870 SATA SSD (used for media for editing current projects)

E: drive: 2TB Samsung 870 SATA SSD

F: drive: 6TB WD 7200 rpm Black HDD 3.5"

Dell Ultrasharp 32" 4K Color Calibrated Monitor

Zyg wrote on 7/5/2024, 9:03 AM

I just upgraded to build 315 right after posting this forum. It's still happening on all of my projects :/

Robert Johnston wrote on 7/5/2024, 1:27 PM

@Zyg

You may need to hold down the CTRL key just a bit longer, especially if you have smooth scroll on and spin the thumbwheel fast. I haven't been able to get the scroll to go back to the top after releasing the CTRL key, but I have had the timeline zoom in if I scroll down and then up fast, then release the CTRL key. I usually need to move the timeline cursor to another position before doing any of that. It's like the mouse commands get backed up in a buffer if you scroll too fast. Then when you release the CTRL key, the backed up mouse commands are treated as just thumbwheel without holding the CTRL key down, which in my case makes the timeline zoom in.

Intel Core i7 10700K CPU @ 3.80GHz (to 4.65GHz), NVIDIA GeForce RTX 2060 SUPER 8GBytes. Memory 32 GBytes DDR4. Also Intel UHD Graphics 630. Mainboard: Dell Inc. PCI-Express 3.0 (8.0 GT/s) Comet Lake. Bench CPU Multi Thread: 5500.5 per CPU-Z.

Vegas Pro 21.0 (Build 108) with Mocha Vegas

Windows 11 not pro

Zyg wrote on 7/5/2024, 7:36 PM

@Robert Johnston @Dexcon Appreciate the responses. The issue seems to come and go. I tried it all last night. I don't believe I have smooth scrolling on and it doesn't seem to have to do with the duration between scrolling and releasing the ctrl key. It's not happening now but I haven't changed anything... I do appreciate the responses though.

Zyg wrote on 7/5/2024, 7:41 PM

So I just figured out the trigger for it. Left clicking into a video track or audio track will scroll to the top of the tracks. After that if I try to ctrl + scroll down it defaults to the top of the tracks. Left clicking into project media and ctrl scrolling through tracks works normally after but as soon as I left click into a track it causes the issue.

Zyg wrote on 7/5/2024, 8:25 PM

Update: Even selecting any track other than the top is defaulting to the top track, both by left clicking it or using directional keys. I tried doing a clean reinstall of vegas pro and I'm still having this issue. I pretty much can't edit any of my projects.

Dexcon wrote on 7/5/2024, 8:33 PM

Uninstalling/re-installing often doesn't achieve anything because it doesn't clear the cache. Try resetting Vegas Pro back to its default (factory) settings making sure to clear the cache when asked in a pop-up window.

Cameras: Sony FDR-AX100E; GoPro Hero 11 Black Creator Edition

Installed: Vegas Pro 16, 17, 18, 19, 20 & 21, HitFilm Pro 2021.3, DaVinci Resolve Studio 18.5, BCC 2023.5, Mocha Pro 2023, Ignite Pro, NBFX TotalFX 7, Neat NR, DVD Architect 6.0, MAGIX Travel Maps, Sound Forge Pro 16, SpectraLayers Pro 11, iZotope RX10 Advanced and many other iZ plugins, Vegasaur 4.0

Windows 11

Dell Alienware Aurora 11

10th Gen Intel i9 10900KF - 10 cores (20 threads) - 3.7 to 5.3 GHz

NVIDIA GeForce RTX 2080 SUPER 8GB GDDR6 - liquid cooled

64GB RAM - Dual Channel HyperX FURY DDR4 XMP at 3200MHz

C drive: 2TB Samsung 990 PCIe 4.0 NVMe M.2 PCIe SSD

D: drive: 4TB Samsung 870 SATA SSD (used for media for editing current projects)

E: drive: 2TB Samsung 870 SATA SSD

F: drive: 6TB WD 7200 rpm Black HDD 3.5"

Dell Ultrasharp 32" 4K Color Calibrated Monitor

Zyg wrote on 7/5/2024, 8:51 PM

@Dexcon Just tried removing the cache. Selected the tick box to delete it and hit okay. The issue is still occurring. I also tried using a different mouse and keyboard, no luck :/.

Please find the attached video of what is occurring. Keep an eye on the bottom left of the video. At first I am selecting a bottom video track and it is going to the top. In the second half of the video I am using the directional keys on the keyboard. At no point am I scrolling up or hitting up on the directional key. This is happening on all my projects.

Dexcon wrote on 7/5/2024, 9:55 PM

That is weird.

Trying the same in one of my projects (58 tracks), the Ctrl key does nothing when held down and using the mouse scroll wheel with a track header highlighted - nothing happens at all. The only way to scroll via the track headers is to use the keyboard's up/down arrows or the scroll bar to the R of the timeline, and there is no reversion to the top track as you are experiencing. Holding down the Ctrl key while scrolling the track headers via the up/down keys or timeline scroll bar makes no difference at all - so I have no idea why you're getting this behaviour.

However, holding down the Ctrl key while scrolling via the mouse's scroll wheel works as expected if the timeline is clicked on rather than the track headers.

NB: I have no custom set key or mouse behaviours so all key and mouse behaviours are at their defaults both in Vegas Pro as well as any other program on the computer or in Windows itself, the only exception being the MX Master 3 mouse itself which did require some basic selections made during its installation and setup.

Cameras: Sony FDR-AX100E; GoPro Hero 11 Black Creator Edition

Installed: Vegas Pro 16, 17, 18, 19, 20 & 21, HitFilm Pro 2021.3, DaVinci Resolve Studio 18.5, BCC 2023.5, Mocha Pro 2023, Ignite Pro, NBFX TotalFX 7, Neat NR, DVD Architect 6.0, MAGIX Travel Maps, Sound Forge Pro 16, SpectraLayers Pro 11, iZotope RX10 Advanced and many other iZ plugins, Vegasaur 4.0

Windows 11

Dell Alienware Aurora 11

10th Gen Intel i9 10900KF - 10 cores (20 threads) - 3.7 to 5.3 GHz

NVIDIA GeForce RTX 2080 SUPER 8GB GDDR6 - liquid cooled

64GB RAM - Dual Channel HyperX FURY DDR4 XMP at 3200MHz

C drive: 2TB Samsung 990 PCIe 4.0 NVMe M.2 PCIe SSD

D: drive: 4TB Samsung 870 SATA SSD (used for media for editing current projects)

E: drive: 2TB Samsung 870 SATA SSD

F: drive: 6TB WD 7200 rpm Black HDD 3.5"

Dell Ultrasharp 32" 4K Color Calibrated Monitor

Robert Johnston wrote on 7/6/2024, 5:24 PM

@Zyg, @Dexcon

In your video, other than the track headers appearing to scroll up when you click on track 6, the tracks are still in the same position, as you will notice on the right side of the video where the events are positioned. The events are still in the same position. If the track headers had been labeled, that would have been more apparent.

Why it appears to scroll up is a mystery. All I can suggest is try a different build of Vegas 21, either build 315 or build 208.

 

Intel Core i7 10700K CPU @ 3.80GHz (to 4.65GHz), NVIDIA GeForce RTX 2060 SUPER 8GBytes. Memory 32 GBytes DDR4. Also Intel UHD Graphics 630. Mainboard: Dell Inc. PCI-Express 3.0 (8.0 GT/s) Comet Lake. Bench CPU Multi Thread: 5500.5 per CPU-Z.

Vegas Pro 21.0 (Build 108) with Mocha Vegas

Windows 11 not pro

Len Kaufman wrote on 7/9/2024, 7:25 PM

Is there a general consensus as to which build of VP21 is the most stable? I've been using Vegas since version numbers were in the single digits. I've had occasional glitches, but never the number and variety of problems that I'm experiencing with Build 315.

RogerS wrote on 7/9/2024, 7:45 PM

Having tested them all, I'd recommend build 208 as a mature, stable build. @Len Kaufman

Custom PC (2022) Intel i5-13600K with UHD 770 iGPU with latest driver, MSI z690 Tomahawk motherboard, 64GB Corsair DDR5 5200 ram, NVIDIA 2080 Super (8GB) with latest studio driver, 2TB Hynix P41 SSD, Windows 11 Pro 64 bit

Dell XPS 15 laptop (2017) 32GB ram, NVIDIA 1050 (4GB) with latest studio driver, Intel i7-7700HQ with Intel 630 iGPU (latest available driver), dual internal SSD (1TB; 1TB), Windows 10 64 bit

VEGAS Pro 19.651
VEGAS Pro 20.411
VEGAS Pro 21.208

Try the
VEGAS 4K "sample project" benchmark: https://forms.gle/ypyrrbUghEiaf2aC7
VEGAS Pro 20 "Ad" benchmark: https://forms.gle/eErJTR87K2bbJc4Q7

Len Kaufman wrote on 7/9/2024, 10:40 PM

Thank you @RogerS. I'll give that a try, if I can find it.

EricLNZ wrote on 7/9/2024, 10:58 PM

@Len Kaufman The post containing the link is below. I've just checked and it's still working.

https://www.vegascreativesoftware.info/us/forum/update-vegas-pro-21-build-208--143825/

 

Len Kaufman wrote on 7/10/2024, 9:22 AM

Thank you @EricLNZ and @RogerS for taking the time to reply . I think I may have solved the problem, and it, apparently had nothing to do with Build 315. It seems that I had a faulty or possibly just overloaded USB hub. (I had a number of drives plugged into the hub.)

I removed the (external) hard drive from the hub and plugged it directly into the computer. Now VP21 build 315 is functioning the way it should. I also owe an apology to the folks at Magix, for impugning their product. Sometimes, the solution is simpler than we imagine it to be.