Machine locking up on me

dogwalker wrote on 9/6/2007, 7:42 AM
I built my machine a while back, around XP Pro, a Core 2 Duo E6300, ATI x1950xt, and and 2 GB of 6400 ram. It's never had problems, but now I'm experience hard lockups in VMS 8 Platinum.

I've tried several things to narrow down the cause, and have loaded the latest chipset drivers (VIA 4-in-1 drivers), video drivers from ATI, and Audigy drivers from Creative (the Audigy is old, and could be a problem).

Here's the interesting thing - when VMS locks up, it involves me doing some sort of mouse drag (scrolling, moving an envelop, moving a transition, etc), and only if the files I've loaded are mpg files. I can work with avi files for hours and not lockup, but mpg files eventually (sometimes quickly) lock up.

I've loaded it on both my computers in my study, and VMS never crashes on the other computer. However, that one is usually in use by my son, and is slower (2400+ xp, 1 GB ram, nvidia 6800 video). (I did check with Sony, and they said it's fine to install it on both computers as long as it's running on only one at a time).

I don't know much about codecs, but I have to wonder if maybe the two computers are handling mpegs differently. I looked at the two computers, and a few of the codecs do have different names, but when I click on properties, they appear to be the same.

I don't mine reinstalling Windows on my PC, but I'd hate to do that, and that not solve the problem.

I'm very new to video editing. In fact, my son is the one getting me into this, and I bought VMS for him. I thought video editing simply meant taking our home movies and inserting chapters using Nero Studio 7 and then burning a dvd. Now he's doing chroma key and all sorts of stuff.


Ivan Lietaert wrote on 9/6/2007, 9:27 AM
Usually, we don't edit mpg files, as it is bound to cause problems, the ones you describe included. You also lose quality, compared to editing avi source files.
So my advise is to stay away from mpg files in VMS.
The two systems you describe are quite different, especially the dual core cpu may have a big impact. You may want to check settings related to this in Vegas, and try out different memory settings as well.
dogwalker wrote on 9/6/2007, 9:42 AM
Thanks for the comment. That makes sense, avoiding mpg files. I do have another application, MemoriesOnTV, which I've used to create some great slideshows. I need to see if it will save as avi.

I know I'm going to sound like a noob, but VMS has opened a whole new world to me. I've enjoyed converting home movies to dvds in the past, and have done very well with creating slideshow videos for our Scouts and school, but I now see that I haven't even scratched the surface with regard to video editing. My young son has left me in the dust!

Thanks again for the suggestion, and it makes perfect sense.
Himanshu wrote on 9/6/2007, 8:11 PM
My guess would be that this is a lock-up due to some multi-threaded code that occurs only on your dual-core machine. You could try to verify that by booting Windows with a flag that makes the system believe that there's only one CPU - /ONECPU ( that you pass on to system startup (My Computer > Properties > Advanced > Startup and Recovery Settings > Edit, and then type the correct flag there.

When you reboot, verify that you show only one CPU in Task Manager's Performance page. If you still see two, set the computer's BIOS to disable Hyperthreading as well.

Then you can try the same steps that are causing the lock-ups and hopefully you won't lock up. If that's the case, you'll have to open a support case with Sony Creative Software.
dogwalker wrote on 9/7/2007, 1:26 PM
Thanks, Himanshu, I'll try that this weekend. I've uninstalled and reinstalled Vegas as well. I guess I could change the number of threads in the options as well.

Thanks again.
Himanshu wrote on 9/7/2007, 9:27 PM
Sure, let us know how you make out.

Changing the number of rendering threads may not eliminate the problem though it's worth a try. I'm saying that because you stated that the hang you saw was when doing other things, not necessarily rendering. To test my theory you would have to make the hardware system & Windows tell all the apps that there's only one CPU, and that's by using the boot flag I mentioned, and if necessary, the BIOS option to disable HyperThreading.

Good luck.
Ivan Lietaert wrote on 9/7/2007, 9:54 PM
I seem to remember that ATI graphics cards are not so good for Vegas compared to nVidia. So you may want to tweak some of your graphics cards settings. First check if the default settings are active. See what it does. I even think you can turn down 'hardware acceleration' completely, as Vegas doesn't use it. Then gently start tweaking the memory settings.
dogwalker wrote on 9/10/2007, 9:08 AM
I'll check my video settings, and can try the acceleration change.

As an update, I did make some progress, and then experienced hard lockups again, and then tried something else, but haven't been able to push it after this last change.

By the way, looking at another thread here, I wonder if this problem is unique to the 8.0b patch. A fellow was having problems (although not lockups), and his problems were fixed by reverting to the original 8.0 installation.

I haven't tried setting my machine to single core yet, but I did go in and lower the number of render threads. Himanshu's right, though, that likely won't help since this problem isn't during rendering.

I did once again update the 4-in-1 drivers and video drivers, just to make sure. And I did have success until yesterday afternoon when I had two avi clips (yep, I found it locks up even on avi files, not just mpg as I originally thought), and tried dragging one relative to the other. It locked hard again. I confirmed I could repeat this crash, then decided I'd try something else before I just give up and reinstall windows.

My IDE setup was
- two hard drives on the primary ide channel
- my dvd burner on the secondary ide channel

My ribbon isn't long enough to put both the burner and one of the drives on the secondary channel, so I just took the burner off and move the second drive to the secondary channel. So now each drive is on its own channel.

I was able to work quite a bit after that, and never locked up.

By the way, for grins, I installed this on my other son's computer, which has an ATI Radeon 9800 pro, but I didn't really test it. I asked him to, and he did some trivial stuff, but I don't think he did any of the things I've been trying. Still, he didn't lock up once.

So, as it stands, this could be
- low level conflicts (codecs, drivers, etc)
- ide issues when the source and destination drives are on the same IDE channel
- ATI video cards (specifically, newer cards such as the x1950xt)
- an issue with dual core machines (my sons' computers are single core amd machines, mine's a dual core intel)

If I lock up again, I'll try reducing video acceleration (I'd just need to remember to bump it back up if I play a game, but my game time is almost zero after I started messing with video editing). Either way, I'll let you guys know.
Himanshu wrote on 9/10/2007, 12:59 PM
If you change too many things you may never really understand what caused/fixed the issue! Try changing only one thing at a time and revert the change if it doesn't help.

BTW, adding the single cpu flag doesn't take long...after seeing that everything you've tried hasn't helped, my bets are still on that :)
dogwalker wrote on 9/10/2007, 2:02 PM
Himanshu, good points. I read the Microsoft article you linked, and your directions for setting ONECPU are excellent, and I'll give that a try, but first I'll give the separate IDE channels a go. If it never locks again (and I'm not confident of that), then I'd still have to wonder why.
dogwalker wrote on 9/13/2007, 8:46 PM
Well, I tried the /onecpu option, and I'm still locking completely.

Can large fragmented source files cause this? My latest scenario has me loading a large (24GB) avi file into the trimmer, then scrubbing quickly to locate regions to cut out. My goal is to take a few 5-10 second sections and combine them to create a background video for the dvd main menu.

When I'm scrubbing, at some point I lock up completely and have to power the computer off.

I've tried just about everything I can think of. I even uninstalled my divx codec, reverted Windows Media Player back to 10. I guess my next move will be to uninstall VMS and reinstall it without patching it this time.

What gets me is that it works just fine on my son's computer (granted, he hasn't messed with that one file, but we did test other files last week where I crashed and he didn't).
dogwalker wrote on 9/13/2007, 9:14 PM
Just for more information, I did reinstall (and not patch this time) VMS 8.0. The particular scenario didn't lock up after that, but that doesn't give me comfort, since I've seen this cycle too many times (i.e. I expect some other action in VMS will lock my computer at some point).

I really like this software, and I imagine it could be something with my computer. However, no other programs crash, and locking a computer is pretty hard these days (at least, supposedly, XP Pro does a better job of protecting the OS from rogue applications).
Himanshu wrote on 9/14/2007, 8:02 AM
After you used the /onecpu option, please make sure that if you bring up Task Manager it shows only one CPU. Your system may still be set up for hyper threading which will make your operating system believe that there is more than one cpu, which may lead software to spawn more threads than it would with just one CPU. Could you please verify that you are showing only one CPU when you run your tests?

The other difference I see is that originally your issue was with MPEG files, but now you are testing against AVIs. It might be better to test your original scenario as well.

Good luck.
dogwalker wrote on 9/14/2007, 11:28 AM
Well, you're right. It does show two cpus, dang it. I have a ECS PT890-A motherboard with VIA chipset. A friend had recommended it, but now I'm unimpressed by the ECS bios. I don't see anything in there to turn off hyperthreading, set to one cpu, etc.


But hey, thanks for your suggestions. I know you're having your own issues with VMS. For what it's worth, that same friend opted to get Roxio 10 (which, from what he says, does have really nice DVD creation components), and he's having crashes, too. I opted for VMS because my son wanted more video editing capabilities than he thought he could get in Roxio.

Me, I've reverted Windows Media Player back to 10, uninstalled XVid and divx drivers, and tried defragging the source hard drive (both my drives are on one IDE cable, by the way).

Finally, as a last resort, I uninstalled and reinstalled VMS 8 late last night, and did not apply the 8.0b patch (some people suggest they have better stability in 8.0 than in 8.0b).

I completely understand how complex this is, with a large, complex application and countless hardware and software and driver configurations. I'm just hoping that, with time and more information, the developers can isolate the problem and help with this. I love this software, but it's getting harder and harder to start it up, knowing there's a good chance I'm going to completely lock up.

If I need to reinstall windows xp pro, I will. For reference, here's my configuration:
ECS PT890-A motherboard (VIA chipset)
E6300 dual core processor
latest Hyperion 4-in-1 (VIA) drivers
ATI x1950xt video card, with latest catalyst video drivers
Audigy X-Gamer (old creative sound card)
two hard drives on one IDE channel
a DVD burner on the other IDE cable
2 GB of DDR 6400 ram (two sticks)
Linksys gigabit LAN (also have builtin lan, which I don't use)
Windows XP Pro, with all latest updates, other than IE 7

software installed
Firefox with a few extensions
Nero Studio 7
MemoriesOnTV 3.1.8 (great slideshow software)
CCE basic
free version of TmpGenc (old)
Windows Media Player (10 now, was 11)
dogwalker wrote on 9/14/2007, 11:44 AM
Um, I just remembered something I should have remembered before, but it's been a while since I upgraded this machine. This system used to have a different motherboard (it was VIA as well), cpu, and video card. When I upgraded, I gave those to my son, and I moved this hard drive to my new system - *without* reformatting and reinstalling Windows. I was hesitant to do so, but three separate friends told me they do so all the time with XP. In the past, I've always reformatted and reinstalled windows.

So, who knows what legacy garbage might be on my drive.

BTW, I don't know how many of the rest of you have submitted problem tickets with Sony, but I've submitted two (this locking up problem, and an original problem getting my forum access), and in both cases they have impressed me greatly with their professionalism and their desire to actually help, rather than give pat "copy and paste" platitudinous answers.

I guess that impresses me so much just because it's so rare these days, after experiences with our cable company and phone company.

Anywho, have a good weekend, and I'll see if there's any way to turn off that other processor in the bios.
Himanshu wrote on 9/19/2007, 6:16 PM

Boot into your BIOS options and go to the Advanced Settings (check your BIOS manual) and look in the "Hyperthreading Technology" option which is enabled by default. You should be able to turn it off.

However, based on what you wrote in your last post about not having reinstalled windows on your new mobo, I would *think* that your system could be in a strange state. I would defer to other experts on Windows/hardware here, but if it were me, I would never trust my system in this state.

In fact, I usually welcome the opportunity to reinstall windows and start fresh on a new machine (unless it was immediately preceded by a total system crash with data loss!).
dogwalker wrote on 9/19/2007, 9:02 PM
Yeah, I'm going to do that this weekend. This motherboard's BIOS is quite weak, there is no option for Hyperthreading (it's an ECS PT890T-A). I may never buy another ECS motherboard after this.

Oh, one guy indicated that disabling "Write Combining" might fix things. Who knows. My first move, though, will be to start with a fresh Windows install. If it still locks after that, then I'll just have to start looking at hardware.

Thanks for all the tips, though. BTW, I am able to work in Vegas for an hour or so sometimes before it locks up. Still, turning the machine off can't be good.
Himanshu wrote on 9/20/2007, 9:28 PM

The last message I posted about the option to disable hyperthreading is information from the manual for your motherboard. I guess since you're going to reinstall the system anyway, you may want to look into this further only if the reinstall doesn't solve your problem. I wish you luck.
dogwalker wrote on 9/20/2007, 11:26 PM
Wow, Himanshu, this is definitely weird. After seeing your posting, I checked the manual, and you're absolutely correct! The manual shows an entry for hyperthreading. However, my BIOS does not have that. I notice other differences, too. For example, my BIOS doesn't show the parallel port. And the manual shows me having 6 audio jacks, while I have only four. I'm very unimpressed by the poor quality control on the BIOS and manual.

Well, I'll feel better about reinstalling anyway, even if it has taken all evening. I just hope this solves my problems. I actually got to work quite a bit on it at various times with no lockups, but the fact that it locks up at all isn't good.

I'll let you know the results. I hope I can go all weekend with no lockups!
dogwalker wrote on 9/22/2007, 2:51 PM
Well, I guess I just can't use VMS8 on my current rig. I do have two more things I can try, from suggestions here:
(1) take out my Audigy sound card (which is also my firewire card, unfortunately, but ok, I can do that)
(2) re-import my movies (Digital8) from within VMS rather than using WinDV

I just ran VMS on my rebuilt hard drive, was enjoying editing, and was dabbling with rendering (not sure which to use yet). I was going to check to make sure I have DVA installed, so I clicked on the Start button to go to Programs, etc. When I clicked on Start, the machine completely locked up. No graphic glitches or anything, just froze where I couldn't move the mouse (there was no hard drive activity either). So I had to power it off.

Can I be overheating?

Unfortunately, this BIOS doesn't allow me to turn off hyperthreading, although the manual indicates it should. And this motherboard doesn't support monitoring the CPU temperature from within Windows. I guess I may have to get another motherboard and start over again.

4eyes, in the other thread, you suggested making my project properties match my source. My source in this case is all 4:3, but I'd like to create a 16:9 movie, since we have HDTV and would like to watch that way. I used the Track Motion to zoom in to fill the preview window.
dogwalker wrote on 9/22/2007, 2:56 PM
Oh, btw, I guess I could check my ram, too? My system specs:

Antec Lanboy II case, 450watt psu (some of these have had problems)
ECS PT890T-A motherboard (VIA chipset)
Intel E6300 Core 2 Duo
ATI x1950xt video card
Creative Audigy sound card and firewire connection
DVD writer
two SATA hard drives
two sticks of DDR ram (dang, I forget the speed)

Here's how I have the files set up. I put the project files, source videos, and audio on my D drive. On my C drive, I moved the Sony temp directory and prerendered directory out of "Document and Settings" and put them in a folder on root. And I was trying to render to a "Sony Movies" folder I created on my C drive.
ADB wrote on 9/22/2007, 3:10 PM
If your machine is not overheating, I'm sure you're getting hot under the collar by now. I've had several overheating problems in the past ... CPU fans lasting as little as 12 months, sometimes running erratically, causing strange effects including lock ups. Recently I was cold and had the room heater set too high and my machine started playing up ... turned the heater off and everything was fine.
I live near the ocean and find that PCs only last about 3 years before salt build up starts causing errors ... I used to leave my PC always turned on to avoid temperature cycling but found doing this draws in more salty air.
dogwalker wrote on 9/22/2007, 3:15 PM
I agree, this sounds like overheating, but I never overheat in playing intense games (I play Ghost Recon and used to play World of Warcraft), and have never locked up).

Is Vegas perhaps pushing the CPU more than other apps? I imagine it is. Unfortunately, I can't monitor the temperature without shutting down and looking in BIOS (by which time I'm sure it's cooled down some).

I'm going to post a summary of suggestions made by people here. I really appreciate the efforts to help me, a stranger.
dogwalker wrote on 9/22/2007, 3:19 PM
Try single core
- unfortunately, can't seem to do this, due to limited motherboard

Turn video acceleration down
- I haven't done this. Think it'll help? It would hurt games, but if it'll help VMS, I'm all for it.
- I did turn off Write Combining last week, and still locked up.

See what else have I've installed
- ati, which also required
- .NET 2.0
- Visual C++ 5.0 redistributable
- fraps
- Trend Micro Internet Security 2007
- Windows Media Player 11

Try removing audio card
- this is my next step, although I've already tried this once, before reinstalling, to no avail

Try importing video in VMS rather than WinDV (will try this, too)
start a new project, "File | New" follow the prompts and make your project settings to DV 4:3/16:9 (whatever your going to capture), then in the audio tab change the default settings to 16bit 48khz stereo. Save this project setup. Then using VMS capture about 30 minutes of DV-Type2 with uncompressed audio, save everything.
Also rule of thumb with almost all video editors is make your "Project Properties" equal to the source videos properties.

- I need to understand this better. What if my source video is 4:3, but I want to create a 16:9 movie?

By the way, I checked Event Viewer, and see lots of stuff:

The ACEEventLog (ATI) is full or "Information" messages which seem bad to me:
0000000002: 2007-09-22 16:40:05:437 Exception <atixcode.dll>: Retrieving the COM class factory for component with CLSID {981145A7-E08E-48F3-A1C4-52C28BCAAAF9} failed due to the following error: 80040154.

Exception Called by: ATI.ACE.CLI.Aspect.TransCode.Graphics.Shared.TC_Component::CheckTrancodeComObject processID:03548 threadID:(CCCThreadNew:Wizard) domainName:(ccc.exe ) assemblyName:(CLI.Aspect.TransCode.Graphics.Shared, Version=2.0.2756.30593, Culture=neutral, PublicKeyToken=90ba9c70f846762e)


0000000001: 2007-09-22 16:40:01:296 Failed to merge manifest file: C:\Program Files\ATI Technologies\ATI.ACE\skins\ccc-skins.xml with exception: Could not find file 'C:\Program Files\ATI Technologies\ATI.ACE\skins\ccc-skins.xml'.

Error Called by: ATI.ACE.CLI.Foundation.MergeManifest::ReadManifest processID:03548 threadID:( ) domainName:(ccc.exe ) assemblyName:(CLI.Foundation.XManifest, Version=2.0.2756.30635, Culture=neutral, PublicKeyToken=90ba9c70f846762e)


I get this a LOT in Event Viewer
Windows saved user DAD\Kerry registry while an application or service was still using the registry during log off. The memory used by the user's registry has not been freed. The registry will be unloaded when it is no longer in use. This is often caused by services running as a user account, try configuring the services to run in either the LocalService or NetworkService account.

And this

The following boot-start or system-start driver(s) failed to load: i8042prt
Paul Mead wrote on 9/22/2007, 7:20 PM
It sure sounds like you have some kind of install problem with your video card. Can't say if it is related to your hang problems, but I would not expect to see those errors.

Btw, 80040154 is a "Class not registered" error, which means, as the text implies, something tried to invoke a COM class factory that was never properly registered. Normally that kind of thing is done during the installation of the driver.

Do you have the latest video drivers for that card?