mp3 files no sound and no waveform

lon-french wrote on 2/1/2020, 12:19 AM

I have Vegas Pro 17, and when I drop a video file with video and audio, the audio track waveform and sound shows up in the track, but when I drop an mp3 file in a separate track for music to play over the video, there is no waveform showing and no sound plays from the mp3 file.
I have tried:
playing the mp3 files using Windows Media to be sure they have sound, and I have tried several different files,
dropped the mp3 in the same track as the video's audio, and I have the same no sound issue,
rebuilding the peaks by going to, Menu-Tools-Rebuild Offline Nesting Audio
rebuilding the Audio Peaks by going to Menu-View-Rebuild Audio Peaks
and showing waveforms by selecting, Audio Event Waveforms, Cntl+Shift+W

The odd thing is that the audio plays from the video and audio tracks, but it won't play the mp3 files.

Any suggestions would be appreciated.

Comments

j-v wrote on 2/1/2020, 4:23 AM

What is the MediaInfo of that problem mp3?

met vriendelijke groet
Marten

Camera : Pan X900, GoPro Hero7 Hero Black, DJI Osmo Pocket, Samsung Galaxy A8
Desktop :MB Gigabyte Z390M, W10 home version 2004 build 19041.264, i7 9700 4.7Ghz,16 DDR4 GB RAM, Gef. GTX 1660 Ti.
Laptop  :Asus ROG GL753VD, W10 home version 2004 build 19041.264, CPU i7 7700HQ, 8 GB RAM, GeF. GTX 1050 (2 GB) + Int. HD Graphics 630(2GB).VP 17,18 and VMS PL 16,17 are installed, all latest builds
Both Nvidia GPU's have driver version 456.38 Studio Driver.
TV      :LG 4K 55EG960V

My slogan is: BE OR BECOME A STEMCELL DONOR !!!

lon-french wrote on 2/1/2020, 10:37 AM

I found the solution for me.  This was from another post that was actually about the audio track making awful noises but applied to my issue too -

--With a problem file (one that has been placed in the timeline of Vegas to be edited) go into its properties and check which plug-in is being used. It's usually "mp3plug2.dll". But sometimes Vegas tries to use "mcplug2.dll" which appears to cause problems.--

For me, Vegas was using the "mcplug2.dll".  There was info in the thread on how to change the plug-in to the necessary one, but I followed this advice from another suggestion, which reset Vegas back to defaults-

--Hold down the CTRL + SHIFT keys at the same time AND ALSO AT THE SAME TIME click the program icon to start the program (the executable file that you would use to start the program). A window pops up and asks, "Do you want to reset all VEGAS Pro preferences to default values" and you can check to "Delete all Cached Application Data" I did not check that box. I then pressed Yes. This will restore program to Factory Default Settings.--

I then pulled the mp3 file into the timeline of Vegas 17 to begin editing, and the waveform was all there in the file see.

Thanks for the links!

EricLNZ wrote on 2/1/2020, 7:22 PM

@lon-french Thanks for reporting back. It appears a full reset frequently solves this mp3 problem.