'MSSQL$SONY_MEDIAMGR2 service' error message

crocdoc wrote on 7/13/2011, 4:25 AM
This seems to be a recurring thing - I'm able to use media manager for a short while, but after a few uses I get the following error message upon launching Vegas 10 "MSSQL$SONY_MEDIAMGR2 service does not exist or the current account does not have enough privilege to manage it'.

I'm not the only one to which this occurs, apparently, for a quick search around has found others asking the same question (the answer seems to be 'switch media manager off', which is unfortunate).

The last time this happened I did a complete reinstall of all of my Sony applications, but I'm unwilling to do that again if it means getting media manager to work for two launches of Vegas before it happens again. I've just uninstalled Vegas 10d to update to 10e and tried uninstalling/reinstalling media manager but now I'm getting that same error message on installation.

Does anyone have a solution to this?


crocdoc wrote on 7/13/2011, 4:45 AM
Alternatively, can anyone recommend some third party software for cataloging clips? Something that allows me to view the clips and apply tags, so when I start a project in Vegas I can find all of the clips I need easily (ie what media manager used to do, when it was working for me with Vegas Pro 8)?
JJKizak wrote on 7/13/2011, 4:59 AM
You might want to check that all of the .nets are installed---1.0, 2.0, 3.5, 4.0 and all the 5.0 stuff.
monoparadox wrote on 7/13/2011, 5:56 AM
Have you tried Windows Live Photogallery? It is surprisingly robust and handles a lot of media types--both photo and video. Best of all, it's free.
NickHope wrote on 7/13/2011, 7:10 AM
Crocdoc, first of all have you got the latest version of MM? See "options > about". Mine is 2.4.3380.13000. I got it from the Vegas Pro 9 page at [url=http://www.sonycreativesoftware.com/download/updates/vegaspro9].

Here's something I posted on another thread about updating SQL Server to service pack 4. It might be relevant to you. I am on Windows XP SP3 32-bit...

After I installed it, Windows Update wanted to update the SQL Server to service pack 4 but it would hang while doing so and I found that many people had the same problem. I suggest you update it to service pack 4 before Windows Update gets its hands on it, as otherwise you might need to go in and delete half-finished update-stuff. I used this updater: [url=

Also, take a look in Windows services. I get to them via Windows Administrative Tools. While running MM I have 4 services in there beginning with SQL (but note that I also have SQL Server Management Studio Express installed. I don't know if that makes a difference).

crocdoc wrote on 7/13/2011, 5:31 PM
Hi Nick,

Thanks for your very thorough response!

I had the latest version of MM but have downloaded it again, just in case.

When I look in the control panel under programs, SQL 5 was listed, but I downloaded the update in your link and installed that as well.

My list of SQL features under Windows Services was identical to yours before I started all of this.

I reinstalled MM after doing all of the above, but the error message reappeared on installation.

crocdoc wrote on 7/13/2011, 5:33 PM
Where do I check and how do I rectify it if they aren't?

The only one listed under programs and features is Microsoft .NET Framework 4 Client Profile
crocdoc wrote on 7/13/2011, 6:16 PM
I've lodged this with technical support but am not feeling optimistic. Perhaps it's an issue between MM and 64bit Windows 7?

Whatever it is, I have around 30+ tapes of short clips logged and tagged with MM which I am now unable to access, so when I have time I'll have to go through all of those videos one at a time and file them into folders so that I can find particular sequences in the future. I hadn't put them into folders in the past because it made it easier to find missing clips when I opened a Vegas project and was using a back-up drive with a different letter - all I had to do was direct Vegas to the appropriately named tape folder.

I am giving a presentation in two weeks and was hoping to update some of my videos by adding more recent material. There's no way in the world I'll be able to go through all of those clips to find the sequences I need, and then still have time to actually edit some videos, in that time.

As a last ditch effort, I'm going to follow the re-installation instructions on this link, one last time:
If it works I'll try to get as much done as I can on my first launch of Vegas and will not reboot my computer for the next two weeks, knowing that I'm unlikely to get media manager working again after a couple of relaunches (if I can get it working the first time as I did last time).

The level of anger and frustration I am feeling right now probably isn't coming across in my messages, but I've learned that I can't rely on media manager any more and am open to suggestions for other logging/cataloging software. I've downloaded Windows Live and will check that out for possible future use.
NickHope wrote on 7/14/2011, 5:45 AM
Are you running 64 bit Vegas? If so, maybe you could see if MM works with 32 bit Vegas (running on your 64-bit OS).
Don Sweger wrote on 7/14/2011, 6:13 AM
I'm almost in the same boat. I've had MM working in the past and now I get the same error message. I've wasted so much time trying to get this to work, I fianlly gave up. We recently shot a project with over 1200 video clips. The whole idea of MM is the be able to tag log and tag those clips and then be able search for and find them again to use where they are needed.

It woule be really nice to have a working media manager....
WillemT wrote on 7/14/2011, 7:15 AM
crocdoc, just a really wild shot in the dark.

I see you mention that the error message includes not enough security priviledge. I run with Control panel "System and Security->Action Center->Change User account Control Settings" with the slider at the bottom (Never notify). I do not have any problems with MM on two different machines - Both Windows 7 64bit.

Maybe worth a try?

crocdoc wrote on 7/14/2011, 3:17 PM
Nick, yes, I am running 64 bit Vegas. I've just done a complete uninstall/reinstall of all Sony software, as well as Microsoft SQL, and even my antivirus program (uninstalled it before reinstalling all Sony products and SQL). Media manager is working again... for now, so I'll see for how long it works before fiddling with it again. I've relaunched Vegas and rebooted the computer a few times and so far the error message hasn't reappeared, so now I'm going to quietly try to get my work done on it while I can!

Willem, the one thing that stopped me from feeling it was an account/user control issue was the inconsistency. It wasn't a matter of it working or not working, but working for a while and then failing. I, too, have my user control settings on 'never notify' because those windows security messages annoy me to no end, but thanks for the tip regardless.