.MTS files no loger work in V13 after installing V14?!

Andrew B wrote on 10/22/2016, 7:07 PM

Hmm.. so I worked on three projects that included MTS video files in V13. These are three, 8-hour, multicamera training sessions. 

I edited all three projects, rendered out draft versions, and everything worked fine. 

I just tried to re-open them up in V13 and I get an error about not being able to load in MTS files.

Just to make sure, I tried dropping one of the video files to the timeline and it just gave me audio. I also noticed I can't drop M2TS files onto the timeline at all anymore. WTH?

Possible culprit - I did install V14 after working on the project originally. 

Is it possible that V14 did something to stop MTS files from working on my computer? If so, would a re-install of V13 fix things?

Any ideas, super users?



ps - I am on a new computer, so the V13 install was completely fresh. I ended up installing V12 on this same computer to work on these projects and they work perfectly. Well, perfectly except for the fact that the V12 interface is impossible to use on a 4K monitor - but that is just a 1st world problem and easy to ignore for now. 😉


Andrew B wrote on 10/22/2016, 7:32 PM

...and the complete re-install fixed it.

Anyone else having these types of issues after installing V14 trial? 

NickHope wrote on 10/23/2016, 1:27 AM

For me, no install of Vegas ever affected functionality of any previous version of Vegas, and that includes V12/13/14.

Andrew B wrote on 10/23/2016, 1:55 PM

Same here Nick. From Vegas 7 all the way up to 13, never an issue. Not sure what happened with the .mts files all of a sudden. The only change I made was installing v14...but then again it could have been a windows update too (but then more folks would have been having the issue).

It will remain a mystery for now.


_litz wrote on 10/27/2016, 10:58 AM

I've seen issues with .mts files and LPCM audio on many occasions; sometimes they work, sometimes they don't.

I've found when they don't, I can use ffmpeg to demux, and put the elements on the timeline just fime.