videoITguy wrote on 4/8/2015, 10:19 PM
for clarity about build 444
Subject: NO MORE CRASH on startup with Build 444
Posted by: D Coblentz
Date: 4/8/2015 6:46:55 PM


I don't know about y'all, but this new Build 444 has finally solved my issues:

* Crash upon startup (had been narrowed down to two possible files within x86 folder: sfvstserver.exe & FileIOSurrogate.exe -- FIXED!

* Various video and audio formats were unavailable in "Render as" - AC3, Image Sequence, MP3, OGG, MOV, WMV, and few more (yes, I had "View all options" checked which has nothing to do with it) -- FIXED!

* Could not import certain formats, including working MP3 files (they played as a shrieking mess on the timeline) -- FIXED!

It only took 7 months (I had upgraded last October sheesh) but at least it all works. DVD Architect is still a brick though...will absolutely not start up--crash as soon as splash logo appears. Anybody with this issue still should get like a free upgrade to something!! We pay alot of money for this stuff!

Thank you Sony Creative Software for your continued efforts at addressing any issues. Hopefully these fixes carry into next version.

and then about the response of SonyKevin (Date: 4/7/2015 9:11:02 AM) from his post above - we now have

As of the date of this post edit - here is the revised explain for Build 444
2.0 What's New
Notable fixes/changes version 13.0 (Build 444)

Added templates for rendering XAVC long-GOP files.
Fixed a bug that prevented closed captions from displaying in the Video Preview window.
Fixed a bug that prevented shot marks from being read in 4K XAVC clips.
xberk wrote on 4/8/2015, 11:04 PM
>> just clicking the header of the first empty column in the Explorer window (in the details view) and boom!!!

Christian ..
Cannot reproduce here. No problems with Explorer window except renaming files. That bug still not fixed.

Paul B .. PCI Express Video Card: EVGA VCX 10G-P5-3885-KL GeForce RTX 3080 XC3 ULTRA ,,  Intel Core i9-11900K Desktop Processor ,,  MSI Z590-A PRO Desktop Motherboard LGA-1200 ,, 64GB (2X32GB) XPG GAMMIX D45 DDR4 3200MHz 288-Pin SDRAM PC4-25600 Memory .. Seasonic Power Supply SSR-1000FX Focus Plus 1000W ,, Arctic Liquid Freezer II – 360MM .. Fractal Design case ,, Samsung Solid State Drive MZ-V8P1T0B/AM 980 PRO 1TB PCI Express 4 NVMe M.2 ,, Wundiws 10 .. Vegas Pro 19 Edit

John_Cline wrote on 4/9/2015, 5:23 AM
I just dropped a couple of GoPro clips onto the timeline in build 444 and they actually played back at the full frame rate, can anyone else confirm that the GoPro playback bug may have finally been squashed?
John Lewis wrote on 4/9/2015, 7:21 AM
Surprising what happens always just before NAB i wonder why ?
NormanPCN wrote on 4/9/2015, 2:04 PM
I think the GoPro decode performance thing might be better or at least much improved.

Even on my new faster machine/cpu my 1080p60 bug/test project now plays at speed in Good mode, whereas before Preview was maybe and Good was certainly garbage. It takes a second to stabilize up to full speed. Seeks are still quite slow compared to all other AVC 1080p60 test files I have.
NickHope wrote on 4/9/2015, 11:17 PM
Could someone at SCS please let us know if anything has been changed that would improve GoPro performance? I've been telling GoPro users to either use a different NLE or to hack VP12/13 by installing mc_dec_avc.dll from VP11. So if it's improved, please tell us and put it in the release notes.

Anyone know where I can get some affected GoPro footage to test?
NormanPCN wrote on 4/10/2015, 2:25 PM
Here is a link to the 1080p60 clip I originally posted in my post, sans the VEG and GH3 AVC files.
131MB in size, 30 second clip.

Original thread
ddm wrote on 4/10/2015, 7:11 PM
From a few tests, it looks to me that 444 does NOT provide better timeline performance. Still quite slow. I've only got my laptop to to test on at the moment, but some old gopro 1080/60p footage plays very slow, if I convert it to cineform avi at the same framerate, it plays effortlessly. I also have a 1080/60p mxf file from a Sony NEX camera and that plays full frame as well. The gopro stuff slows down to 2 to 3 frames a second.
NormanPCN wrote on 4/10/2015, 8:16 PM
You cannot really compare AVC decode performance to Cineform or mpeg-2 based sources.

Try encoding your GoPro 1080p60 clip to XAVC-S MP4 via Vegas and test the decode performance of the XAVC-S on your machine. XAVC-S is high profile, CABAC AVC just like GoPro. Actually at a much higher bitrate as well which makes thing tougher.

In my old tests, everything but the GoPro played on my old machine.
wwjd wrote on 4/11/2015, 10:34 AM
Would this update leave my old/replaced files intact for gopro playback? On raw footage playback at 2.7k size, still choopy at 2FPS, but scaled down to 1080 is closer to 22fps on 30p footage and time line. For me everything was 1-2fps until I did the file swap trick. most everything else including 4k 30p plays fine in preview
RPScott wrote on 4/11/2015, 5:49 PM
It's NOT Just him. I just updated my support ticket I opened in December. I still CANNOT IMPORT X70 MXF 24P 50mbs XAVC-L files into Sony Vegas Pro 13 Build 444.

I tried updating to firmware 1.2 and still no luck.

So I bought a SONY Profesional XDCAM Camera...
Shoot Sony XAVC -L codec...
but cannot edit footage in Sony Vegas PRO 13 Build 444 software...

Sure there are work arounds...But it's been 6 months since I bought this camera in October 2014...

NaperRick wrote on 4/12/2015, 4:44 PM
If I drop an MP3 audio file to an audio track in the timeline I get a high pitched warbling noise when played - I never had that problem before build 444.
The audio event just shows a horizontal line - no audio waveform

I also can't import MOV files created with an IPhone - that is also a new problem for me with build 444.

NaperRick wrote on 4/12/2015, 5:14 PM

After a bit of Googling I ran into a fix. I had to start Vegas while holding down the CNTL and Shift key and clear all the IO cache's

Then both the MP3 and MOV file problems were resolved.

Sure with that was in the Sony Knowledge base tagged to problems with MP3 and MOV files.

Marc S wrote on 4/24/2015, 1:12 AM
Just bought a Sony X70 and I am also unable to read clips in Vegas latest build 444. I'm recording XVC-L 1080p at 60fps.

I'd file a ticket but Sony takes a month on average to respond with canned answers. Really shameful they can't get their own cameras working with their own software when Adobe CC and at least Edius are already doing it. Appears Vegas has been abandoned for the new venture called Catalyst which will probably never be completely developed either. Hope I'm wrong...
bhc wrote on 4/25/2015, 8:55 PM
For those unable to import XAVC-L footage into build 444, I suggest you try updating to the latest camera firmware. I have a PXW-X180 and footage shot with the latest 2.0 firmware does important successfully, but footage shot on earlier 1.0 and 1.1 firmware does not.

I have contacted SCS about the issues importing some footage and they are investigating.
videoITguy wrote on 4/26/2015, 10:00 AM
to bhc: Yes the Long Gop Fix reported to improve with x180 camera now in new firmware - HOWEVER for x70 camera owners - there is still no joy.
Terje wrote on 4/28/2015, 9:09 AM
For me, the first build of VP13 that I can use is 444, and thanks a lot for this release SCS.

Previously adding Film Convert to a clip would have Vegas crash instantly on playback or render, and even not having it there Vegas would crash two out of three times on render on a moderately complex timeline. For 444 I have not had a single crash so far - touch wood.