"Open in Sound Forge" fails with a lengthy audio track

TheEclipsedLock wrote on 3/7/2022, 5:33 PM

Hello! I am using Vegas Pro v18.0 build 527 on Windows 10. I am editing a video that is almost three and a half hours long. In order to be more time efficient, I was thinking of doing some edits on the entirety of an audio track and then cutting it up, rather than cutting it up and opening dozens of smaller clips in Sound Forge.

However, when I select "open copy in sound forge", I am greeted with a message that went something along the lines of "this file would exceed the maximum length" since Vegas was rendering the audio track as a .wav file before opening it in Sound Forge. Would there happen to be a way to just allow it or increase the maximum length? (As an additional note, I usually click on "Open Copy in Sound Forge" rather than "Open in Sound Forge" as the latter always gets the first audio track even if I selected a different track, while the former opens the track I want in Sound Forge.)

Or can I somehow force it to open in another audio format that would support it or be more efficient? If so on the latter, where would I search for it? I haven't yet seen an option that allows me to open it in formats other than .wav before opening sound forge.

Thank you for taking the time to read this, and potentially helping me :D

Comments

john_dennis wrote on 3/7/2022, 11:50 PM

@TheEclipsedLock

From Wikipedia:

"Limitations

The WAV format is limited to files that are less than 4 GiB, because of its use of a 32-bit unsigned integer to record the file size header. Although this is equivalent to about 6.8 hours of CD-quality audio (44.1 kHz, 16-bit stereo), it is sometimes necessary to exceed this limit, especially when greater sampling rates, bit resolutions or channel count are required. The W64 format was therefore created for use in Sound Forge. Its 64-bit header allows for much longer recording times. The RF64 format specified by the European Broadcasting Union has also been created to solve this problem."

Are you near the time limit of the WAV file format? 48kHz 24bit LPCM would be less than 6.8 hours.

My main system:
Motherboard: Asus X99-AII
CPU: Intel i7-6850K
GPU: Sapphire Radeon RX480-8GB
RAM: Corsair Dominator (4 x 4 GB) DDR4 2400
Disk O/S & Programs: Intel SSD 750 (400 GB)
Disk Active Projects: 1TB & 2TB WD BLACK SN750 NVMe Internal PCI Express 3.0 x4 Solid State Drives
Disk Other: WD Ultrastar/Hitachi Hard Drives: WDBBUR0080BNC-WRSN, HGST HUH728080ALE600, 724040ALE640, HDS3020BLA642
Case: LIAN LI PC-90 Black Aluminum ATX Full Tower Case
CPU cooling: Corsair Hydro series H115i
Power supply: SeaSonic SS-750KM3 750W 80 PLUS GOLD Certified Full Modular Active PFC Power Supply
Drive Bay: Kingwin KF-256-BK 2.5" and 3.5" Trayless Hot Swap Rack with USB 3
Sound card: Crystal Sound 3 on motherboard. Recording done on another system.
Primary Monitor: Asus ProArt PA248q (24" 1920 x 1200)
O/S: Windows 10 Pro 22H2, Build 19045.2130

Camera: Sony RX10 Model IV

https://www.youtube.com/user/thedennischannel

Dexcon wrote on 3/8/2022, 12:33 AM

@TheEclipsedLock  ... With the pertinent information that john-dennis has provided, it might be worthwhile having a look in Vegas Pro 18's Options/Preferences/General (tab) to see if the following 2 item are checked or not: 'Render large Wave files as Wave64' and 'Allow Wave renders up to 4 GB'. They are checked by default in my VP18.

Then have a look at Options/Preferences/General (tab) in Sound Forge Pro to see if 'Allow Wave renders up to 4 GB' is checked or not. It is checked by default in my Sound Forge Pro 15.

There is a 'Render large Wave files as Wave64' in Sound Forge Pro but it is hidden away in Internal Preferences. To get to it, go to Options and hold down the Shift key when clicking on Preferences. You'll then see a new tab called 'Internal'. At the bottom of the 'Internal' window is a search field - type in Wave and the top item that appears with Wave as the filter should be the Wave64 option. In the 'Value' field just to the right of that item, overwrite FALSE with TRUE and then after clicking elsewhere in that window, the Apply button should become highlighted. Hit Apply and OK and then in VP18 give the 'Open Copy in Sound Forge' process again and see if the Internal Preferences change fixes things for you. If not, try unchecking the 'Allow Wave renders up to 4 GB' in Sound Forge Pro if it is currently checked - or vice versa.

Cameras: Sony FDR-AX100E; GoPro Hero 11 Black Creator Edition

Installed: Vegas Pro 16 Edit, Vegas Pro 17 Edit, Vegas Pro 18, Vegas Pro 19 Edit, Vegas Pro 20 Edit, HitFilm Pro 2021.3, BCC 2023, Mocha Pro 2022.5.1, Ignite Pro, NBFX TotalFX 7, Neat NR, DVD Architect 6.0, MAGIX Travel Maps, Sound Forge Pro 16, SpectraLayers Pro 9, iZotope RX10 Advanced and many other iZ plugins, Vegasaur 4.0

Windows 11

Dell Alienware Aurora 11

10th Gen Intel i9 10900KF - 10 cores (20 threads) - 3.7 to 5.3 GHz

NVIDIA GeForce RTX 2080 SUPER 8GB GDDR6 - liquid cooled

64GB RAM - Dual Channel HyperX FURY DDR4 XMP at 3200MHz

C drive: 1TB M.2 PCIe NVMe SSD

D drive: 6TB WD 7200 rpm Black HDD 3.5"

E & F drives: 2 x 2TB Barracuda HDDs 2.5"

 

TheEclipsedLock wrote on 3/8/2022, 11:52 AM

@john_dennis @Dexcon Thank you so much for the information the two of you have given me! After applying those settings, I am able to open it all within Sound Forge.

David-Lay wrote on 11/8/2022, 6:17 PM

I am using VP 20 that is packaged with Sound Forge Audio Studio 15 (not pro). When I "Open in Audio Editor"to edit the audio, the audio channels automatically open in SF. However, after I have finished the audio editing, the edited audio does not export back into VP. What am I doing wrong? It use to automatically export back in older versions.

rraud wrote on 11/9/2022, 11:26 AM

You have to 'Save' the audio file in Sound Forge before closing. Unlike Vegas' "Open copy in Audio Editor" it does create a new take (file). I recommend making a copy of the file's audio prior to forking with it. Saving it in Sound Forge is a destructive process.