Preview Device Interlace Issue

OldSmoke wrote on 2/5/2013, 6:31 PM
Hi everyone.
I am not sure if that has been discussed but I have an issue with the "Apply Deinterlace Filter" setting on the "Preview Device Preference" tab. It seems that the deinterlace filter is only applied to the Preview Window but not the external monitor. I am working with 1080-60i and sometimes of my older videos are 1080-50i and both have the same issue.

A picture of the issue can be found here: https://dl.dropbox.com/u/39278380/deinterlace-test.jpg

I have a 3 monitor settup using a GTX570 and a GTX560Ti in the same PC; main window and external monitor are on the GXT570 (left & center) and the ProDock is on the GTX560 (right).

Is this an old issue or did I miss something?

Proud owner of Sony Vegas Pro 7, 8, 9, 10, 11, 12 & 13 and now Magix VP15&16.

System Spec.:
Motherboard: ASUS X299 Prime-A

Ram: G.Skill 4x8GB DDR4 2666 XMP

CPU: i7-9800x @ 4.6GHz (custom water cooling system)
GPU: 1x AMD Vega Pro Frontier Edition (water cooled)
Hard drives: System Samsung 970Pro NVME, AV-Projects 1TB (4x Intel P7600 512GB VROC), 4x 2.5" Hotswap bays, 1x 3.5" Hotswap Bay, 1x LG BluRay Burner

PSU: Corsair 1200W
Monitor: 2x Dell Ultrasharp U2713HM (2560x1440)

Comments

farss wrote on 2/5/2013, 6:41 PM
Seems to work OK on my system. My understanding is the de-interlacing is done by the GPU. I wonder if having Vegas split over two GPUs is confusing things.

Bob.
Rainer wrote on 2/6/2013, 1:41 AM
I think it's an old issue. For me seems to occur with some Canon HFS footage. Not sure if it's a Vegas or Canon or both issue, but the original clips look fine in Windows Media Player. I'm thinking it's mainly a Canon PsF issue because you can't transcode the affected footage to the same quality without artifacts. Interested if this is the footage type you are using. It's not every clip. Where it occurs I take the cowardly way out and drop every second field with VirtualDub (to me this looks better than deinterlacing). Open to any other suggestions. My example: http://dl.dropbox.com/u/96106037/Clipboard01.jpg.
Marton wrote on 2/6/2013, 5:49 AM
This picture is not interlaced, it's deinterlaced.
Maybe you mean about resampling? (double edges, etc)
OldSmoke wrote on 2/6/2013, 6:42 AM
Hi farss

I had the same thought and tested that too. I switched back to the default windows layout to have the preview window as well as the full screen external monitor on the same GPU but the problem was still the same. I have yet to remove the second GPU and just try.

The footage I use comes from all sorts of cameras but it's always a Sony; Z5U, NX5U, Z1 and a simple CX150. That means I got HDV and AVCHD. I also have very old D8 Tapes and it is the same with that footage.

I will remove one card today and see what happens.

Edit:
I removed one card and the problem was still there. It seems to be less apparent for 1080-60i but that may have to do with the fact that the temporal spacing in 60i is less then in 50i?

Proud owner of Sony Vegas Pro 7, 8, 9, 10, 11, 12 & 13 and now Magix VP15&16.

System Spec.:
Motherboard: ASUS X299 Prime-A

Ram: G.Skill 4x8GB DDR4 2666 XMP

CPU: i7-9800x @ 4.6GHz (custom water cooling system)
GPU: 1x AMD Vega Pro Frontier Edition (water cooled)
Hard drives: System Samsung 970Pro NVME, AV-Projects 1TB (4x Intel P7600 512GB VROC), 4x 2.5" Hotswap bays, 1x 3.5" Hotswap Bay, 1x LG BluRay Burner

PSU: Corsair 1200W
Monitor: 2x Dell Ultrasharp U2713HM (2560x1440)

Rainer wrote on 2/6/2013, 3:19 PM
Oldsmoke, thanks so it's probably not a Canon problem and if it's with HDV it's not an AVCHD split cadence issue. Do you have access to another NLE? If so, how does the footage look in that system? (I'm not seeing the issue with Magix, but possibly that only displays one field).
OldSmoke wrote on 2/6/2013, 3:40 PM
The only other NLE I have is Davinci Resolve Lite but it cant read HDV or AVCHD and I would have to convert it which doesn't make a good comparison. I rather believe that the deinterlace filter is only applied to the Preview Window and not the external monitor. Maybe SCS assumes that we use a TV or proper monitor for that purpose anyway? I have launched a report with SCS but not sure if I will get an answer. By the way, the final render is fine, no issue there. I could try an earlier versions; VP11 has the same issue but I still have them all from 10 down to 7.

Proud owner of Sony Vegas Pro 7, 8, 9, 10, 11, 12 & 13 and now Magix VP15&16.

System Spec.:
Motherboard: ASUS X299 Prime-A

Ram: G.Skill 4x8GB DDR4 2666 XMP

CPU: i7-9800x @ 4.6GHz (custom water cooling system)
GPU: 1x AMD Vega Pro Frontier Edition (water cooled)
Hard drives: System Samsung 970Pro NVME, AV-Projects 1TB (4x Intel P7600 512GB VROC), 4x 2.5" Hotswap bays, 1x 3.5" Hotswap Bay, 1x LG BluRay Burner

PSU: Corsair 1200W
Monitor: 2x Dell Ultrasharp U2713HM (2560x1440)

farss wrote on 2/6/2013, 3:48 PM
I did a quick check yesterday with V9 and what I noticed was it looked de-interlaced during playback at speed but when paused I'm pretty certain I could see the two fields.
I'll try to have another look for you today but I'm really snowed under with my NAS issue(s). The footage I had was mostly "garden hose cam" from a friend's holiday video so anything is possible.

Bob.
OldSmoke wrote on 2/6/2013, 9:32 PM
Thanks for the help Bob. I even find playback is a bit choppy on the external monitor but smooth in the preview window. Even when I enlarge the preview windows as big as possible, it is always smooth. I will try a TV as external monitor tomorrow and see how that fairs. GPU Acceleration on or off also doesn't make a difference. I am otherwise happy with the system and don't experience as many issues as others have. In fact, GPU acceleration always worked well on my systems but I do take a long time to research the right hardware before I build a new rig.

Proud owner of Sony Vegas Pro 7, 8, 9, 10, 11, 12 & 13 and now Magix VP15&16.

System Spec.:
Motherboard: ASUS X299 Prime-A

Ram: G.Skill 4x8GB DDR4 2666 XMP

CPU: i7-9800x @ 4.6GHz (custom water cooling system)
GPU: 1x AMD Vega Pro Frontier Edition (water cooled)
Hard drives: System Samsung 970Pro NVME, AV-Projects 1TB (4x Intel P7600 512GB VROC), 4x 2.5" Hotswap bays, 1x 3.5" Hotswap Bay, 1x LG BluRay Burner

PSU: Corsair 1200W
Monitor: 2x Dell Ultrasharp U2713HM (2560x1440)

TheHappyFriar wrote on 2/6/2013, 10:51 PM
I just tested this under Vegas 10 (never knew that option existed).

I have a second LCD monitor as my preview monitor.

With the interlace filter disabled I see interlace lines on my preview monitor.

When it enabled I don't see them, but its a little blurry.

They are gone however. Looks like it's doing a frame blend on my end.
OldSmoke wrote on 2/7/2013, 7:18 AM
I have the same interlace lines on both, the preview window and the external monitor when I switch the filter off. With the filter on the preview window is perfect, playback and paused but the external monitor is as you mentioned blurry and when there is fast motion you get something more like the same frome twice but offset. I will post another picture later to show what I mean. Maybe Vegas uses the already de-interlaced picture from the preview window and applies the filter again?

So far no reply from SCS support.

Proud owner of Sony Vegas Pro 7, 8, 9, 10, 11, 12 & 13 and now Magix VP15&16.

System Spec.:
Motherboard: ASUS X299 Prime-A

Ram: G.Skill 4x8GB DDR4 2666 XMP

CPU: i7-9800x @ 4.6GHz (custom water cooling system)
GPU: 1x AMD Vega Pro Frontier Edition (water cooled)
Hard drives: System Samsung 970Pro NVME, AV-Projects 1TB (4x Intel P7600 512GB VROC), 4x 2.5" Hotswap bays, 1x 3.5" Hotswap Bay, 1x LG BluRay Burner

PSU: Corsair 1200W
Monitor: 2x Dell Ultrasharp U2713HM (2560x1440)

TheHappyFriar wrote on 2/7/2013, 9:09 AM
How is your preview hooked up to your computer? I'm using a DVI port. Like I said, it looks like it's doing a field blend for deinterlacing. I didn't check my GPU settings to see if it has a default option, but changing in the project settings made no difference.
OldSmoke wrote on 2/7/2013, 1:58 PM
All my monitors are hookep via DVI. I also tried to use a HDTV via HDMI. I even made sure that only the HDMI port is occupied but the issue is still there. I then made a clean install of all known working Nvidia drivers: 275.33 (my favorite) up the latest 310.90 (the worst of all) but to no avail. I did notice however that the 310.90 driver creates 3D Program Profiles for VP10,11&12!

Another strange thing: I put the file in VP12 on the timeline and check the playback/ pause to test the issue...still there. I open VP11 and put the same file on the timeline... now the preview window and the external monitor show "double images" for 2 frames and then both are ok for the next frames and so on. I will restart the PC and open VP11 as the first program and see what happens.

Edit:
Did a restart, went straight into VP11 and same as above. Here is a link to 4 consecutive frames from VP11:
https://dl.dropbox.com/u/39278380/DeInterlaceIssue/Frame-1.png
https://dl.dropbox.com/u/39278380/DeInterlaceIssue/Frame-2.png
https://dl.dropbox.com/u/39278380/DeInterlaceIssue/Frame-3.png
https://dl.dropbox.com/u/39278380/DeInterlaceIssue/Frame-4.png

VP12 still has the same problem. Should I install VP10 and try? The older the version the better? Like Whisky?

Proud owner of Sony Vegas Pro 7, 8, 9, 10, 11, 12 & 13 and now Magix VP15&16.

System Spec.:
Motherboard: ASUS X299 Prime-A

Ram: G.Skill 4x8GB DDR4 2666 XMP

CPU: i7-9800x @ 4.6GHz (custom water cooling system)
GPU: 1x AMD Vega Pro Frontier Edition (water cooled)
Hard drives: System Samsung 970Pro NVME, AV-Projects 1TB (4x Intel P7600 512GB VROC), 4x 2.5" Hotswap bays, 1x 3.5" Hotswap Bay, 1x LG BluRay Burner

PSU: Corsair 1200W
Monitor: 2x Dell Ultrasharp U2713HM (2560x1440)

Rainer wrote on 2/7/2013, 2:37 PM
I don't recall this problem occurring with VP10, so it's worth a try. You could also try transcoding one of the clips that has the issue outside Vegas (like to Lagarith) and see how that looks (I'd bet really messed up). Might also mention I know another forum member who is having this issue who hasn't mentioned it on the forum.
OldSmoke wrote on 2/7/2013, 3:33 PM
I installed VP10 and that behaves like VP12. I did a render out to AVC/Progressive and with the standard project settings, Blend Fields and Gaussian I get the same mess. Only when I set deinterlace methode to interpolate I get correct result regardless of the motion blur type and renderer; same in VP11.
Then I thought that maybe the motion of the rollercoaster is just too fast for blending the fields and I just simply need interpolation? I then rendered the section with the person walking from left to right in front of the camera, the section I took the stills from and that was the same mess; only interpolation would work. I usually take sport events, like figure skating because my daugthers are figure skaters I would always use gaussian(asymmetric) and interpolate when I render out to AVC for the Internet and hence havent really noticed this issue.

Proud owner of Sony Vegas Pro 7, 8, 9, 10, 11, 12 & 13 and now Magix VP15&16.

System Spec.:
Motherboard: ASUS X299 Prime-A

Ram: G.Skill 4x8GB DDR4 2666 XMP

CPU: i7-9800x @ 4.6GHz (custom water cooling system)
GPU: 1x AMD Vega Pro Frontier Edition (water cooled)
Hard drives: System Samsung 970Pro NVME, AV-Projects 1TB (4x Intel P7600 512GB VROC), 4x 2.5" Hotswap bays, 1x 3.5" Hotswap Bay, 1x LG BluRay Burner

PSU: Corsair 1200W
Monitor: 2x Dell Ultrasharp U2713HM (2560x1440)

TheHappyFriar wrote on 2/7/2013, 8:38 PM
Interpolate to remove fields ditches a while set of fields. Blend mixes them together. That's why one looks good & the other blurs.

I'd say that it's working, you're just not expecting what's happening. It is removing the fields by blending them together.

I tried messing with the deinterlace settings in my ATI control panel, it made no difference, so it's not going though that on Vegas 10 with an ATI card.

The reason it would look OK in the preview window & not on the full display is because your preview isn't at full project resolution.
OldSmoke wrote on 2/8/2013, 11:02 AM
I did some more testing this morning as I feel that it doesnt work or atleast the way it should; certainly not for the preview window and external monitor but rendering seems ok. There are 12 scenarios that I tested with regards to changing the "Apply Deinterlace Filter" setting in the "Preview Device Preferences" as well as changing the Project settings. The test and the results are in a text file here:
https://dl.dropbox.com/u/39278380/DeinterlaceFilterTest/test_results.txt

The related pictures can be found here:
https://dl.dropbox.com/u/39278380/DeinterlaceFilterTest/Project_Prog-Gaussian-Blend-NoFilter.jpg
https://dl.dropbox.com/u/39278380/DeinterlaceFilterTest/Project_Prog-Gaussian-Blend-WithFilter.jpg
https://dl.dropbox.com/u/39278380/DeinterlaceFilterTest/Project_Prog-Gaussian-Interpolate-NoFilter.jpg
https://dl.dropbox.com/u/39278380/DeinterlaceFilterTest/Project_Prog-Gaussian-Interpolate-WithFilter.jpg
https://dl.dropbox.com/u/39278380/DeinterlaceFilterTest/Project_Prog-Gaussian-None-NoFilter.jpg
https://dl.dropbox.com/u/39278380/DeinterlaceFilterTest/Project_Prog-Gaussian-None-WithFilter.jpg
https://dl.dropbox.com/u/39278380/DeinterlaceFilterTest/Project_UFF-Gaussian-Blend-NoFilter.jpg
https://dl.dropbox.com/u/39278380/DeinterlaceFilterTest/Project_UFF-Gaussian-Blend-WithFilter.jpg
https://dl.dropbox.com/u/39278380/DeinterlaceFilterTest/Project_UFF-Gaussian-Interpolate-NoFilter.jpg
https://dl.dropbox.com/u/39278380/DeinterlaceFilterTest/Project_UFF-Gaussian-Interpolate-WithFilter.jpg
https://dl.dropbox.com/u/39278380/DeinterlaceFilterTest/Project_UFF-Gaussian-None-NoFilter.jpg
https://dl.dropbox.com/u/39278380/DeinterlaceFilterTest/Project_UFF-Gaussian-None-WithFilter.jpg

It is interesting that changing the field order to progressive, eventhough the footage is interlaced shows somewhat the correct behavior in the preview window and the external monitor. However the "Apply deinterlace filter" setting has no influence.

Once I change the field order to UFF for the project, the preview window seems to have the deinterlace filter applied at all times and using interplation. The external monitor does only do blend but not interpolation.

I dont believe it was intended this way but if so, I would appreciate an explanation.

It also doesn't make any difference where the external monitor is displayed; even on the same GPU and using the default window layout and the same monitor as external, like a single monitor setup, the results are the same.

Proud owner of Sony Vegas Pro 7, 8, 9, 10, 11, 12 & 13 and now Magix VP15&16.

System Spec.:
Motherboard: ASUS X299 Prime-A

Ram: G.Skill 4x8GB DDR4 2666 XMP

CPU: i7-9800x @ 4.6GHz (custom water cooling system)
GPU: 1x AMD Vega Pro Frontier Edition (water cooled)
Hard drives: System Samsung 970Pro NVME, AV-Projects 1TB (4x Intel P7600 512GB VROC), 4x 2.5" Hotswap bays, 1x 3.5" Hotswap Bay, 1x LG BluRay Burner

PSU: Corsair 1200W
Monitor: 2x Dell Ultrasharp U2713HM (2560x1440)

TheHappyFriar wrote on 2/8/2013, 9:20 PM
The reason the preview looks correct is because it's dropping 1/2 the image to make it fit in to the preview window, the external monitor isn't. The external is correct when you're applying the "Apply Deinterlace Filter", it's blending the fields.



The left part of the image is part of your image "Project_UFF-Gaussian-Blend-NoFilter.jpg". You can see the interlace lines. The one on the right is part of your image "Project_UFF-Gaussian-Blend-WithFilter.jpg". You can see the lines are gone.

I'd say it is doing what it is expected to do.
OldSmoke wrote on 2/8/2013, 9:58 PM
I was not aware that the preview window is only half the image. Is that documented somewhere? If what your are saying is correct, then the de-interlace filter can only do Blend but not Interpolate on the external monitor? How about the fact that it works in both windows when I set the Project Properties to Progressive?

Proud owner of Sony Vegas Pro 7, 8, 9, 10, 11, 12 & 13 and now Magix VP15&16.

System Spec.:
Motherboard: ASUS X299 Prime-A

Ram: G.Skill 4x8GB DDR4 2666 XMP

CPU: i7-9800x @ 4.6GHz (custom water cooling system)
GPU: 1x AMD Vega Pro Frontier Edition (water cooled)
Hard drives: System Samsung 970Pro NVME, AV-Projects 1TB (4x Intel P7600 512GB VROC), 4x 2.5" Hotswap bays, 1x 3.5" Hotswap Bay, 1x LG BluRay Burner

PSU: Corsair 1200W
Monitor: 2x Dell Ultrasharp U2713HM (2560x1440)

TheHappyFriar wrote on 2/8/2013, 10:22 PM
It's only half because your preview window is lower then the project resolution so it's dropping fields to make it fit.

It looks like it can only blend in an interlaced project and I don't know why.

As for it working with project properties @ progressive, I don't know. Most likely a bug somewhere that it's using the project deinterlace method with a progressive project but sticking with blend in an interlaced project setting.

Since it's narrowed down to the fact it only does blend in interlaced projects but in progressive it uses the project properties, I'd say submit it as a bug.
OldSmoke wrote on 2/9/2013, 12:26 PM
I will report this as a bug. I switched of "Simulate Device Aspect Rato" and also "Scale Video to fit Preview Window". This confirmes, sort of, that it does onlt use half the fame; now I can see the deinterlace lines. However, at this settings the "Apply Deinterlace Filter" function doesnt do anything for the preview window when the project is set to UFF, not even a blend is applied.

Just for the thrill of it. I used one of my old D8 Tapes which are PAL DV 720x576, 25i on the time line, set the project properties to match the media, draged the preview window to cover the hole monitor, 1920x1080, so that it doesnt have to scale at all. If I use the correct LFF setting for the source media, the preview window althought it displays 720x576x32 looks interlaced even with the filter on and the external monitor again only does blend and not interpolate. Only if a I set the project to progressive do I get the correct filter applied for both windows.

Sample footage: https://dl.dropbox.com/u/39278380/interlace%20test.mpg

Proud owner of Sony Vegas Pro 7, 8, 9, 10, 11, 12 & 13 and now Magix VP15&16.

System Spec.:
Motherboard: ASUS X299 Prime-A

Ram: G.Skill 4x8GB DDR4 2666 XMP

CPU: i7-9800x @ 4.6GHz (custom water cooling system)
GPU: 1x AMD Vega Pro Frontier Edition (water cooled)
Hard drives: System Samsung 970Pro NVME, AV-Projects 1TB (4x Intel P7600 512GB VROC), 4x 2.5" Hotswap bays, 1x 3.5" Hotswap Bay, 1x LG BluRay Burner

PSU: Corsair 1200W
Monitor: 2x Dell Ultrasharp U2713HM (2560x1440)

farss wrote on 2/9/2013, 1:02 PM
The Internal Preview monitor has always displayed both fields. I'd be quite annoyed if it didn't because you really need to see both fields to avoid making bad decisions.

If you want to render Progressive output from interlaced content then the project's De-interlace setting makes a difference. I set it to Interpolate and as I'm always rendering 720p for YT, the loss of vertical resolution is acceptable. If you want to deliver the best possible outcome then use the YADIF adaptive de-interlacing plugin. It is free but it is an OFX plug so the earliest version of Vegas it will work with is V10.

If you want to preview content as it will be delivered while editing then you really need an external monitor capable of correctly displaying it. HD monitors capable of correctly displaying interlaced content do exist but they are not cheap and you need to connect them via either HD-SDI or HDMI.

Bob.
OldSmoke wrote on 2/9/2013, 1:12 PM
Hi Bob.

What I am looking for is to show the interlaced video as deinterlaced on the external monitor and I thought the "Apply Deinterlace Filter" was ment to do that. It does it but only half way, up to Blend, Interpolate is not done. I know how the final delivery works and I have no issue there. It is my opinion that something isnt working correctly. If you now say that the preview window contains full frames then why does it always provide interpolated content when the project setting is interlaced but follows the interlace setting when the project is set to progressive?

Proud owner of Sony Vegas Pro 7, 8, 9, 10, 11, 12 & 13 and now Magix VP15&16.

System Spec.:
Motherboard: ASUS X299 Prime-A

Ram: G.Skill 4x8GB DDR4 2666 XMP

CPU: i7-9800x @ 4.6GHz (custom water cooling system)
GPU: 1x AMD Vega Pro Frontier Edition (water cooled)
Hard drives: System Samsung 970Pro NVME, AV-Projects 1TB (4x Intel P7600 512GB VROC), 4x 2.5" Hotswap bays, 1x 3.5" Hotswap Bay, 1x LG BluRay Burner

PSU: Corsair 1200W
Monitor: 2x Dell Ultrasharp U2713HM (2560x1440)

farss wrote on 2/9/2013, 1:50 PM
"If you now say that the preview window contains full frames then why does it always provide interpolated content when the project setting is interlaced but follows the interlace setting when the project is set to progressive? "

Are you talking about the internal or external preview?

I'm leaving out the external as that's a bit of an unknown.

The internal will display interpolated when it has to scale, turn off scaling and you should see both fields (blend).

Bob.
OldSmoke wrote on 2/9/2013, 3:53 PM
Bob.

I see both fields but interlaced and that with the filter on.
https://dl.dropbox.com/u/39278380/Pic1.png
https://dl.dropbox.com/u/39278380/Pic2.png
https://dl.dropbox.com/u/39278380/Pic3.png

I took three pictures to show all the actual settings

Setting the deinterlacing in project properties to either blend or deinterlace doesnt make a difference, the result is the same as shown in the pictures above.

As mentioned earlier, setting the project properties to progressive will work on both, the external and internal preview.

Proud owner of Sony Vegas Pro 7, 8, 9, 10, 11, 12 & 13 and now Magix VP15&16.

System Spec.:
Motherboard: ASUS X299 Prime-A

Ram: G.Skill 4x8GB DDR4 2666 XMP

CPU: i7-9800x @ 4.6GHz (custom water cooling system)
GPU: 1x AMD Vega Pro Frontier Edition (water cooled)
Hard drives: System Samsung 970Pro NVME, AV-Projects 1TB (4x Intel P7600 512GB VROC), 4x 2.5" Hotswap bays, 1x 3.5" Hotswap Bay, 1x LG BluRay Burner

PSU: Corsair 1200W
Monitor: 2x Dell Ultrasharp U2713HM (2560x1440)