render is DARKER. this seems new VP17

wwjd wrote on 11/8/2019, 7:11 AM

I GET levels. Use them all the time. Kept all my video tracks restricted to 16-235 levels. EXCEPT the top which is black bars overlay. Because, well, I want them to stay deep black, like I have always done in previous versions.

Preview LOOKS fine. Rendered to Magix Internet HD (like I always used to do just fine) and levels plummet in 17. Why? New codec in there? What happened to the WYSIWYG render from preview?

If I slap levels on final master, black bars will be gray bars and I don't want that.

Comments

Marco. wrote on 11/8/2019, 7:53 AM

Could you show a screenshot of the whole preview window, including top and bottom bar?

Len Kaufman wrote on 11/8/2019, 9:19 AM

Experiencing something similar, though not involving black bars. Just the images themselves. Everything looks fine in preview, but the final rendered video is decidedly darker.

Marco. wrote on 11/8/2019, 10:03 AM

Is it darker in an external player or in the Vegas Pro preview?

wwjd wrote on 11/8/2019, 12:23 PM

Marco, is darker in external players: VLC, Windows Media photo video whatever, old Media Player. Is like my 16-235 on the tracks - seen in preview - are not pushed to file. All my old stuff rendered this was used to be, with VLC displaying 16-235 correctly, and Windows Media being natively darker, but still proper.

The pic I posted above shows the Preview screen on the right, and VLC on the left. The background on the right is a dark gray, not black, like the black bars at top and bottom.

A couple details possibly, but doubtfully related, I'm running nvideo 10bit mode, and in vegas, rendering from 32bit floating point video. I did try rendering a second from 8bit mode and it made no difference.

I understand external players can and do play back things differently, which is why I use 3 or 4 of them to test. But usually I can make a render out to 16-235.

Also have tried changing "COLOR SPACE" in the render part to rec709, but that changed nothing.

May be the black bars overlay is yanking everything back up to FULL 0-255, but the preview does not show that even at BEST/FULL SIZE settings.

 

Marco. wrote on 11/8/2019, 12:49 PM

That's what my guess was. The Vegas rendered files actually aren't darker. Instead the players do a studio swing/full swing adoption.

fifonik wrote on 11/8/2019, 4:45 PM

It was always like this. If preview is not on separate monitor, it does not show you "proper levels" (you can use SemW extension to apply required StuduiRGB to ComputerRGB conversion).

Check FAQ

Last changed by fifonik on 11/8/2019, 4:47 PM, changed a total of 1 times.

Camcorder: Panasonic X920

Desktop: MB: MSI B450M MORTAR TITANIUM, CPU: AMD Ryzen 3700X, RAM: G'Skill 16 GB DDR4@3200, Graphics card: MSI RX470 4GB, SSD (OS): Samsung 850 EVO SATA 250MB, HDDs: Seagate & Toshiba 2TB, OS: Windows 10 Pro 1909

NLE: Vegas Pro [Edit] 11, 12, 13, 15, 17

wwjd wrote on 11/8/2019, 7:40 PM

Well, I usually don't have this issue. Render to 16-235, stays to 16-235. I'll figure it out tomorrow. Thanks for the help.