Resampling - again

nepomuk wrote on 2/16/2019, 5:51 AM

VMS16: Rendering 1920x1080p30 mp4 source files (from a mobile phone) to 1920x1080i29.97 (for Blu-Ray) always triggers the (Smart) Resampling and produces ugly blended fields, only because the source file is not exactly 29.97fps but slightly off, say 30.007fps or 29.884 for example. So far that's by design it seems which I understand.
However, even disabling the Resampling does not help to prevent the field blending. The only way I found which seems to solve the issue is to set the rendering quality to Preview or Draft. The higher quality settings produce blended fields even though the (smart) resampling is disabled. I think this is a bug.

Secondly, I found the rendering process behaves different when the Resampling is disabled via the Switch or via the Preferences menu. Confused ...…..

Comments

3POINT wrote on 2/16/2019, 9:54 AM

Import your mobile phone clips with projects frame rate.

nepomuk wrote on 2/16/2019, 10:15 AM

Thanks. I tried but this still creates blended fields unless I set the rendering quality to lower levels like preview or draft …… strange.

j-v wrote on 2/16/2019, 11:48 AM

And your rendertemplate is?????

met vriendelijke groet
Marten

Camera : Pan X900, GoPro Hero7 Hero Black, DJI Osmo Pocket, Samsung Galaxy A8
Desktop :MB Gigabyte Z390M, W10 home version 2004 build 19041.264, i7 9700 4.7Ghz,16 DDR4 GB RAM, Gef. GTX 1660 Ti.
Laptop  :Asus ROG GL753VD, W10 home version 2004 build 19041.264, CPU i7 7700HQ, 8 GB RAM, GeF. GTX 1050 (2 GB) + Int. HD Graphics 630(2GB).VP 17,18 and VMS PL 16,17 are installed, all latest builds
Both Nvidia GPU's have driver version 456.38 Studio Driver.
TV      :LG 4K 55EG960V

My slogan is: BE OR BECOME A STEMCELL DONOR !!!

EricLNZ wrote on 2/16/2019, 4:40 PM

@nepomuk - your phone clips are probably variable framerate and 30.007 etc is probably the average framerate. Variable framerate files are a problem with NLEs and there are many posts on the problem. The usual recommendation is to convert the files with Handbrake and use the resulting mp4 files in VMS.

nepomuk wrote on 2/16/2019, 5:41 PM

@EricLNZ

I think you are perfectly right. The .mp4 mobile phone files are indeed VFR. I dumped the time stamps and interestingly they are quite regular i.e. basically CFR with the exception of perhaps the first and the last frame which are off the kilter. I was hoping that VMS 16 would master this case as it was advertised to better cope with VFR files. Unfortunately that seems not to be the case (yet), but surprisingly it seems to be somehow doable with lower rendering quality settings.

Anyway, as you mention, it is probably safer to pre-process the files with HandBrake or ffmpeg. Thanks for pointing this out 🙂.

3POINT wrote on 2/17/2019, 6:46 AM

I just started 2weeks ago to edit my Samsung variable framerate recordings. I got perfect results, without blending or missing frames by importing each clip at projectframerate (30fps) and rendering with the renderwizard (mp4).

nepomuk wrote on 2/17/2019, 9:24 AM

Interesting. Maybe it works more reliable as long as everything stays progressive? I want to convert the "approximate 30fps" progressive Samsung .mp4 clips to Blu-ray format 1920x1080i60 (59.94 fields per second) for later authoring to a Blu-ray disc by means of DVDA. I am using the AVCHD template in VMS which converts the progressive VFR frames to interlaced Blu-ray compatible format, unfortunately producing blended fields unless I set the rendering quality to preview or draft, even though I import the clips at project framerate.

3POINT wrote on 2/17/2019, 12:37 PM

Blended fields is always a result of resampling, which is active when mediaframerate doesn't match projectframerate. This probably also happens when you try to make 60i from 30p. Like presampling is not shown in preview draft or preview, it is also probably not used when you render with project quality set to draft or preview. I would prefer disable resampling instead.

nepomuk wrote on 2/17/2019, 1:04 PM

Yes, agree. That was my conclusion as well. But I am still wondering why disabling resampling still does produce blended fields when the render quality is set to higher levels (even though the clip is imported at project framerate). But maybe it's not really an issue to select a lower render quality (like preview or draft) because I read somewhere that this setting affects predominantly the resizing algorithm, so as long as I don't resize I shouldn't experience any significant quality losses (I hope).

Edit: I did few more test and confirm that the smart resample and disable resample behave as expected as long as everything stays progressive. The problem with the blended fields despite disabled resampling exists for the case of progressive-to-interlaced conversion with higher quality rendering setting only and can be solved with setting the rendering quality to preview (or draft).

EricLNZ wrote on 2/17/2019, 4:10 PM

Maybe you've discovered another resampling bug. I say another because there are existing old bugs unless they've been fixed in VMS16. I haven't checked. My main problem is that disabling resampling with interlaced material results in final incorrect field order as interlaced frames are duplicated instead of being deinterlaced then duplicated.

Could you upload one of your short problem phone files somewhere so we can download as I'd like to have a play with it to see what I get.

nepomuk wrote on 2/17/2019, 5:35 PM

Here we go:

http://www.mediafire.com/file/32s097ru44ku99r/2018-08-19_17.42.01.mp4/file

Render with VMS 16 to AVCHD 1920x1080 60i with render quality set to preview and high and inspect the fields.

Looking forward to your findings. Thanks for checking.

 

EricLNZ wrote on 2/17/2019, 7:15 PM

Thanks. Very pretty.

Adding the file to the timeline of a 1920x1080 29.97i project I get the audio longer than the video. 16 secs 11 frames compared to 15 secs 22 frames? I disabled Resampling from the timeline clips properties menu (right click).

Exporting to Sony AVC/MVC AVCHD 1920x1080-60i template using rendering qualities of Preview, Good and Best (I have no High option) the results were identical. Advancing frame by frame with MPC-HC, and on a VMS16 timeline, with project properties set to 59.94 so every deinterlaced frame was visible, I found no ghosting. As expected with resampling, disabled frames had been duplicated. The only "ghosting" is with the far right wheel but this is visible on the original file as the camera shutter hasn't frozen all movement and there's blurring.

So I cannot reproduce the problem. I was only using CPU processing. Are you perhaps using GPU processing and this is causing a problem?

nepomuk wrote on 2/18/2019, 2:03 AM

I agree with all your findings and comments. It is just unfortunate (it was late yesterday …..) that I happened to pick a clip for which "disable resampling" works as expected and independent of the rendering quality setting. Later today I'll try to find a critical clip which is short enough for uploading which should eventually demonstrate my issue. I just don't want to trim a longer clip for uploading, because trimming may affect the behavior. (On the other hand cutting off the first and last few frames may perhaps be a solution - I'll have to try).
Btw. I am using CPU processing. It seems that GPU with NVIDIA HW is not very efficient. But this is only my first and vague impression.

j-v wrote on 2/18/2019, 3:12 AM

Maybe my way of working with your previous sended file can help you if you see troubles again.
I rendered with my fastest renderoption ( with the Nvidia 😉) but had not the possibilty to render to 60i although the project was set to i, so it rendered to 60p out of yours nearly 30p file.
Look

Last changed by j-v on 2/18/2019, 3:15 AM, changed a total of 2 times.

met vriendelijke groet
Marten

Camera : Pan X900, GoPro Hero7 Hero Black, DJI Osmo Pocket, Samsung Galaxy A8
Desktop :MB Gigabyte Z390M, W10 home version 2004 build 19041.264, i7 9700 4.7Ghz,16 DDR4 GB RAM, Gef. GTX 1660 Ti.
Laptop  :Asus ROG GL753VD, W10 home version 2004 build 19041.264, CPU i7 7700HQ, 8 GB RAM, GeF. GTX 1050 (2 GB) + Int. HD Graphics 630(2GB).VP 17,18 and VMS PL 16,17 are installed, all latest builds
Both Nvidia GPU's have driver version 456.38 Studio Driver.
TV      :LG 4K 55EG960V

My slogan is: BE OR BECOME A STEMCELL DONOR !!!

3POINT wrote on 2/18/2019, 4:08 AM

Nepomuk wants to make from his 30 vfr progressive smartphone recordings a Blu-ray, which ofcourse is interlaced and not progressive.

3POINT wrote on 2/18/2019, 4:57 AM

Just downloaded your example.

My workaround:

1. Set the projectsettings of your VMS to:

2. Import your clip(s) to the timeline at Projects framerate (rightclick clip(s) in mediafolder).

3. Render with your favorite Bluray 1080i60 template.

No need to disable resampling and no ghost images.

Last changed by 3POINT on 2/18/2019, 5:04 AM, changed a total of 2 times.

3POINT, Theo Houben, Vegasuser since version 5 and co-founder of the Dutch Vegasforum https://www.vegas-videoforum.nl/index.php

Recware: DJI Osmo Pocket, GoproHero7Black, PanasonicFZ300/HCX909, Sony PXW-X160.

Software: Vegaspro18/VegasMovieStudio17/PowerDirector365

Hardware:i7 4770, 16GB, GTX650ti, 1920x1200 display

Playware:Samsung Qled QE65Q6FN, Philips 55PFL7108

j-v wrote on 2/18/2019, 5:15 AM

Thanks Theo.
So the OP may ignore my message but in fact I was a bit reacting on what @EricLNZ was telling

Adding the file to the timeline of a 1920x1080 29.97i project I get the audio longer than the video. 16 secs 11 frames compared to 15 secs 22 frames?

that longer audiofile is caused by the way adding such a file to the timeline
do it by dragging from the Vegas explorer gives this


-first opening in Projectmedia and than dragged to the time gives this

 

met vriendelijke groet
Marten

Camera : Pan X900, GoPro Hero7 Hero Black, DJI Osmo Pocket, Samsung Galaxy A8
Desktop :MB Gigabyte Z390M, W10 home version 2004 build 19041.264, i7 9700 4.7Ghz,16 DDR4 GB RAM, Gef. GTX 1660 Ti.
Laptop  :Asus ROG GL753VD, W10 home version 2004 build 19041.264, CPU i7 7700HQ, 8 GB RAM, GeF. GTX 1050 (2 GB) + Int. HD Graphics 630(2GB).VP 17,18 and VMS PL 16,17 are installed, all latest builds
Both Nvidia GPU's have driver version 456.38 Studio Driver.
TV      :LG 4K 55EG960V

My slogan is: BE OR BECOME A STEMCELL DONOR !!!

3POINT wrote on 2/18/2019, 5:31 AM

Hi Marten, indeed dragging from explorer folder or from media folder gives different results. But both methods still give blended fields due to the resampling.

nepomuk wrote on 2/18/2019, 7:54 AM

@3POINT

Your suggested procedure is exactly what I am doing.

But now try this file, which has a framerate of slightly above the project framerate of 29.97i.

http://www.mediafire.com/file/zadk4jct8c60a8z/2018-07-20_15.34.22.mp4/file

Import it at project framerate and convert it to 1920x1080i60. Independent of "smart" or "disabled" resampling I am always getting blended, messed up fields, unless I set the rendering quality to preview (or draft).

 

3POINT wrote on 2/18/2019, 8:39 AM

@nepomuk

I did, the same perfect result as with your previous clip. Just be sure that you import all your clips at projects framerate. See below: you will directly recognize in the preview (when set to best) if there is blending or when not.

3POINT wrote on 2/18/2019, 8:54 AM

The result of my rendering: https://www.dropbox.com/s/66zjh9dldh2arka/test.m2ts?dl=0

nepomuk wrote on 2/18/2019, 12:55 PM

Now that's really amazing. Your result is what I would expect. But see what I am getting when rendering with quality good or best (for smart resampling and disabled resampling, doesn't matter):

https://www.mediafire.com/file/tquq8uc9oxb9q9n/W2gutoff.m2ts/file

I import the clip at project framerate as you did. The broken picture sequence for the video and the 99.9% at the end of the audio track indicate that the clip is actually imported at the project framerate of 29.97i).

Odd. Something must be broken here. Maybe I should reinstall VMS. I am using VMS 16 Build 109.

Scratching my head…..

3POINT wrote on 2/18/2019, 2:02 PM

When I play your rendered file, I don't see anything unusual. Seems OK to me.

How do you exactly render, I used the AVCHD renderwizard, renderquality is always projectquality:

nepomuk wrote on 2/18/2019, 5:20 PM

That's exactly how I render it.

If you step through my rendered file W2gutoff.m2ts at field level, means either separate the frames into fields or bob-deinterlace it, don't you see how the fields are blended?

Your rendered files is ok though, same as I get when I set in the Project Properties the Full-resolution rendering quality to Preview.