Resampling - again

Comments

EricLNZ wrote on 2/18/2019, 5:39 PM

Like 3POINT it plays okay for me. I don't see any blended frames. What do you mean by "field level'? How are you watching the file?

The right windmill is blurred as its either slightly out of focus or its movement hasn't been frozen by your camera's shutter speed. But there's no ghosting. There is a very slight variation between identical frames caused by the file being interlaced and my players interpolation of the missing fields not being totally accurate, but that's normal with interlaced images where half of each frame is "made up".

In conclusion I don't believe there is anything wrong with your exported file. Perhaps there's something strange how you are playing it?

EricLNZ wrote on 2/18/2019, 5:44 PM

Further thought: I wonder if your player is only showing half of the full frame rate and blending two frames together?

EricLNZ wrote on 2/18/2019, 6:00 PM

Thanks Theo.
So the OP may ignore my message but in fact I was a bit reacting on what @EricLNZ was telling

Adding the file to the timeline of a 1920x1080 29.97i project I get the audio longer than the video. 16 secs 11 frames compared to 15 secs 22 frames?

that longer audiofile is caused by the way adding such a file to the timeline
do it by dragging from the Vegas explorer gives this


-first opening in Projectmedia and than dragged to the time gives this

 

Something else new I've learnt today. But why does it vary. Is it a bug?

nepomuk wrote on 2/18/2019, 6:31 PM

Let me explain a bit better what I am talking about:

The AVCHD rendered file is 29.97 interlaced frames per second = 59.94 fields per second. This is what is generated with the AVCHD template and it is Blu-ray compliant. So far ok.

If you playback and deinterlace in real-time you may not see the deficiencies in my uploaded W2gutoff.m2ts file. At a first glance it may look ok. When we however split the frames into fields (which are half hight) and step through the fields we see (or I see) that the fields are not clear but blended (=ghosts). I understand motion blur and camera defocus, but this is not what I am talking about. I am also not watching the interlaced frames on a progressive monitor without deinterlacing (which would show combing).

I examine the separated fields with avisynth with the script

assumeTFF() #for top field first
separatefields()

and play this script in a SW player stepping through the fields.

Anyway, I can prevent the field blending by selecting the render quality in the project settings to Preview.
As long as I remember this the result will be ok, means no blended fields. Both fields are taken from the same source frame, without interpolation or similar.

I am just still wondering why the file which was rendered by 3POINT with quality set to Good does not have the same blended fields as mine ……

 

3POINT wrote on 2/19/2019, 3:17 AM

I'm wondering that you make interlaced (i60) from progressive (p30) to let your player deinterlace it (to get p30). Normally, making interlaced from progressive should give two identical interlaced fields, because there is no time difference. Also making interlaced from progressive will not give the smoother look of interlaced. (only p60 to i60 gives).

nepomuk wrote on 2/19/2019, 4:01 AM

The only reason is Blu-ray compliance. The Blu-ray standard does not accept 1920x1080 30p, but only 29.97i (sometimes called 60i referring to the 59.94 fields per second - there is some ambiguity with the terminology). This is also what the AVCHD template in VMS correctly takes care of.

Blu -ray accepts 1920x1080 progressive as 23.976p or 24.000p only, but not 29.97 which MUST be encoded or flagged as interlaced, otherwise authoring programs like DVD Architect will reject it or re-encode it once more to make it compliant.

You are right, the 29.97 interlaced frames have 2 "identical" fields (well, with 1 scanline off) without time difference, and hence will not give a smoother look. It is simply to satisfy the Blu-ray standard and hence to avoid rejection of the files by disc authoring programs or (HW) players.

Because the Samsung mobile phone clips are 1920x1080 29.97 progressive (VFR, unfortunately, with slightly above or below the nominal 29.97fps), they have to be converted to Interlaced (or pseudo-interlaced as 2 "identical" fields with no time difference) by VMS for Blu-ray compliance. VMS basically does this with the AVCHD template - with the issues (or bug?) I reported in my case. If I want to prevent VMS to do something "smart" during the progressive to interlaced conversion, I have to set the render quality to Preview or Draft. Otherwise it may interpolate and/or produce blended fields. Even disabling the resampling does not help.

3POINT wrote on 2/19/2019, 4:33 AM

I have also a Samsung mobile phone and discovered a strange phenomena two weeks ago when I first started to edit those clips in VMS. When importing those clips on my Edit PC, VMS behaves like I showed you, importing the clips sets VMS to the framerate of the first clip (somewhere around 30 fps). When importing those clips to my Edit Laptop, those clips sets VMS to exactly 30,0000 fps. Till now I couldn't find an explanation for this difference, my laptop and pc have almost the same specs, ofcourse the same version and build of VMS, only difference is the GPU.

I had already long discussions about this with j-s, who discovered the same behavior on his laptop.

With other words, VMS seems to behave different on different systems...

nepomuk wrote on 2/19/2019, 5:08 AM

OMG.....

To complicate things a bit more:
I noticed different rendering behavior when I disabled the Resampling by
a) selecting the video track on the timeline, right click, Switch … and select Disable Resampling
b) selecting the video track on the timeline, right click, Properties …. and disabling the Resampling in the window popping up
Actually I am on the German version of VMS, so my translations may not be 100% correct. But now I am even afraid that there might be differences between language editions, although same version (16.0) and Build (109). Ugghhh…...

j-v wrote on 2/19/2019, 5:09 AM

The only reason is Blu-ray compliance.

Maybe this is the time to quit that old and not further supported option from the past.
I did it already more than 4 years ago and since that time I'm a happy user again that uses all the modern options of a good and uptodate edit program!

met vriendelijke groet
Marten

Camera : Pan X900, GoPro Hero7 Hero Black, DJI Osmo Pocket, Samsung Galaxy A8
Desktop :MB Gigabyte Z390M, W10 home version 2004 build 19041.264, i7 9700 4.7Ghz,16 DDR4 GB RAM, Gef. GTX 1660 Ti.
Laptop  :Asus ROG GL753VD, W10 home version 2004 build 19041.264, CPU i7 7700HQ, 8 GB RAM, GeF. GTX 1050 (2 GB) + Int. HD Graphics 630(2GB).VP 17,18 and VMS PL 16,17 are installed, all latest builds
Both Nvidia GPU's have driver version 456.71 Studio Driver.
TV      :LG 4K 55EG960V

My slogan is: BE OR BECOME A STEMCELL DONOR !!!

3POINT wrote on 2/19/2019, 5:31 AM

OMG.....

To complicate things a bit more:
I noticed different rendering behavior when I disabled the Resampling by
a) selecting the video track on the timeline, right click, Switch … and select Disable Resampling
b) selecting the video track on the timeline, right click, Properties …. and disabling the Resampling in the window popping up
Actually I am on the German version of VMS, so my translations may not be 100% correct. But now I am even afraid that there might be differences between language editions, although same version (16.0) and Build (109). Ugghhh…...


As being a Dutchman living in Germany, I always use the English version of VMS (also niemals die Deutsche Version, wegen der manchmal sehr krummen Uebersetzungen und die Missverstaendnisse die dadurch entstehen koennen).

With my workflow (importing clips at projects framerate) I didn't disable the smart resampling.

nepomuk wrote on 2/19/2019, 6:21 AM

The only reason is Blu-ray compliance.

Maybe this is the time to quit that old and not further supported option from the past.
I did it already more than 4 years ago and since that time I'm a happy user again that uses all the modern options of a good and uptodate edit program!

I would have to disagree. Blu-ray and DVD are quite alive.

Or take for example my scenario:
I want to make some clips of great-grandchildren available to their great-grandparents. The great-grandparents are no digital natives, but they have a TV and a player which they know how to operate. No USB sticks or external drives, no cloud access, no NAS etc. So I author the clips to a Blu-ray disc, add a simple menu for navigation and selecting the clip they want to view, and we are done. No explanation about TV settings, no aspect ratio issues, no extra items to download and install and so on.

3POINT wrote on 2/19/2019, 6:26 AM

Ha ha, I and j-s are digital natives grandparents who make clips available to their children and grandchildren....they get always my old TV equipment, so they are well equipped with TV with USB ports. 

Last changed by 3POINT on 2/19/2019, 6:30 AM, changed a total of 1 times.

3POINT, Theo Houben, Vegasuser since version 5 and co-founder of the Dutch Vegasforum https://www.vegas-videoforum.nl/index.php

Recware: DJI Osmo Pocket, GoproHero7Black, PanasonicFZ300/HCX909, Sony PXW-X160.

Software: Vegaspro18/VegasMovieStudio17/PowerDirector365

Hardware:i7 4770, 16GB, GTX650ti, 1920x1200 display

Playware:Samsung Qled QE65Q6FN, Philips 55PFL7108

j-v wrote on 2/19/2019, 6:40 AM

Yess, you may need it, but I'm glad I don't need it (anymore).
And you know what is so funny?
I also have grandchildren and I make video's for them and for their parents (my children) and those video's ought not being longer than 1 minute and "grandpa please only to play on my smartphone because other things we don't have". 😀😄

met vriendelijke groet
Marten

Camera : Pan X900, GoPro Hero7 Hero Black, DJI Osmo Pocket, Samsung Galaxy A8
Desktop :MB Gigabyte Z390M, W10 home version 2004 build 19041.264, i7 9700 4.7Ghz,16 DDR4 GB RAM, Gef. GTX 1660 Ti.
Laptop  :Asus ROG GL753VD, W10 home version 2004 build 19041.264, CPU i7 7700HQ, 8 GB RAM, GeF. GTX 1050 (2 GB) + Int. HD Graphics 630(2GB).VP 17,18 and VMS PL 16,17 are installed, all latest builds
Both Nvidia GPU's have driver version 456.71 Studio Driver.
TV      :LG 4K 55EG960V

My slogan is: BE OR BECOME A STEMCELL DONOR !!!

Marco. wrote on 2/19/2019, 6:55 AM

@nepomuk

»I noticed different rendering behavior when I disabled the Resampling by
a) selecting the video track on the timeline, right click, Switch … and select Disable Resampling
b) selecting the video track on the timeline, right click, Properties …. and disabling the Resampling in the window popping up
«

I use the German version of Movie Studio, too. It doesn't matter from where you disable resampling. It's always the same core function.

When you say there is a different rendering behavior, what exactly does that mean?

nepomuk wrote on 2/19/2019, 7:20 AM

@Marco
Example: Mobile VFR clip with framerate slightly off from nominal 29.97fps, say slightly below. Import it at project framerate.
- Video timeline changes differently for the 2 options for disabling the resampling (depending on source)
- rendered filesize is different, and the frames/fields are also not identical for the 2 options.

This was just an observation. I didn't investigate further.

Marco. wrote on 2/19/2019, 7:46 AM

»You are right, the 29.97 interlaced frames have 2 "identical" fields (well, with 1 scanline off) without time difference, and hence will not give a smoother look.«

Checking your clip W2gutoff.m2ts, upper and lower fields are not identical. This clip and its fields look fine here.

Stepping through some checkpoints now.

3POINT wrote on 2/19/2019, 7:51 AM

When I disable resampling, whether by event properties or by event switches, it toggles the same function, as Marco also already stated, also I don't see any difference in behavior or difference in preview (set to best).

Marco. wrote on 2/19/2019, 8:07 AM

And I now did a render test with your second VFR clip added at project framerate. One go resampling turned off by the switch, one go turned off by the properties. I always render with the "Best" render quality option. Both rendered clips are exactly the same (exactly same length).

There must be something else diffferent in your project.

nepomuk wrote on 2/19/2019, 8:10 AM

Checking your clip W2gutoff.m2ts, upper and lower fields are not identical.

Of course not, because VMS created new fields, but unfortunately all fields are blended (with ghosts).

I would have expected to get identical clean fields for the top and bottom field which constitute a frame. The original frame is progressive, and I don't want VMS to synthesize or interpolate new fields.

nepomuk wrote on 2/19/2019, 8:18 AM

And I now did a render test with your second VFR clip added at project framerate. One go resampling turned off by the switch, one go turned off by the properties. I always render with the "Best" render quality option. Both rendered clips are exactly the same (exactly same length and both are without interlaced lines).

 

Did you step through the fields? How do they look? Clean, no blends visible? No motion between the field pairs which constitute an interlaced frame? Did you render with the AVCHD template? Can you perhaps upload your rendered sample?

Marco. wrote on 2/19/2019, 8:31 AM

Both rendered clips are here.

Clean, no blending. Rendered with the given AVCHD template. But (unlike I first wrote and then deleted in my post above) motion differences between the two fields of one frame. This is what surprises me. While it seems you expected this one, I didn't. With resampling disabled Movie Studio should render two identical fields for each frame even when the output is technically flagged as interlaced.

Do you see the blending in the Movie Studio preview?

Marco. wrote on 2/19/2019, 9:02 AM

I see the field differences (which were not expected result for me) are caused by the frame rate adaption. This seem to override the disabled resampling in some way. If you set the frame rate to 1 or 0.5, disabled resampling behaves as expected.

I will check if former Vegas Pro or Movie Studio versions behaved same way.

Edit:

Same behaviour in Vegas Pro 13. If the playback rate is altered to anything else but even divided rates, disabling resample fails. Disabled resample works the way expected for the frame rates of 1 and 0.5 and 0.25. It seems if Vegas Pro or Movie Studio fails in using even doubled frames it falls back to resampling instead.

So in the end all I can do is to state what nepomuk already reported in his very first post, except of there is no difference on my system between the way I select the resampling mode.

nepomuk wrote on 2/19/2019, 9:53 AM

@Marco.

Your uploaded rendered files look exactly like mine. But I have to disagree that the fields are clean. They are blended. You will see this when you separate the fields (e.g. with avisynth or VirtualDub) an look carefully.

So I am happy that you confirm that resampling cannot (unfortunately) be disabled unless for specific fractions 1, 1/2, 1/4 and falls back to resampling otherwise, in particular this happens for the VFR clips which will always be resampled as they will never fullfill the condition.

As I mentioned before, I found however a workaround to force the disabling of the the resampling, namely to set the project render quality to preview (Vorschau) or Draft (Entwurf). Then you will get - even for the VFR clips - clean fields without motion between the fields belonging to the same source frame. As it should be. Just try it.

Marco. wrote on 2/19/2019, 10:26 AM

Yes, the results with that both render qualities is expected behaviour because "Draft" and "Preview" will always turn resampling competely off.

Just digged the official infos about the quality settings once published by a SCS tech:

Quality: Best

Scaling: bi-cubic/integration
Field Handling: on
Field Rendering: on (setting dependent)
Framerate Resample/IFR: on (switch dependent)

Quality: Good

Scaling: bi-linear
Field Handling: on
Field Rendering: on (setting dependent)
Framerate Resample/IFR: on (switch dependent)

Quality: Preview

Scaling: bi-linear
Field Handling: off
Field Rendering: off
Framerate Resample/IFR: always off

Quality: Draft

Scaling: point sample
Field Handling: off
Field Rendering: off
Framerate Resample/IFR: always off

Scaling:

These methods come into play when conforming sources that differ from the output size. They are also used when panned, cropped or resized in track motion.

Bi-Cubic/Integration - Best image resizing algorithm available in Vegas. Quality differences will be most noticeable when using very large stills or stretching small sources.

Bi-linear - Best compromise between speed and quality. This method will produce good results in most cases.

Point Sampling - Fast but produces poor results.

Field Handling:

This refers to the field conformance stage of Vegas's video engine. This includes Interlaced to Progressive conversion, Interlaced to interlaced output when scaling, motion or geometric Video FX and Transitions are involved. Skipping this stage can sometimes result in bad artifacts when high motion interlaced sources are used.

Field Rendering:

When the output format is interlaced, Vegas will internally render at the field rate (twice the frame rate) to achieve smooth motion and FX interpolation.

Frame Rate Resample:

This kicks in when speed changes are made through Velocity Envelopes and/or event stretching. In can also be used when up-converting low frame rate sources. This only kicks in if the resample switch is turned on and quality is set to good or best.

Interlace Flicker Reduction:

This kicks in if the event switch is turned on and quality is set to good or best. See Vegas' documentation for a description of this switch.