Reset Color Curves

OhMyGosh wrote on 7/17/2016, 8:10 PM
Must be getting rusty or something, but can't remember how to set the Color Curve FX back to it's original (pre mess with it state) setting! Also, to key frame you click on the 'animate' button, but when you want that to go away, what do you do? Sorry they are kinda lame questions, but didn't know where else to ask. Thanks. Cin


Chienworks wrote on 7/17/2016, 8:31 PM
Caveat: i'm still on versions 9/10, so it may have changed a bit in the version you're using ...

Reset color curves: click on the Preset: pull down menu and choose "Reset to None".

Get rid of Animate window: close the FX window, then reopen it.
OhMyGosh wrote on 7/18/2016, 12:23 AM
Great to see you are still here Chienworks, it's been a long time! :) I hope life has been going good for you. I rarely use VMS anymore and have downloaded the trial version of Vegas Pro 13, as I would like to get back to doing some video projects. A little nervous to say the least about the sell out of Sony. I thought like you, that there was the option of 'Reset to None', but I don't see it. I also closed out the FX window, which seemed like a lame thing to have to do, but it still comes back! Not that big of a deal I guess, but just annoying. I guess unless someone else has a better idea, I would have to delete the Color Curves FX, and then re add it to reset it to default, but that would border on plain stupid. Thanks for all your help now and over all the years. Hopefully I will 'see' more of you soon, as I'm sure I'll have lots more stupid questions as I try and figure this all out. :) Cin
john_dennis wrote on 7/18/2016, 2:35 AM
Vegas Pro 13 allows you the delete the keyframes all at once. Select the Color Curves keyframe timeline inside the Animate window, Strike Cntrl+A, Strike Delete, answer the message and let the coders know you are really serious. Gone.

OhMyGosh wrote on 7/18/2016, 9:52 AM
Wow, you hit that nail on the head John. Thanks. My mistake when trying to reset to original was that I clicked on 'Default' in the preset window, and not the drop down list. To get the keyframe window to disappear, I did as you said. My mistake there was that even though I didn't mean to keyframe that media, just by messing with it, it puts a keyframe at the very beginning! Thanks again for taking the time to help. Cin
john_dennis wrote on 7/18/2016, 10:34 AM
You're welcome. Every time I do one of these I learn something.
Chienworks wrote on 7/18/2016, 10:51 AM
There is always at least one keyframe, at the beginning. Sometimes it's only an "implied" keyframe, which contains the default values, and it's invisible. Whevever you make any adjustment a new keyframe is created to store these changes. It may be at the beginning and override the implied keyframe. You may click anywhere in the animate timeline and then when you make changes a new keyframe is created there.

If you have animation enabled, then moving the cursor on the editing timeline also moves the animation cursor, and a new keyframe is created. This has a couple of effects. 1) if you're expecting it, you can gradually and smoothly change the effects while the video is playing and see it in the preview window in real time. You'll accumulate a bunch of automatically generated keyframes to hold all the changes from frame to frame to frame. The other effect, 2) is that if you're not expecting it, you'll accumulate a bunch of automatically generated keyframes littering the animate timeline that you probably don't want, and may not know how they got there or possibly even notice, making you wonder why the image changes all on its own as the clip plays.
OhMyGosh wrote on 7/18/2016, 11:36 AM
Yes, it was the 'implied' keyframe that got me! Even if you don't make any changes, it's there and it doesn't go away unless you use John's tip. The program has crashed 3 times in the past hour just messing with things, so I think keyframes are about to be the least of my problems! :0
Thanks again. Cin